java 安装问题(新)

为当前最终发行版之前的所有版本提供支持
回复
adma
帖子: 2
注册时间: 2007-01-24 19:15
送出感谢: 0
接收感谢: 0

java 安装问题(新)

#1

帖子 adma » 2007-01-24 23:30

我执行:
liuliang@liuliang-laptop:/$ sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
sun-java5-jre: 依赖: sun-java5-bin (= 1.5.0-06-1) 但是它将不会被安装 或
ia32-sun-java5-bin (= 1.5.0-06-1) 但却无法安装它
E: 无法安装的软件包

然后有执行


liuliang@liuliang-laptop:/$ sudo update-alternatives --config java

There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
*+ 2 /usr/lib/jvm/java-gcj/jre/bin/java

Press enter to keep the default[*], or type selection number:
liuliang@liuliang-laptop:/$ sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
sun-java5-jre: 依赖: sun-java5-bin (= 1.5.0-06-1) 但是它将不会被安装 或
ia32-sun-java5-bin (= 1.5.0-06-1) 但却无法安装它
E: 无法安装的软件包


liuliang@liuliang-laptop:/$ sudo apt-get install sun-java5-bin
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
sun-java5-bin: 依赖: unixodbc 但却无法安装它
E: 无法安装的软件包



这是怎么回事阿?
该怎么办?谢谢
adma
帖子: 2
注册时间: 2007-01-24 19:15
送出感谢: 0
接收感谢: 0

终于被我搞定拉!!!!!!

#2

帖子 adma » 2007-01-25 0:23

:D 是原的问题!!
yangbing
帖子: 1
注册时间: 2006-12-30 10:33
送出感谢: 0
接收感谢: 0

#3

帖子 yangbing » 2007-01-27 14:12

我有类同的问题,希望高手解答
回复

回到 “老旧版本支持”