[问题]新内核不能启动

为当前最终发行版之前的所有版本提供支持
回复
xybds
帖子: 120
注册时间: 2006-05-29 14:09
送出感谢: 0
接收感谢: 0

[问题]新内核不能启动

#1

帖子 xybds » 2007-01-26 3:31

刚刚编译了kernel 2.6.19.2,开机选择新内核后,在waiting for root filesystem卡住。怎么办阿
实在不想再重来一遍。清大家帮忙看看
littleUbuntu
帖子: 1103
注册时间: 2006-10-19 9:02
送出感谢: 0
接收感谢: 0

#2

帖子 littleUbuntu » 2007-01-26 7:16

看样子是没有加入相关的硬盘驱动造成的,只能重新编译。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2007-01-26 8:37

系统都起不来,表示你编译的内核有问题啊.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
xybds
帖子: 120
注册时间: 2006-05-29 14:09
送出感谢: 0
接收感谢: 0

#4

帖子 xybds » 2007-01-26 11:28

找到原因了,没有加sata硬盘的支持 8)
头像
imlazy
帖子: 136
注册时间: 2006-10-29 10:49
来自: Shanghai, China
送出感谢: 0
接收感谢: 0

#5

帖子 imlazy » 2007-03-27 22:52

怎么加SATA硬盘的支持,讲一下。
我现在编译2.16.20.4的内核,也是卡在waiting for root filesystem。
能讲一下编译时要选哪些选项吗。
头像
imlazy
帖子: 136
注册时间: 2006-10-29 10:49
来自: Shanghai, China
送出感谢: 0
接收感谢: 0

#6

帖子 imlazy » 2007-03-28 19:10

能告诉我一下吗,SATA的选项我试了好多了,这两天内核编了不下10次。
头像
imlazy
帖子: 136
注册时间: 2006-10-29 10:49
来自: Shanghai, China
送出感谢: 0
接收感谢: 0

#7

帖子 imlazy » 2007-03-31 10:41

能告诉我直持SATA需要哪些选项吗。
在本本上编内核就是麻烦啊。
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#8

帖子 dogfox » 2007-03-31 12:43

lz是本本
不排除本本的硬件支持选项被你无视了
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
imlazy
帖子: 136
注册时间: 2006-10-29 10:49
来自: Shanghai, China
送出感谢: 0
接收感谢: 0

#9

帖子 imlazy » 2007-04-03 12:25

dogfox 写了:lz是本本
不排除本本的硬件支持选项被你无视了
请问您说的是哪些选项呢。能具体指出来吗。
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#10

帖子 dogfox » 2007-04-03 16:52

我记不清了
我在配置时一般都会去掉这些支持...
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
回复

回到 “老旧版本支持”