[问题]我照论坛里的教程装显卡驱动,装不了,求助!

为当前最终发行版之前的所有版本提供支持
carelan
帖子: 66
注册时间: 2006-12-10 17:21
送出感谢: 0
接收感谢: 0
联系:

[问题]我照论坛里的教程装显卡驱动,装不了,求助!

#1

帖子 carelan » 2007-01-28 1:53

我的CPU是闪龙3000+,显卡是nvida 7300GT的,
我照教程在http://www.nvidia.com/object/unix.html下载了个
NVIDIA-Linux-x86_64-1.0-9746-pkg2.run驱动,我也不知道驱动下载对了没有.....
然后我就注销,按Ctrl+Alt+F1,输入用户名和密码,登录后关闭gdm:
sudo /etc/init.d/gdm stop
我把NVIDIA-Linux-x86_64-1.0-9746-pkg2.run放在/home/carelan/目录下
然后我就
sudo sh /home/carelan/NVIDIA-Linux-x86_64-1.0-9746-pkg2.run
然后就提示我
SH: can't open NVIDIA-Linux-x86_64-1.0-9746-pkg2.run
装不了,请问一下我哪步出错了,或漏了哪步...

之前没有装过驱动
头像
NODandGDI
帖子: 57
注册时间: 2006-11-02 12:51
送出感谢: 0
接收感谢: 0

#2

帖子 NODandGDI » 2007-01-28 2:42

劝你用终端安装 sudo atp-get install nvidia-glx

如果升级驱动到1.0.9631加入源

deb http://www.albertomilone.com/drivers/ed ... gacy/32bit binary/

这个办法你要谢谢论坛中的 coffer 呵呵 祝你成功
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-01-28 10:57

2楼完全正确

coffer在论坛首发的,目前为止我认为是这样。


现在装n卡9631驱动最安全最放心的做法就是加coffer帖的那个源。出不了国找个代理也可。


楼主的做法可能是按照论坛上的一个回帖去做的,只是楼主还没开始运行那个run文件

运行肯定是可以的,这个我用过,不过运行后照有的办法不一定能装上

很多帖子中提到安装到是否上网选否就可以了
这个我试过,运行run文件是可以的,但装不进去,我还试过不同linux内核

如果非要要装,选yes才有可能,不过我不会再当小白了


记得 ee 好像 说过,直接 apt-get install 安装的N卡驱动要好得多,好像有一个一万美元的N卡驱动还没发布呢
no security measure is worth anything if an attacker has physical access to the machine
carelan
帖子: 66
注册时间: 2006-12-10 17:21
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 carelan » 2007-01-28 11:45

运行了第一条命令出现错误
carelan@carelan-desktop:~$ sudo atp-get install nvidia-glx
sudo: atp-get: command not found
carelan@carelan-desktop:~$
我也不知道之前装驱动搞了些什么...郁闷。
现在该怎么做了?麻烦了。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 skyx » 2007-01-28 11:49

apt ,有提示的,先潜一段时间水,多看置顶贴和wiki指南吧
no security measure is worth anything if an attacker has physical access to the machine
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 skyx » 2007-01-28 11:55

NODandGDI 写了:劝你用终端安装 sudo atp-get install nvidia-glx

二楼不小心:

应该是

sudo apt-get install nvidia-glx


成功后然后

代码: 全选

不清楚最好还是不要着急执行下面的指令,先提个醒,到时候可怪不得我

sudo nvidia-xconfig
no security measure is worth anything if an attacker has physical access to the machine
头像
NODandGDI
帖子: 57
注册时间: 2006-11-02 12:51
送出感谢: 0
接收感谢: 0

#7

帖子 NODandGDI » 2007-01-28 12:11

skyx 写了:
NODandGDI 写了:劝你用终端安装 sudo atp-get install nvidia-glx

二楼不小心:

应该是

sudo apt-get install nvidia-glx


成功后然后

代码: 全选

不清楚最好还是不要着急执行下面的指令,先提个醒,到时候可怪不得我

sudo nvidia-xconfig
谢谢6楼指出的错应该是 sudo apt-get install nvidia-glx (凌晨2点多回的帖子两眼有点打架)LZ不好意思 按照6楼进行基本安装 然后在升级.
ghost0
帖子: 364
注册时间: 2006-08-11 0:28
送出感谢: 0
接收感谢: 0

#8

帖子 ghost0 » 2007-01-28 15:35

应该是 sudo apt-get install linux-restricted-modules-$(uname -r) nvidia-glx 吧
光一个nvidia-glx不行的
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 skyx » 2007-01-28 16:18

ghost0 写了:应该是 sudo apt-get install linux-restricted-modules-$(uname -r) nvidia-glx 吧
光一个nvidia-glx不行的
把下面这个源加上

deb http://www.albertomilone.com/drivers/ed ... gacy/32bit binary/


sudo apt-get install nvidia-glx后

系统会自动把需要的一同带上的。

我前几天还装过的,在我的blog中有全程记录,

只有把上面的源加上才能搞定9631驱动,如果用其它的内地源,就算能成功装上驱动,也是8xxx版的驱动

搞不好还会进不了x .


这种情况(edgy)从2007年1月10日开始,到现在一直都是这个情况


dapper用什么源一直非常 稳定
no security measure is worth anything if an attacker has physical access to the machine
carelan
帖子: 66
注册时间: 2006-12-10 17:21
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 carelan » 2007-01-28 17:13

照楼上各位朋友的给出的命令,我想已经装上了,
但好像没什么不同。。
怎么知道自己是否装了驱动?
头像
felixlu
帖子: 311
注册时间: 2006-11-25 15:27
来自: SZ
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 felixlu » 2007-01-28 17:22

Ctrl+Alt+Backspace重启X的时候有没有看到nVIDIA的LOGO?有的话就是成功了。
另外也可以看看屏幕还闪不闪(CRT显示器),不闪就对了。
NoteBook: IBM X40 (1G Hz, 1.25GB, 20G+120GB)
Desktop: APU A6-3670, MSI A75A-G55, 4GB DDR3 1600 x 2
Slackware64 + Win7
carelan
帖子: 66
注册时间: 2006-12-10 17:21
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 carelan » 2007-01-28 17:33

。。。这个好像没有装驱动的时候就有了,屏幕一直以来都不闪,和在XP里面装了驱动的感觉一样。
在这里系统里面我啥驱动也没装过,一装好系统,声音有了,可以上网了,
不想XP里面,装了声卡驱动,网卡驱动才行。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#13

帖子 skyx » 2007-01-28 17:40

felixlu 写了:Ctrl+Alt+Backspace重启X的时候有没有看到nVIDIA的LOGO?有的话就是成功了。
另外也可以看看屏幕还闪不闪(CRT显示器),不闪就对了。
有没有装上的正解
如果屏保可用,说明3d也没问题、


听说最新内核直接支持nvidia显卡,我还不知道


一直都在等传说中的 一万美金的 N卡驱动
no security measure is worth anything if an attacker has physical access to the machine
carelan
帖子: 66
注册时间: 2006-12-10 17:21
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 carelan » 2007-01-28 18:48

好像还不行,我按了Ctrl+Alt+Backspace,没有看到LOGO,屏幕不闪是我把刷新率调到了85。
carelan@carelan-desktop:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
nvidia-glx 已经是最新的版本了。
The following packages were automatically installed and are no longer required:
libgnucrypto-java libcairo-java-gcj libbcprov-java-gcj libglib-java-gcj
bittornado liblog4j1.2-java libseda-java libgtk-java-gcj libcommons-cli-java
libgtk-jni libcairo-java libbcprov-java libglib-java libgtk-java
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
carelan@carelan-desktop:~$
这算完成了么?
还要执行什么步骤?
sammual
帖子: 16
注册时间: 2007-01-28 0:25
送出感谢: 0
接收感谢: 0

#15

帖子 sammual » 2007-01-29 12:28

每次都是这样,不知道哪里出错了

sammual@sammual-desktop:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
nvidia-glx: 依赖: nvidia-kernel-1.0.9631
E: 无法安装的软件包
回复

回到 “老旧版本支持”