[其它]求助,問個tar.gz的安裝問題。

为当前最终发行版之前的所有版本提供支持
回复
xiaoliu216
帖子: 8
注册时间: 2007-01-28 13:18
送出感谢: 0
接收感谢: 0

[其它]求助,問個tar.gz的安裝問題。

#1

帖子 xiaoliu216 » 2007-01-28 14:07

:cry: 一個簡單的安裝問題。
我想安裝glibc,到configure這一步的時候就進行不下去了。
出現這個錯誤
darkness@darkness-desktop:~/glibc-2.4$ ./configure --prefix=/usr/share
./configure: 100: cannot create conf10118.sh: Permission denied
./configure: 100: cannot create conf10118.sh: Permission denied
chmod: cannot access `conf10118.sh': No such file or directory
./configure: line 91: conf10118.sh: Permission denied
./configure: line 92: conf10118.sh: Permission denied
看起來是好像是權限地問題。
但如果我輸入sudo ./configure也是不行
darkness@darkness-desktop:~/glibc-2.4$ sudo ./configure --prefix=/usr/share
configure: error: you must configure in a separate build directory
這要我怎麽安裝呢??????
xiaoliu216
帖子: 8
注册时间: 2007-01-28 13:18
送出感谢: 0
接收感谢: 0

#2

帖子 xiaoliu216 » 2007-01-28 14:45

.........自己頂~~~~~~~~~~~
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 zhan » 2007-01-28 15:36

glibc 也敢自己安装 ...
这个还是用 源里面的吧。一个不好会使得你的几乎所有的软件都起不来的...
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
ilove3d
帖子: 24
注册时间: 2007-01-18 22:01
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 ilove3d » 2007-01-28 15:43

chmod 777 *
xiaoliu216
帖子: 8
注册时间: 2007-01-28 13:18
送出感谢: 0
接收感谢: 0

#5

帖子 xiaoliu216 » 2007-01-28 15:49

zhan 写了:glibc 也敢自己安装 ...
这个还是用 源里面的吧。一个不好会使得你的几乎所有的软件都起不来的...
我也不想阿,只是安裝軟件要用到新一點的版本阿
xiaoliu216
帖子: 8
注册时间: 2007-01-28 13:18
送出感谢: 0
接收感谢: 0

#6

帖子 xiaoliu216 » 2007-01-28 15:53

ilove3d 写了:chmod 777 *
多謝了,但是還不完全可以。
darkness@darkness-desktop:~/glibc-2.4$ ./configure --prefix=/usr/share
./configure: line 1029: config.log: Permission denied
這個又應該怎麽分權限???
可以說清楚點嗎???謝謝
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 zhan » 2007-01-28 16:10

既然不可避免要装的话,把那个 prefix 指定到其他的地方,不要和系统相关的地方,比如 /opt 等等,这样你用的那个软件也好指定 glibc 。

./configure 是不需要 sudo 的,这个有问题的话很是奇怪。可以根据提示看看 configure 文件 的那一行,还有那个 config.log 是怎么回事,它的权限。等等的
另外,把问题贴到 google 上看看..
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
xiaoliu216
帖子: 8
注册时间: 2007-01-28 13:18
送出感谢: 0
接收感谢: 0

#8

帖子 xiaoliu216 » 2007-01-28 16:56

zhan 写了:既然不可避免要装的话,把那个 prefix 指定到其他的地方,不要和系统相关的地方,比如 /opt 等等,这样你用的那个软件也好指定 glibc 。

./configure 是不需要 sudo 的,这个有问题的话很是奇怪。可以根据提示看看 configure 文件 的那一行,还有那个 config.log 是怎么回事,它的权限。等等的
另外,把问题贴到 google 上看看..
。。。。。謝謝。configure看還不是看得很懂。
來我還是去看看linux下文件權限的資料了
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2007-01-28 17:01

那解压的目录,是不是权限不对啊。别是sudo解压的吧。
glibc这样的东西最好别动。可能你就是非常熟悉编译了,也可能搞坏系统,因为你不一定熟悉ub的特殊规定。
● 鸣学
xiaoliu216
帖子: 8
注册时间: 2007-01-28 13:18
送出感谢: 0
接收感谢: 0

#10

帖子 xiaoliu216 » 2007-01-28 17:07

eexpress 写了:那解压的目录,是不是权限不对啊。别是sudo解压的吧。
glibc这样的东西最好别动。可能你就是非常熟悉编译了,也可能搞坏系统,因为你不一定熟悉ub的特殊规定。
。。。。。好像就是sudo解壓的。我再看看
回复

回到 “老旧版本支持”