[求助]这下真的搞不定了:D (edgy->feisty升级导致不能启动)

为当前最终发行版之前的所有版本提供支持
回复
头像
xrfang
帖子: 1116
注册时间: 2006-12-08 10:21
送出感谢: 0
接收感谢: 0

[求助]这下真的搞不定了:D (edgy->feisty升级导致不能启动)

#1

帖子 xrfang » 2007-01-28 15:21

看到feisty的一些截图,一时手痒,决定升级,还好没有在我的笔记本上搞。现在把我的台式机搞死了。启动不起来,现象如下:

如果使用启动菜单中的Kernel 2.6.20-5-generic选项,则启动到下面这句就死掉了:
* Configuring network interfaces...

如果使用Kernel 2.6.16-10-generic则出现下面的错误信息:
Cannot open root device "UUID=b33dc...." or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

请问有经验的“乌友”如何解决这类启动不了的问题。多谢!
evamix
帖子: 7
注册时间: 2007-01-26 14:35
送出感谢: 0
接收感谢: 0

#2

帖子 evamix » 2007-01-28 15:34

我在dos启动grub.exe或用autoboot.bat引导loadlin.exe的方法安装也是
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
运行到这里就停了 :( ,帮顶
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-01-28 16:12

我曾从dapper 升级到feisty成功

从edgy升级到 feisty失败

linux和windows不一样的。

跨版本升级是个有风险的事情。

想尝鲜最好全新安装
no security measure is worth anything if an attacker has physical access to the machine
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-01-28 16:12

Please append a correct "root=" boot option
看menu.lst里面此内核部分的root写法。live cd 进去修改试试。
● 鸣学
weiboo
帖子: 19
注册时间: 2006-10-27 20:06
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 weiboo » 2007-01-28 16:19

升级成功失败主要是源的问题,如果原里的升级软件缺了,升级就会有问题;
我曾经用上交的源升级成功,用清的源华的升级也没有问题;
头像
xrfang
帖子: 1116
注册时间: 2006-12-08 10:21
送出感谢: 0
接收感谢: 0

#6

帖子 xrfang » 2007-01-28 16:35

我现在已经有了feisty iso文件了,重新安装,会不会把我机器上ext3分区里面的数据删除? :lol:
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2007-01-28 17:11

升级的时候小心点,把所有问题都解决了才重启.一定要多dist-upgrade几次,确保升级完成.升级有风险,但是一般也能够解决.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
xrfang
帖子: 1116
注册时间: 2006-12-08 10:21
送出感谢: 0
接收感谢: 0

#8

帖子 xrfang » 2007-01-28 19:29

karron 写了:升级的时候小心点,把所有问题都解决了才重启.一定要多dist-upgrade几次,确保升级完成.升级有风险,但是一般也能够解决.
后悔没有先到论坛讨教经验。现在只能去修理了。。。 :oops:
回复

回到 “老旧版本支持”