求助:sudo没用了!

为当前最终发行版之前的所有版本提供支持
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

求助:sudo没用了!

#1

帖子 woodandwood » 2007-01-29 17:01

如然发现,sudo用不起来了!
xxx@xxx-desktop:~$sudo
sudo: can't open /etc/sudoers: Permiission denied
重装sudo也还是这样,在输入sudo -h时倒是可以显示:
xxx@xxx-desktop:~$ sudo -h
usage: sudo -K | -L | -V | -h | -k | -l | -v
usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
{ -e file [...] | -i | -s | <command> }
这是为什么啊?请教达人!谢谢!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-01-29 17:33

是不是將sudoer的權限改過。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

#3

帖子 woodandwood » 2007-01-29 17:38

没有,啥也没动…… :(
头像
xrfang
帖子: 1116
注册时间: 2006-12-08 10:21
送出感谢: 0
接收感谢: 0

#4

帖子 xrfang » 2007-01-29 19:32

你看看你自己这个用户有没有管理用户的权限。系统上(除了root)是不是有2个以上的用户?有没有新加用户?确认用的是哪个用户。。。
hjoywl
帖子: 74
注册时间: 2007-01-28 20:19
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 hjoywl » 2007-01-29 22:27

try to use sudo -sh
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2007-01-29 22:32

列一下
/usr/bin/sudo

/etc/sudoers
的权限。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

#7

帖子 woodandwood » 2007-01-30 9:52

谢谢各位答疑解惑!

机器上除了root之外就一个用户,我一直都是用那个用户来做sudo操作的;

xxx@xxx-desktop:~$sudo -sh
sudo: please use single character options
sudo: can't open /etc/sudoers: Permission denied

-rwsr-xr-x 1 root root 93844 2006-05-17 16:41 /usr/bin/sudo
-r--r----- 1 root root 327 2007-01-24 16:31 /etc/sudoers
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

#8

帖子 woodandwood » 2007-01-30 10:00

另外,我的桌面也进不去了,启动时,在看到鼠标的那个圆圈出来后就没了,然后就是一些什么什么。。。[ok],直到
*Running local boot scripts (/etc/rc.local) [ok]
用Alt+F1进入到命令行,发现进程里面只有一个gdm,我看正常的机器里都是两个的,而且/var/lib/gdm里面没有东西,重装gdm也是一样,不知道这两者是不是有联系…… -_-''
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#9

帖子 yohu » 2007-01-30 10:32

试试这样:

1.用recovery模式启动。
2.

代码: 全选

cat /etc/sudoers
看看你的/etc/sudoers里面是否有这一段:

代码: 全选

root    ALL=(ALL) ALL
%admin ALL=(ALL) ALL
如果没有第二行,自己添加上去,注意先备份文件。

代码: 全选

cp /etc/sudoers /etc/sudoers.backup
vi /etc/sudoers
在root那一行下面添加:

代码: 全选

%admin ALL=(ALL) ALL
如果已经有了这行了,那么运行下面的命令:

代码: 全选

addgroup 你的用户名 admin
chmod 440 /etc/sudoers
然后重启看看。
拥有超级牛力的搜索引擎:
http://www.google.com/linux
http://www.google.com/
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

#10

帖子 woodandwood » 2007-01-30 11:03

果然是没有第二行……
照你的做了一遍,重起后运行sudo还是can't open /etc/sudoers: Permission denied
…… 很崩溃的说……
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#11

帖子 yohu » 2007-01-30 11:29

最后一步做了没?
拥有超级牛力的搜索引擎:
http://www.google.com/linux
http://www.google.com/
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

#12

帖子 woodandwood » 2007-01-30 12:01

做了,说我的用户已属于admin组了……
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#13

帖子 yohu » 2007-01-30 12:42

chmod那步呢?
看起来还是访问权限的问题,奇怪……
再不然

代码: 全选

chmod 666 /etc/sudoers
拥有超级牛力的搜索引擎:
http://www.google.com/linux
http://www.google.com/
woodandwood
帖子: 86
注册时间: 2006-07-21 16:15
送出感谢: 0
接收感谢: 0

#14

帖子 woodandwood » 2007-01-30 13:03

如果改成666的话,再运行sudo,就会有显示:
sudo:/etc/sudoers is mode 0666, should be 0440
后面的命令同样运行不起来
yohu
帖子: 955
注册时间: 2006-12-18 17:04
来自: 福建泉州
送出感谢: 0
接收感谢: 1 次

#15

帖子 yohu » 2007-01-30 13:08

晕,不好意思,呵呵,不知道原来这个东西必须是440,那就帮不上忙了。
最后可以试试,再修改/etc/sudoers
把%admin换成你的用户名,死马当活马医了,呵呵,再不行就没辙了。
拥有超级牛力的搜索引擎:
http://www.google.com/linux
http://www.google.com/
回复

回到 “老旧版本支持”