这回问题严重了,包依赖关系出错,不能用install -f更正了

为当前最终发行版之前的所有版本提供支持
回复
chensn
帖子: 21
注册时间: 2007-01-06 10:28
送出感谢: 0
接收感谢: 0

这回问题严重了,包依赖关系出错,不能用install -f更正了

#1

帖子 chensn » 2007-01-29 17:02

下列的软件包有不能满足的依赖关系:
cpp-4.1: 依赖: gcc-4.1-base (= 4.1.1-13ubuntu5) 但是 4.1.1-21ubuntu7 已经安装了
gcc-4.1: 依赖: gcc-4.1-base (= 4.1.1-13ubuntu5) 但是 4.1.1-21ubuntu7 已经安装了
libgcc1: 依赖: gcc-4.1-base (= 4.1.1-13ubuntu5) 但是 4.1.1-21ubuntu7 已经安装了
libstdc++6: 依赖: gcc-4.1-base (= 4.1.1-13ubuntu5) 但是 4.1.1-21ubuntu7 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系

看起来,原来有一些人包括我都有些误解,就是认为软件更新太慢。可是很多时候确实不是可以更新的。
要检查依赖关系的啊!
源里面的文件其实已经放进去了,但是如果新版本的软件使用的库,编译器更新了。则需要把这些库给,编译器升级。
或许对原来的程序会有影响吧,

重新装gcc-4.1-base (= 4.1.1-13ubuntu5)这个包因为这个错误没有消除,无法装
把gcc-4.1-base 4.1.1-21ubuntu7 卸载会出现一大堆的软件要卸掉。要疯了啊,这么长的一串。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-01-29 17:29

降級可以麽。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
chensn
帖子: 21
注册时间: 2007-01-06 10:28
送出感谢: 0
接收感谢: 0

已经解决

#3

帖子 chensn » 2007-01-29 17:31

您的系统里有 4 个(依赖关系)毁损的软件包!
请使用“Broken”过滤器定位它们。

不知道怎么用法,这几个要卸的话,一大堆都说是必须。

已经解决,在新立得里面翻了半天,有一个强制版本,把软件的版本给调回去了。
又学了一招 . 不过有那么多的依赖关系是=的软件包,是不太好随便升级啊
回复

回到 “老旧版本支持”