求救,编译错误,/bin/sh: gcc-3.4: command not found

为当前最终发行版之前的所有版本提供支持
回复
ksfwzrn
帖子: 21
注册时间: 2007-01-24 22:20
送出感谢: 0
接收感谢: 0

求救,编译错误,/bin/sh: gcc-3.4: command not found

#1

帖子 ksfwzrn » 2007-01-31 9:52

系统:ubuntu 5.10
目的:驱动intel 536ep软猫

ubuntu@ubuntu:~/Intel-536$ sudo make 536
请尝试执行‘uname --help’来获取更多信息。
Module precompile check
Current running kernel is: 2.6.12-9-386
/lib/modules... autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: 没有那个文件或目录
autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: 没有那个文件或目录
version.h matches running kernel
uname -r|grep "2.6" && \
cd coredrv && make 536core_26 && \
cp Intel536.ko .. && cd .. && \
strip --strip-debug Intel536.ko && \
exit; \
ls Intel536.ko >/dev/null 2>&1 || uname -r | grep "2.6" && echo "Failed to buil d driver" && exit; \
if [ ]; then \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_SOURCE_PATH= "PSTN_DEF=-DTARGET_SELA H -DTARGET_LINUX -DLINUX" 536core; \
else \
cd coredrv; make TARGET=TARGET_SELAH KERNEL_INCLUDES=/lib/modules/`uname -r`/bui ld/include \
"PSTN_DEF=-DTARGET_SELAH -DTARGET_LINUX -DLINUX" 536core; \
fi ; \
cp Intel536.o .. ; \
if [ -a /boot/vmlinuz.version.h ]; then \
cp /boot/vmlinuz.version.h /lib/modules/`uname -r`/build/include/linux/v ersion.h;\
fi
2.6.12-9-386
make[1]: Entering directory `/home/ubuntu/Intel-536/coredrv'
make -C /lib/modules/2.6.12-9-386/build SUBDIRS=/home/ubuntu/Intel-536/coredrv modules
/usr/src/linux-headers-2.6.12-9-386/scripts/gcc-version.sh: line 11: gcc-3.4: co mmand not found
/usr/src/linux-headers-2.6.12-9-386/scripts/gcc-version.sh: line 12: gcc-3.4: co mmand not found
make[2]: gcc-3.4:命令未找到
make[2]: Entering directory `/usr/src/linux-headers-2.6.12-9-386'
CC [M] /home/ubuntu/Intel-536/coredrv/coredrv.o
/bin/sh: gcc-3.4: command not found
make[3]: *** [/home/ubuntu/Intel-536/coredrv/coredrv.o] 错误 127
make[2]: *** [_module_/home/ubuntu/Intel-536/coredrv] 错误 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.12-9-386'
make[1]: *** [536core_26] 错误 2
make[1]: Leaving directory `/home/ubuntu/Intel-536/coredrv'
2.6.12-9-386
Failed to build driver
ubuntu@ubuntu:~/Intel-536$
vbarter
帖子: 60
注册时间: 2006-11-28 18:10
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 vbarter » 2007-01-31 10:33

gcc 没有?
回复

回到 “老旧版本支持”