ubuntu6.10安装nvidia驱动如何退出Xwindows?

为当前最终发行版之前的所有版本提供支持
回复
Zspider
帖子: 5
注册时间: 2007-02-02 19:41
送出感谢: 0
接收感谢: 0

ubuntu6.10安装nvidia驱动如何退出Xwindows?

#1

帖子 Zspider » 2007-02-02 19:55

先说说为什么不装apt里面的nvidia-glx,因为apt-get install nvidia-glx时出现了下述状况:
The following packages have unmet dependencies:
nvidia-glx: Depends: nvidia-kernel-1.0.9631
不管更改了哪个源都没有用,这是第一个问题

于是去官网下载了一个驱动文件NVIDIA-Linux-x86-1.0-9746-pkg1.run
运行sh NVIDIA-Linux-x86-1.0-9746-pkg1.run
系统提示要安装驱动必须退出X,可是不知道这个命令,于是google之后又百度,

先是只接重启进入recovery模式,重新安装,系统提示说运行级别最好在init 3,于是输入init 3后系统居然自动启动了X
@_@

后尝试在init 3下运用ctrl+alt+backspace组合键,也只是达到了重新启动X的效果,失败。

最后妄图修改inittab文件默认启动级别,但是在/etc/下根本找不到……

因此上来发文求教,还请高手多多指点!
主要问题有三:
1、6.10无法用apt安装nvidia-glx驱动的问题,如上述
2、ubuntu系统没有inittab文件?还是说改成了什么别的文件名隐藏在什么地方……
3、如何在启动X后退出之进入字符界面?(注意,必须退出X,而不是进入另一个字符界面的tty)

感谢赐教!!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-02-02 20:02

1.进入一个tty
2.登录。。
3.sudo /etc/init.d/gdm stop ...这样X就被××掉了
或者更暴力
sudo killall Xorg
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2007-02-02 20:05

最新驱动请添加这个源。。

# ATi & nVidia drivers Ubuntu packages
deb http://www.albertomilone.com/drivers/ed ... gacy/32bit binary/
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
Zspider
帖子: 5
注册时间: 2007-02-02 19:41
送出感谢: 0
接收感谢: 0

#4

帖子 Zspider » 2007-02-02 22:11

BigSnake.NET 写了:最新驱动请添加这个源。。

# ATi & nVidia drivers Ubuntu packages
deb http://www.albertomilone.com/drivers/ed ... gacy/32bit binary/



感谢!能够把X给关了,不过装完驱动就出问题了,装完当时能进X,重启就不行了,得再装一遍才能进。好像还是和那个nvidia-kernel有关。我自己再摸索摸索吧

另外楼上的给的源的网址貌似有点问题?怎么后面的“/32bit”与“binary/”间有个空格?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 BigSnake.NET » 2007-02-02 22:15

是有个空格的
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
Zspider
帖子: 5
注册时间: 2007-02-02 19:41
送出感谢: 0
接收感谢: 0

#6

帖子 Zspider » 2007-02-02 22:20

啊,谢~!果然是。不过我上那个网站看了一下,我应该用*/edgy/latest/*那个
回复

回到 “老旧版本支持”