求助ubuntu12..4编译问题:当做到make -j4后出现如下:

为当前最终发行版之前的所有版本提供支持
回复
Arctic_wang
帖子: 1
注册时间: 2013-01-23 9:49
系统: ubuntu
送出感谢: 0
接收感谢: 0

求助ubuntu12..4编译问题:当做到make -j4后出现如下:

#1

帖子 Arctic_wang » 2013-01-31 18:07

在android2.3.4编译的过程中出现如下的问题之后就运行不过去去了。
Install: out/host/linux-x86/framework/apicheck.jar
Install: out/host/linux-x86/framework/clearsilver.jar
Install: out/host/linux-x86/framework/droiddoc.jar
Install: out/host/linux-x86/lib/libneo_util.so
Install: out/host/linux-x86/lib/libneo_cs.so
Install: out/host/linux-x86/lib/libneo_cgi.so
Install: out/host/linux-x86/lib/libclearsilver-jni.so
Copying: out/target/common/obj/JAVA_LIBRARIES/core_intermediates/emma_out/lib/classes-jarjar.jar
Install: out/host/linux-x86/framework/dx.jar
Install: out/host/linux-x86/bin/dx
host C++: libutils <= frameworks/base/libs/utils/AssetDir.cpp
g++: –fpermissive:没有那个文件或目录
make: *** [out/host/linux-x86/obj/STATIC_LIBRARIES/libutils_intermediates/AssetDir.o] 错误 1
make: *** 正在删除文件“out/host/linux-x86/obj/STATIC_LIBRARIES/libutils_intermediates/AssetDir.o”
在网上搜了一些,但说gcc版本太高了,但我换了低版本的gcc-4.4.7还是出现如下问题,求高手帮助,感激不尽:请详细说明

找到了问题的解决的办法::

主要是把文件的
frameworks/base/libs/utils/Android.mk
LOCAL_CFLAGS += -DLIBUTILS_NATIVE=1 $(TOOL_CFLAGS) -fpermissive
那个 -fpermissive 前面的 "-" 是有问题的。。。换成用字母的 - ,再保存一下,
原来当初复制的时候出现的问题“-”是英文输入,而我用的是'-'中文输入,心里舒服多了。不过又出现了新的问题,简直就是个问题专业户
回复

回到 “老旧版本支持”