bash-shell挂载分区与设置用户ID的问题?

为当前最终发行版之前的所有版本提供支持
回复
hitcser01
帖子: 60
注册时间: 2012-08-18 18:33
送出感谢: 10 次
接收感谢: 0

bash-shell挂载分区与设置用户ID的问题?

#1

帖子 hitcser01 » 2013-02-17 22:15

打算修改~/.profile文件来实现自定义的启动项。
其中,有一个自动挂载windows分区的功能(不用劝我,就这么做吧,^_^)。但是现在不能实现功能呀~
-rwSr--r-- 1 root caiji 72 Feb 17 22:04 mymount.sh
//-----------------mymount.sh文件内容
mount sda1 /win/c
#......
//-----------------

~/.profile 中有 . ~/bin/mystartup.sh
~/bin/mystartup.sh 中有 ~/bin/mymount.sh

谢谢前辈和高手的指教!
遇到同样问题的朋友可以跟踪下菜鸟我在本帖的发言,可能会有相关情况的更多说明。o(∩∩)o
谢谢各位帮忙的朋友了!
头像
YeLee
论坛版主
帖子: 26408
注册时间: 2008-08-13 8:48
系统: Fundu i64
来自: 东海硇州,一双管钥。
送出感谢: 25 次
接收感谢: 307 次
联系:

Re: bash-shell挂载分区与设置用户ID的问题?

#2

帖子 YeLee » 2013-02-17 22:23

亲,自动加载用fstab啊,假如是加启动项目的话,直接把.desptop文件拷贝到autstart里面啊,跟着,我也不知道你究竟想干嘛了。 :em01 :em01 :em01
这些用户感谢了作者 YeLee 于这个帖子:
hitcser01 (2013-07-22 16:31)
评价: 3.7%
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关
hitcser01
帖子: 60
注册时间: 2012-08-18 18:33
送出感谢: 10 次
接收感谢: 0

Re: bash-shell挂载分区与设置用户ID的问题?

#3

帖子 hitcser01 » 2013-02-17 22:28

YeLee 写了:亲,自动加载用fstab啊,假如是加启动项目的话,直接把.desptop文件拷贝到autstart里面啊,跟着,我也不知道你究竟想干嘛了。 :em01 :em01 :em01
谢谢!
1.自动挂载,fstab尝试过网上的教程,都失败了,不想再这么折腾。mount命令能懂一点,想这么做。
2.启动项那个没看懂,菜鸟一只 :em04
主要是我想知道我这么做怎么没效果呢? :em06
遇到同样问题的朋友可以跟踪下菜鸟我在本帖的发言,可能会有相关情况的更多说明。o(∩∩)o
谢谢各位帮忙的朋友了!
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

Re: bash-shell挂载分区与设置用户ID的问题?

#4

帖子 cuihao » 2013-02-17 22:33

fstab怎么填失败了?
你那个脚本:

代码: 全选

mount sda1 /win/c
也不对额,至少是/dev/sda1吧。
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
hitcser01
帖子: 60
注册时间: 2012-08-18 18:33
送出感谢: 10 次
接收感谢: 0

Re: bash-shell挂载分区与设置用户ID的问题?

#5

帖子 hitcser01 » 2013-02-17 22:40

cuihao 写了:fstab怎么填失败了?
你那个脚本:

代码: 全选

mount sda1 /win/c
也不对额,至少是/dev/sda1吧。
fstab怎么失败不知道,反正是启动的时候提示错误,也没有深究。。。 :em06
然后按照提示修改后让然不行哦,很有道理。其他错误?
谢谢。
遇到同样问题的朋友可以跟踪下菜鸟我在本帖的发言,可能会有相关情况的更多说明。o(∩∩)o
谢谢各位帮忙的朋友了!
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

Re: bash-shell挂载分区与设置用户ID的问题?

#6

帖子 cuihao » 2013-02-17 22:45

我只能建议你回去试fstab。给你写了:

代码: 全选

/dev/sda1 /win/c ntfs(或者vfat) defaults 0 2
不用重启看,保存后直接:

代码: 全选

sudo mount /win/c
如果fstab写对了,那么就会正常挂载。否则回来贴错误。
这些用户感谢了作者 cuihao 于这个帖子:
hitcser01 (2013-02-17 22:55)
评价: 3.7%
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
头像
YeLee
论坛版主
帖子: 26408
注册时间: 2008-08-13 8:48
系统: Fundu i64
来自: 东海硇州,一双管钥。
送出感谢: 25 次
接收感谢: 307 次
联系:

Re: bash-shell挂载分区与设置用户ID的问题?

#7

帖子 YeLee » 2013-02-17 22:46

这些用户感谢了作者 YeLee 于这个帖子:
hitcser01 (2013-02-17 22:57)
评价: 3.7%
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关
hitcser01
帖子: 60
注册时间: 2012-08-18 18:33
送出感谢: 10 次
接收感谢: 0

Re: bash-shell挂载分区与设置用户ID的问题?

#8

帖子 hitcser01 » 2013-02-17 22:55

回6楼:谢谢,搞定了。不知道以前为什么老是错误。ubuntu启动LOGO转动的时候报错,提示取消挂载。。。好在现在搞定了。
其实我还是想知道我之前错在哪里了, :em05
//提示下比我还新的新手,
sudo vim /etc/fstab
添加(视情况变更):
/dev/sda1 /win/c ntfs(或者vfat) defaults 0 2

回7楼:谢谢,很好的东西,好好看看! :em11 :em11 :em11
遇到同样问题的朋友可以跟踪下菜鸟我在本帖的发言,可能会有相关情况的更多说明。o(∩∩)o
谢谢各位帮忙的朋友了!
回复

回到 “老旧版本支持”