求问为什么ub1210不能使用 squeeze-php54 源??

为当前最终发行版之前的所有版本提供支持
回复
yzhkpli
帖子: 113
注册时间: 2008-11-20 15:08
送出感谢: 0
接收感谢: 0

求问为什么ub1210不能使用 squeeze-php54 源??

#1

帖子 yzhkpli » 2013-02-24 16:16

ubuntu12.10 64位安装php54

参考 http://www.dotdeb.org/instructions/
sudo vim /etc/apt/sources.list.d/dotdeb.org.list
内容只有四行
deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all

deb http://packages.dotdeb.org squeeze-php54 all
deb-src http://packages.dotdeb.org squeeze-php54 all


执行 apt-get update返回是
...
Ign http://packages.dotdeb.org squeeze/all Translation-en_US
Ign http://packages.dotdeb.org squeeze/all Translation-en
Ign http://packages.dotdeb.org squeeze-php54/all Translation-en_US
Ign http://packages.dotdeb.org squeeze-php54/all Translation-en
Fetched 70.8 kB in 15s (4,450 B/s)
Reading package lists... Done
执行安装命令
yum2014@ubuntu:/etc/apt/sources.list.d$ sudo apt-get install php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5 : Depends: libapache2-mod-php5 (>= 5.4.11-1~dotdeb.0) but it is not going to be installed or
libapache2-mod-php5filter (>= 5.4.11-1~dotdeb.0) but it is not going to be installed or
php5-cgi (>= 5.4.11-1~dotdeb.0) but it is not going to be installed or
php5-fpm (>= 5.4.11-1~dotdeb.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



删掉后面两行即可安装成功。但是安装的是php-5.4.6.

求问为什么不能使用 squeeze-php54 源??

ps
http://packages.dotdeb.org/dists/squeez ... ary-amd64/
这里面都有那些 not going to be installed 的软件啊!
yzhkpli
帖子: 113
注册时间: 2008-11-20 15:08
送出感谢: 0
接收感谢: 0

Re: 求问为什么ub1210不能使用 squeeze-php54 源??

#2

帖子 yzhkpli » 2013-02-24 16:51

squeeze源是不是挂了。安装nginx-extras
sudo apt-get install nginx-extras

执行这个也报告
The following packages have unmet dependencies:
nginx-extras : Depends: perlapi-5.10.1 but it is not installable
Depends: libperl5.10 (>= 5.10.1) but it is not installable
E: Unable to correct problems, you have held broken packages.
回复

回到 “老旧版本支持”