当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 共享启用时要求安装 samba 但出错,如何解决啊?
帖子发表于 : 2013-02-26 22:08 

注册: 2013-02-26 22:05
帖子: 3
系统: ubuntu 12.04
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install samba


正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
samba : 依赖: samba-common (= 2:3.6.3-2ubuntu2) 但是 2:3.6.3-2ubuntu2.3 正要被安装
依赖: libwbclient0 (= 2:3.6.3-2ubuntu2) 但是 2:3.6.3-2ubuntu2.3 正要被安装
推荐: tdb-tools 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

怎么整啊?

然后我就装samba-common 也提 示不行
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
samba-common 已经是最新的版本了。
下列软件包是自动安装的并且现在不需要了:
python-mako brasero-common gir1.2-gst-plugins-base-0.10 libdiscid0
gir1.2-gstreamer-0.10 gir1.2-ubuntuoneui-3.0 libburn4 dvd+rw-tools
libquvi-scripts libgpod4 rhythmbox-data libdmapsharing-3.0-2
python-markupsafe libubuntuoneui-3.0-1 libgmime-2.6-0 growisofs
media-player-info libgpod-common libquvi7 libjte1 libisofs6
libmusicbrainz3-6
使用'apt-get autoremove'来卸载它们
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。

装 另外一个也一样。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 共享启用时要求安装 samba 但出错,如何解决啊?
帖子发表于 : 2013-02-27 14:13 
头像

注册: 2008-12-16 14:01
帖子: 1130
地址: 漂在江湖
送出感谢: 14
接收感谢: 13
试试
sudo apt-get install samba4


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 共享启用时要求安装 samba 但出错,如何解决啊?
帖子发表于 : 2013-02-27 15:37 

注册: 2013-02-26 22:05
帖子: 3
系统: ubuntu 12.04
送出感谢: 0 次
接收感谢: 0 次
男菜鸟 写道:
试试
sudo apt-get install samba4


还是不行哟!


正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
gir1.2-totem-1.0 python-mako brasero-common gir1.2-gst-plugins-base-0.10
libdiscid0 gir1.2-gstreamer-0.10 gir1.2-ubuntuoneui-3.0 libburn4
dvd+rw-tools libtotem-plparser17 totem-common libquvi-scripts libtotem0
libgpod4 rhythmbox-data libdmapsharing-3.0-2 python-markupsafe
libubuntuoneui-3.0-1 libgmime-2.6-0 growisofs media-player-info
libgpod-common libquvi7 libjte1 libisofs6 gir1.2-totem-plparser-1.0
libmusicbrainz3-6
使用'apt-get autoremove'来卸载它们
将会安装下列额外的软件包:
attr bind9utils ldb-tools libdcerpc-server0 libdcerpc0 libgensec0
libhdb9-heimdal libkdc2-heimdal libldb1 libndr-standard0 libndr0
libregistry0 libsamba-credentials0 libsamba-hostconfig0 libsamba-policy0
libsamba-util0 libsamdb0 libsmbclient-raw0 libtevent0 python-dnspython
python-ldb python-samba python-talloc python-tdb samba-dsdb-modules
samba4-common-bin tdb-tools
建议安装的软件包:
phpldapadmin samba-gtk swat2
推荐安装的软件包:
bind9
下列【新】软件包将被安装:
attr bind9utils ldb-tools libdcerpc-server0 libdcerpc0 libgensec0
libhdb9-heimdal libkdc2-heimdal libldb1 libndr-standard0 libndr0
libregistry0 libsamba-credentials0 libsamba-hostconfig0 libsamba-policy0
libsamba-util0 libsamdb0 libsmbclient-raw0 libtevent0 python-dnspython
python-ldb python-samba python-talloc python-tdb samba-dsdb-modules samba4
samba4-common-bin tdb-tools
升级了 0 个软件包,新安装了 28 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 8,050 kB 的软件包。
解压缩后会消耗掉 37.4 MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://mirrors.163.com/ubuntu/ precise/main libhdb9-heimdal i386 1.6~git20120311.dfsg.1-2 [67.2 kB]
获取:2 http://mirrors.163.com/ubuntu/ precise/universe libtevent0 i386 0.9.15-2 [26.5 kB]
获取:3 http://mirrors.163.com/ubuntu/ precise/universe libldb1 i386 1:1.1.4-1 [136 kB]
获取:4 http://mirrors.163.com/ubuntu/ precise/universe libsamba-util0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [231 kB]
获取:5 http://mirrors.163.com/ubuntu/ precise/universe libndr0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [37.1 kB]
获取:6 http://mirrors.163.com/ubuntu/ precise/universe libndr-standard0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [1,676 kB]
获取:7 http://mirrors.163.com/ubuntu/ precise/universe libsamba-hostconfig0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [56.2 kB]
获取:8 http://mirrors.163.com/ubuntu/ precise/universe libsamba-credentials0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [29.0 kB]
获取:9 http://mirrors.163.com/ubuntu/ precise/universe libsamdb0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [132 kB]
获取:10 http://mirrors.163.com/ubuntu/ precise/universe libgensec0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [251 kB]
获取:11 http://mirrors.163.com/ubuntu/ precise/universe libsmbclient-raw0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [556 kB]
获取:12 http://mirrors.163.com/ubuntu/ precise/main python-talloc i386 2.0.7-3 [7,002 B]
获取:13 http://mirrors.163.com/ubuntu/ precise/universe libdcerpc0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [557 kB]
获取:14 http://mirrors.163.com/ubuntu/ precise/universe libregistry0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [53.6 kB]
获取:15 http://mirrors.163.com/ubuntu/ precise/universe libdcerpc-server0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [336 kB]
获取:16 http://mirrors.163.com/ubuntu/ precise/universe libsamba-policy0 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [23.2 kB]
获取:17 http://mirrors.163.com/ubuntu/ precise/universe python-ldb i386 1:1.1.4-1 [31.8 kB]
获取:18 http://mirrors.163.com/ubuntu/ precise/main libkdc2-heimdal i386 1.6~git20120311.dfsg.1-2 [63.2 kB]
获取:19 http://mirrors.163.com/ubuntu/ precise/main attr i386 1:2.4.46-5ubuntu1 [28.7 kB]
获取:20 http://mirrors.163.com/ubuntu/ precise/main bind9utils i386 1:9.8.1.dfsg.P1-4 [105 kB]
获取:21 http://mirrors.163.com/ubuntu/ precise/universe ldb-tools i386 1:1.1.4-1 [33.1 kB]
获取:22 http://mirrors.163.com/ubuntu/ precise/main python-dnspython all 1.9.4-0ubuntu3 [99.2 kB]
获取:23 http://mirrors.163.com/ubuntu/ precise/main python-tdb i386 1.2.9-4 [10.6 kB]
获取:24 http://mirrors.163.com/ubuntu/ precise/universe python-samba i386 4.0.0~alpha18.dfsg1-4ubuntu2 [1,545 kB]
获取:25 http://mirrors.163.com/ubuntu/ precise/universe samba-dsdb-modules i386 4.0.0~alpha18.dfsg1-4ubuntu2 [261 kB]
获取:26 http://mirrors.163.com/ubuntu/ precise/universe samba4-common-bin i386 4.0.0~alpha18.dfsg1-4ubuntu2 [25.4 kB]
获取:27 http://mirrors.163.com/ubuntu/ precise/main tdb-tools i386 1.2.9-4 [22.8 kB]
获取:28 http://mirrors.163.com/ubuntu/ precise/universe samba4 i386 4.0.0~alpha18.dfsg1-4ubuntu2 [1,649 kB]
下载 8,050 kB,耗时 15秒 (510 kB/s)
正在预设定软件包 ...
/tmp/samba4.config.36821: 1: /tmp/samba4.config.36821: samba-tool: not found
/tmp/samba4.config.36821: 1: /tmp/samba4.config.36821: samba-tool: not found
Selecting previously unselected package libhdb9-heimdal.
(正在读取数据库 ... 系统当前共安装有 144014 个文件和目录。)
正在解压缩 libhdb9-heimdal (从 .../libhdb9-heimdal_1.6~git20120311.dfsg.1-2_i386.deb) ...
Selecting previously unselected package libtevent0.
正在解压缩 libtevent0 (从 .../libtevent0_0.9.15-2_i386.deb) ...
Selecting previously unselected package libldb1.
正在解压缩 libldb1 (从 .../libldb1_1%3a1.1.4-1_i386.deb) ...
Selecting previously unselected package libsamba-util0.
正在解压缩 libsamba-util0 (从 .../libsamba-util0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libndr0.
正在解压缩 libndr0 (从 .../libndr0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libndr-standard0.
正在解压缩 libndr-standard0 (从 .../libndr-standard0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libsamba-hostconfig0.
正在解压缩 libsamba-hostconfig0 (从 .../libsamba-hostconfig0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libsamba-credentials0.
正在解压缩 libsamba-credentials0 (从 .../libsamba-credentials0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libsamdb0.
正在解压缩 libsamdb0 (从 .../libsamdb0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libgensec0.
正在解压缩 libgensec0 (从 .../libgensec0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libsmbclient-raw0.
正在解压缩 libsmbclient-raw0 (从 .../libsmbclient-raw0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package python-talloc.
正在解压缩 python-talloc (从 .../python-talloc_2.0.7-3_i386.deb) ...
Selecting previously unselected package libdcerpc0.
正在解压缩 libdcerpc0 (从 .../libdcerpc0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libregistry0.
正在解压缩 libregistry0 (从 .../libregistry0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libdcerpc-server0.
正在解压缩 libdcerpc-server0 (从 .../libdcerpc-server0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package libsamba-policy0.
正在解压缩 libsamba-policy0 (从 .../libsamba-policy0_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package python-ldb.
正在解压缩 python-ldb (从 .../python-ldb_1%3a1.1.4-1_i386.deb) ...
Selecting previously unselected package libkdc2-heimdal.
正在解压缩 libkdc2-heimdal (从 .../libkdc2-heimdal_1.6~git20120311.dfsg.1-2_i386.deb) ...
Selecting previously unselected package attr.
正在解压缩 attr (从 .../attr_1%3a2.4.46-5ubuntu1_i386.deb) ...
Selecting previously unselected package bind9utils.
正在解压缩 bind9utils (从 .../bind9utils_1%3a9.8.1.dfsg.P1-4_i386.deb) ...
Selecting previously unselected package ldb-tools.
正在解压缩 ldb-tools (从 .../ldb-tools_1%3a1.1.4-1_i386.deb) ...
Selecting previously unselected package python-dnspython.
正在解压缩 python-dnspython (从 .../python-dnspython_1.9.4-0ubuntu3_all.deb) ...
Selecting previously unselected package python-tdb.
正在解压缩 python-tdb (从 .../python-tdb_1.2.9-4_i386.deb) ...
Selecting previously unselected package python-samba.
正在解压缩 python-samba (从 .../python-samba_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package samba-dsdb-modules.
正在解压缩 samba-dsdb-modules (从 .../samba-dsdb-modules_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package samba4-common-bin.
正在解压缩 samba4-common-bin (从 .../samba4-common-bin_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
Selecting previously unselected package tdb-tools.
正在解压缩 tdb-tools (从 .../tdb-tools_1.2.9-4_i386.deb) ...
Selecting previously unselected package samba4.
正在解压缩 samba4 (从 .../samba4_4.0.0~alpha18.dfsg1-4ubuntu2_i386.deb) ...
正在处理用于 man-db 的触发器...
正在处理用于 ureadahead 的触发器...
ureadahead will be reprofiled on next reboot
正在设置 libhdb9-heimdal (1.6~git20120311.dfsg.1-2) ...
正在设置 libtevent0 (0.9.15-2) ...
正在设置 libldb1 (1:1.1.4-1) ...
正在设置 libsamba-util0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libndr0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libndr-standard0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libsamba-hostconfig0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libsamba-credentials0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libsamdb0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libgensec0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libsmbclient-raw0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 python-talloc (2.0.7-3) ...
正在设置 libdcerpc0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libregistry0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libdcerpc-server0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 libsamba-policy0 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 python-ldb (1:1.1.4-1) ...
正在设置 libkdc2-heimdal (1.6~git20120311.dfsg.1-2) ...
正在设置 attr (1:2.4.46-5ubuntu1) ...
正在设置 bind9utils (1:9.8.1.dfsg.P1-4) ...
正在设置 ldb-tools (1:1.1.4-1) ...
正在设置 python-dnspython (1.9.4-0ubuntu3) ...
正在设置 python-tdb (1.2.9-4) ...
正在设置 python-samba (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 samba-dsdb-modules (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 samba4-common-bin (4.0.0~alpha18.dfsg1-4ubuntu2) ...
正在设置 tdb-tools (1.2.9-4) ...
update-alternatives: 使用 /usr/bin/tdbbackup.tdbtools 来提供 /usr/bin/tdbbackup (tdbbackup),于 自动模式 中。
正在设置 samba4 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
ERROR: Invalid smb.conf
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
ERROR: Invalid smb.conf
/var/lib/dpkg/info/samba4.postinst: 14: /var/lib/dpkg/info/samba4.postinst: /usr/share/samba/setoption.pl: Permission denied
dpkg:处理 samba4 (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 126
正在处理用于 libc-bin 的触发器...
由于已经达到 MaxReports 限制,没有写入 apport 报告。
ldconfig deferred processing now taking place
在处理时有错误发生:
samba4
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译