求助 猫驱动程序打包的问题

为当前最终发行版之前的所有版本提供支持
回复
luqiyihui
帖子: 64
注册时间: 2012-12-26 20:32
送出感谢: 5 次
接收感谢: 0

求助 猫驱动程序打包的问题

#1

帖子 luqiyihui » 2013-02-27 15:30

thinkpad X200本子 的猫驱动能找到ubnuntu8.04版,网站提供最后支持到9.04版的驱动,问题是我现在系统装的是12.04,安装过程后显示 如下:

1、安装8.04版的驱动后终端显示:

luqi@ubuntu:~/下载$ sudo dpkg -i hsf*.deb
Selecting previously unselected package hsfmodem:i386.
(正在读取数据库 ... 系统当前共安装有 250609 个文件和目录。)
正在解压缩 hsfmodem:i386 (从 hsfmodem_7.68.00.14full_i386.deb) ...
Removing old /etc/hsfmodem
Removing old /usr/lib/hsfmodem
正在设置 hsfmodem:i386 (7.68.00.14full) ...
Conexant HSF softmodem driver, version 7.68.00.14full

If you need license keys, assistance or more information, please go to:
http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Ubuntu-12.04.2 linux-3.2.0-38-generic x86_64-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

WARNING: missing file /lib/modules/3.2.0-38-generic/build/include/linux/autoconf.h
The cause of this is usually a missing or unconfigured
kernel source tree (and sometimes an incorrect directory or symbolic link).

However, proper /boot/config-3.2.0-38-generic was found.

Unable to prepare temporary kernel tree

First, ensure that the proper kernel source and compiler packages
from your distribution vendor and/or the community are installed.

The Linux kernel can then be reconfigured by running "make menuconfig"
under the kernel source directory (usually /usr/src/linux).

Verify that the proper options for your system are selected.

Then compile and install your new kernel (for more information about
this procedure, see the README file under the kernel source directory),
reboot the system using the new kernel, and re-run "hsfconfig".


2、安装9.04版的驱动后显示如下:

luqi@ubuntu:~/下载$ sudo dpkg -i hsfmodem_7.80.02.06full_k2.6.31_17_generic_ubuntu_i386.deb
(正在读取数据库 ... 系统当前共安装有 252592 个文件和目录。)
正预备替换 hsfmodem:i386 7.68.00.14full (使用 hsfmodem_7.80.02.06full_k2.6.31_17_generic_ubuntu_i386.deb) ...
Warning: Module snd_hda_intel is in use
Warning: Module snd_hda_codec is in use by snd_hda_intel,snd_hda_codec_conexant
Sending TERM signal to processes still using the driver:
PID USER COMMAND
5104 luqi /usr/bin/pulseaudio --start --log-target=syslog
Warning: Module snd_hda_codec is in use by snd_hda_codec_conexant
Warning: Module snd_hda_codec is in use by snd_hda_codec_conexant
Warning: Module snd_hda_codec is in use by snd_hda_codec_conexant
Warning: Module snd_hda_codec is in use by snd_hda_codec_conexant
Warning: Module snd_hda_codec is in use by snd_hda_codec_conexant
正在解压缩将用于更替的包文件 hsfmodem:i386 ...
正在设置 hsfmodem:i386 (7.80.02.06full-k2.6.31-17-generic-1.ubuntu) ...
Conexant HSF softmodem driver, version 7.80.02.06full

If you need license keys, assistance or more information, please go to:
http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: Ubuntu-12.04.2 linux-3.2.0-38-generic x86_64-SMP

Please obtain the appropriate variant of this package for your system
or try the generic DEB or tar version.

是不是我 的系统版本太高了,驱动已经不支持,那有没有办法自己重新打包到12.04系统下驱动呢?有达人能指点下吗???
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

Re: 求助 猫驱动程序打包的问题

#2

帖子 luojie-dune » 2013-02-27 15:52

那个。可能吧。直接买个外置猫好了 30元+,或者设置好FAX,直接网络接收。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
luqiyihui
帖子: 64
注册时间: 2012-12-26 20:32
送出感谢: 5 次
接收感谢: 0

Re: 求助 猫驱动程序打包的问题

#3

帖子 luqiyihui » 2013-02-27 16:01

谢谢2楼的建议,办公室买了HP一体机。只是最近一直在折腾Ubuntu,所以就把之前没有解决的问题拿出来捣腾下,因为比较菜,所以向网友寻求帮助!
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 求助 猫驱动程序打包的问题

#4

帖子 AutoXBC » 2013-02-27 20:08

提示没有预编译内核模块,需要开发环境来编译一个,然后提示缺少相关的工具,那就先把这个开发包装上,然后再尝试一次。

代码: 全选

sudo apt-get install build-essential
回复

回到 “老旧版本支持”