关于ctags的使用出现了问题,求帮助

为当前最终发行版之前的所有版本提供支持
回复
zero_hsy
帖子: 37
注册时间: 2013-03-03 10:45
系统: ubuntu
送出感谢: 8 次
接收感谢: 0

关于ctags的使用出现了问题,求帮助

#1

帖子 zero_hsy » 2013-03-03 10:59

大家好,我刚刚用linxu,有问题想请教大家:网上查了ctags,想试一下它的功能,可是我输入 :~/zwjzgx$ ctags -R*
跳出来: 程序 'ctags' 已包含在下列软件包中:
* exuberant-ctags
* elvis-tools (You will have to enable component called 'universe')
请尝试:sudo apt-get install <选定的软件包>

想问一下什么原因,不明白啊!
头像
YeLee
论坛版主
帖子: 26408
注册时间: 2008-08-13 8:48
系统: Fundu i64
来自: 东海硇州,一双管钥。
送出感谢: 25 次
接收感谢: 307 次
联系:

Re: 关于ctags的使用出现了问题,求帮助

#2

帖子 YeLee » 2013-03-03 11:06

请尝试:sudo apt-get install <选定的软件包>
:em01 :em01 :em01
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 关于ctags的使用出现了问题,求帮助

#3

帖子 lainme » 2013-03-03 13:48

你没装ctags,当然用不了。看提示

sudo apt-get install exuberant-ctags
zero_hsy
帖子: 37
注册时间: 2013-03-03 10:45
系统: ubuntu
送出感谢: 8 次
接收感谢: 0

Re: 关于ctags的使用出现了问题,求帮助

#4

帖子 zero_hsy » 2013-03-03 18:07

我敲了命令行:sudo apt-get install exuberant-ctags
显示为:
正在处理用于 man-db 的触发器...
正在设置 exuberant-ctags (1:5.9~svn20110310-3) ...
update-alternatives: 错误: 无 ctags 的候选项。
update-alternatives: 使用 /usr/bin/ctags-exuberant 来提供 /usr/bin/ctags (ctags),于 自动模式 中。
update-alternatives: 错误: 无 etags 的候选项。
update-alternatives: 使用 /usr/bin/ctags-exuberant 来提供 /usr/bin/etags (etags),于 自动模式 中。

怎么解决啊??
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 关于ctags的使用出现了问题,求帮助

#5

帖子 lainme » 2013-03-03 18:38

这个应该没问题吧。你试下的ctags 命令能用不
zero_hsy
帖子: 37
注册时间: 2013-03-03 10:45
系统: ubuntu
送出感谢: 8 次
接收感谢: 0

Re: 关于ctags的使用出现了问题,求帮助

#6

帖子 zero_hsy » 2013-03-03 20:22

恩,我找到了,生成了tag文件,但是我在命令行中输入:vim -t result(result是一个c代码中的一个变量),结果:进入了vim后跳出:E426: 找不到 tag: result
这是为什么啊? 还有ctag用来浏览代码,真的在现实生活中常用吗?
头像
zhw2101024
帖子: 1849
注册时间: 2009-03-28 16:10
系统: Arch debian win7
送出感谢: 9 次
接收感谢: 70 次
联系:

Re: 关于ctags的使用出现了问题,求帮助

#7

帖子 zhw2101024 » 2013-03-05 10:06

现实生活中用不到,编程专用
回复

回到 “老旧版本支持”