请教一个关于 安装 Vim的问题

为当前最终发行版之前的所有版本提供支持
回复
GalaxySky
帖子: 9
注册时间: 2013-01-31 15:52
系统: Arch
送出感谢: 0
接收感谢: 0

请教一个关于 安装 Vim的问题

#1

帖子 GalaxySky » 2013-03-09 19:22

请教一个问题,下面的三个命令都可以安装vim.这三个命令在安装vim的细节上有什么区别吗?

sudo apt-get install vim-full

sudo apt-get install vim-gtk

sudo apt-get install vim-gnome
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 请教一个关于 安装 Vim的问题

#2

帖子 lainme » 2013-03-09 19:31

按不同编译选项编译的vim。话说已经没有vim-full了吧。vim-gtk和vim-gnome具体区别不知道,但应该差不了太多,装哪个都行吧。
头像
YeLee
论坛版主
帖子: 26408
注册时间: 2008-08-13 8:48
系统: Fundu i64
来自: 东海硇州,一双管钥。
送出感谢: 25 次
接收感谢: 307 次
联系:

Re: 请教一个关于 安装 Vim的问题

#3

帖子 YeLee » 2013-03-09 19:42

gnome版本提供会话管理器的交互功能吧,用户在退出当前会话的时候,Vim会检查并弹出询问窗口的,听说这货的工具栏还可以移动至不同的地方喔,当然,功能跟速度是反比的,只是这速度的区别人类很难感觉到而已。
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关
GalaxySky
帖子: 9
注册时间: 2013-01-31 15:52
系统: Arch
送出感谢: 0
接收感谢: 0

Re: 请教一个关于 安装 Vim的问题

#4

帖子 GalaxySky » 2013-03-09 19:46

lainme 写了:按不同编译选项编译的vim。话说已经没有vim-full了吧。vim-gtk和vim-gnome具体区别不知道,但应该差不了太多,装哪个都行吧。
嗯,多谢了,了解了。
GalaxySky
帖子: 9
注册时间: 2013-01-31 15:52
系统: Arch
送出感谢: 0
接收感谢: 0

Re: 请教一个关于 安装 Vim的问题

#5

帖子 GalaxySky » 2013-03-09 19:47

YeLee 写了:gnome版本提供会话管理器的交互功能吧,用户在退出当前会话的时候,Vim会检查并弹出询问窗口的,听说这货的工具栏还可以移动至不同的地方喔,当然,功能跟速度是反比的,只是这速度的区别人类很难感觉到而已。
嗯,多谢了,了解了。
头像
b33e
论坛版主
帖子: 3866
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: 请教一个关于 安装 Vim的问题

#6

帖子 b33e » 2013-03-10 0:27

安装vim-gnome会包含vim-gtk的安装 :em01
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

Re: 请教一个关于 安装 Vim的问题

#7

帖子 sanz » 2013-03-11 10:23

缺别就是只有装了那个,才能用系统粘贴板。("+y / "+p)
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
回复

回到 “老旧版本支持”