在linux下安装软件,显示有些软件包不能通过验证,什么意思

为当前最终发行版之前的所有版本提供支持
回复
zero_hsy
帖子: 37
注册时间: 2013-03-03 10:45
系统: ubuntu
送出感谢: 8 次
接收感谢: 0

在linux下安装软件,显示有些软件包不能通过验证,什么意思

#1

帖子 zero_hsy » 2013-03-09 20:06

大家好,我是新手,在linux下安装软件,结果出现了:有些软件包不能通过验证,是不是最好不要在继续安装下去?还有如果安装了有什么不好的结果?为什么会出现这样的事情?求帮助,谢谢!!!
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 在linux下安装软件,显示有些软件包不能通过验证,什么意思

#2

帖子 lainme » 2013-03-09 20:13

没有加签名?如果你信任来源也可以装。
zero_hsy
帖子: 37
注册时间: 2013-03-03 10:45
系统: ubuntu
送出感谢: 8 次
接收感谢: 0

Re: 在linux下安装软件,显示有些软件包不能通过验证,什么意思

#3

帖子 zero_hsy » 2013-03-09 20:27

可是怎么才能信任来源,有什么方法可以查看来源是否值得信赖?还有如果不不知道信不信任,装了会有什么结果?
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 在linux下安装软件,显示有些软件包不能通过验证,什么意思

#4

帖子 lainme » 2013-03-09 22:21

我说信任来源,是指你自己信不信任它。包管理器的,你想 yes 继续也行,多数情况应该没事。

apt装软件会验证数字签名的,通过了就是信任。不信任的原因,可能没数字签名,可能软件列表有问题等。

先刷新软件列表看看,如果还出现,可以考虑把/var/lib/apt/lists/下的文件都删掉再试
回复

回到 “老旧版本支持”