Help~~~系统无法安装和卸载软件

为当前最终发行版之前的所有版本提供支持
回复
Vsmi2013
帖子: 2
注册时间: 2013-03-11 14:28
系统: ubuntu
送出感谢: 0
接收感谢: 0

Help~~~系统无法安装和卸载软件

#1

帖子 Vsmi2013 » 2013-03-11 14:37

如题 在卸载或者安装软件的时候会提示如错误:E: Sub-process /usr/bin/dpkg returned an error code (1) ,使用 sudo apt-get -f install 命令的详细信息如下:
root@garyshi:~sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
升级了 0 个软件包,新安装了 0 个软件包, 要卸载 0 个软件包,有 0 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0 B/8,740 kB 的软件包。
解压缩后会消耗掉 0 B 的额外空间。
dpkg: error processing mysql-server-5.5 (--configure):
现在尚不能配置软件包 mysql-server-5.5
不能配置(目前状态为 half-installed )
在处理时有错误发生:
mysql-server-5.5
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@garyshi:~#

我是新手,请教各位高手。谢谢
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: Help~~~系统无法安装和卸载软件

#2

帖子 eexpress » 2013-03-11 14:46

强制卸载这软件先。
安装/更新前,先update源的软件列表。
● 鸣学
回复

回到 “老旧版本支持”