当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [帮帮忙]更新后的疑惑
帖子发表于 : 2007-02-05 1:49 

注册: 2006-08-29 23:08
帖子: 210
地址: 广东茂名
送出感谢: 0 次
接收感谢: 0 次
更新系统后,遇到如下问题,请问:这该怎么办?

1、更新过程:

1)我用下列命令更新系统
sudo aptitude update && sudo aptitude dist-upgrade

2)结果是:

下列软件包是“破损”的:
libcairo2

下列软件包将被升级:
app-install-data-commercial gtk2-engines-pixbuf libc6 libc6-dev
libc6-i686 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common synaptic
10 个软件包被升级,新安装 0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 15.7MB 的存档。 解包后将释放 12.3kB。
下列软件包存在未满足的依赖关系:
libcairo2: 依赖: libfreetype6 (>= 2.2) 但是 2.1.10-1ubuntu2.2 已安装。

Resolving dependencies...
下列动作将解决这些依赖关系:

保持 下列软件包于其当前版本:
libcairo2 [1.0.4-0ubuntu1 (dapper, dapper, dapper, dapper, dapper, now)]

分数是 0

是否接受该解决方案?[Y/n/q/?] y
警告:您将安装以下软件包的不可信版本!

不可信的软件可能会危害您的系统安全。
只有当您非常清楚地了解这就是您所要执行的操作时,才应该进行安装操作。

libc6-i686 synaptic libc6-dev libc6 app-install-data-commercial

您想忽略这条警告信息并继续执行吗?
要继续,请键入“是”;要中止,请键入“否”: 是
下列软件包已经被阻止升级:
libcairo2

下列软件包将被升级:
app-install-data-commercial gtk2-engines-pixbuf libc6 libc6-dev
libc6-i686 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common synaptic
9 个软件包被升级,新安装 0 个, 0 个将被删除, 同时 1 个将不升级。
需要获取 15.4MB 的存档。 解包后将要使用 4096B。
您要继续吗?[Y/n/?] y
警告:您将安装以下软件包的不可信版本!

不可信的软件可能会危害您的系统安全。
只有当您非常清楚地了解这就是您所要执行的操作时,才应该进行安装操作。

libc6-i686 synaptic libc6-dev libc6 app-install-data-commercial

您想忽略这条警告信息并继续执行吗?
要继续,请键入“是”;要中止,请键入“否”: 是
正在编辑扩展状态信息... 完成



2、对结果的不解:

(1)下列软件包是“破损”的:
libcairo2


破损,就应该重装吧,而在新立得里面,我看到已安装的版本是1.0.4-0ubuntu1,而最新的版本是1.2.2-0ubuntu2

但是,为什么要

下列软件包已经被阻止升级:
libcairo2


问:我可不可以升级它,升级会有什么后果吗??


(2)下列软件包存在未满足的依赖关系:
libcairo2: 依赖: libfreetype6 (>= 2.2) 但是 2.1.10-1ubuntu2.2 已安装。

既然要(>= 2.2)的版本才满足依赖,为什么不装呢,而 “2.1.10-1ubuntu2.2”,那就应该卸掉再装(>= 2.2)的啊。

而新立得里面的信息是:
已安装版本:2.1.10-lubuntu2.2,而最新版本同样是2.1.10-lubuntu2.2,既然已安装的和最新的都是一样的2.1.10-lubuntu2.2,可为什么还有“ibcairo2: 依赖: libfreetype6 (>= 2.2) ,"2.1.10-lubuntu2.2"都最新的了,2.2又从何而来??


(3)libcairo2和libfreetype6是什么来的?

下面是它们在新立得的注释,(我看到下面的头就大),那位大哥大姐有空的帮忙看看。

libcairo2的英语注释:

The Cairo 2D vector graphics library
Cairo is a multi-platform library providing anti-aliased
vector-based rendering for multiple target backends. Paths consist
of line segments and cubic splines and can be rendered at any width
with various join and cap styles. All colors may be specified with
optional translucence (opacity/alpha) and combined using the
extended Porter/Duff compositing algebra as found in the X Render
Extension.

Cairo exports a stateful rendering API similar in spirit to the path
construction, text, and painting operators of PostScript, (with the
significant addition of translucence in the imaging model). When
complete, the API is intended to support the complete imaging model of
PDF 1.4.

This package contains the shared libraries.

libfreetype6的英语注释:

FreeType 2 font engine, shared library files
The FreeType project is a team of volunteers who develop free,
portable and high-quality software solutions for digital typography.
They specifically target embedded systems and focus on bringing small,
efficient and ubiquitous products.

The FreeType 2 library is their new software font engine. It has been
designed to provide the following important features:
* A universal and simple API to manage font files
* Support for several font formats through loadable modules
* High-quality anti-aliasing
* High portability & performance

Supported font formats include:
* TrueType files (.ttf) and collections (.ttc)
* Type 1 font files both in ASCII (.pfa) or binary (.pfb) format
* Type 1 Multiple Master fonts. The FreeType 2 API also provides
routines to manage design instances easily
* Type 1 CID-keyed fonts
* OpenType/CFF (.otf) fonts
* CFF/Type 2 fonts
* Adobe CEF fonts (.cef), used to embed fonts in SVG documents with
the Adobe SVG viewer plugin.
* Windows FNT/FON bitmap fonts

This package contains the files needed to run programs that use the
FreeType 2 library.

Home Page: http://www.freetype.org/
Authors: David Turner <david.turner@freetype.org>
Robert Wilhelm <robert.wilhelm@freetype.org>
Werner Lemberg <werner.lemberg@freetype.org>




最后,重复一下我的疑问:

(1)libcairo2,我可不可以升级它,升级会有什么后果吗??

(2)下列软件包存在未满足的依赖关系:
libcairo2: 依赖: libfreetype6 (>= 2.2) 但是 2.1.10-1ubuntu2.2 已安装。

这个问题怎样解决?

(3)这两个是关于什么的包?

多谢多谢各位啦。。。



_________________
做一个精通linux的高手--不易;
做一个熟练的linux使用者--不难。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译