当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]系统如何改分辨率
帖子发表于 : 2007-02-05 11:42 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
我装了UBUNTU后显示分辨率只能是800x600但我的显示器是19宽屏的,,最好是能用1440x900,我以前装的LINUX系统也不支持这那么大,但最少也能到1024x768吧,但现在只能是800X600,那个大侠可以帮帮我呀,


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-02-05 11:47 

注册: 2007-01-27 10:14
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
安装驱动……


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-02-05 12:07 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
显卡驱动。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-02-05 13:10 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
如果显示驱动本来支持的话,你装多少遍都没用。

必须改 xorg.conf 才可以出。如果不熟练可以用 dkpg 的那个配置工具重新配制 xorg。

搜一下这样的帖子很多的,就是搞1440x900。for gentoo 和FC的贴子都有。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-02-06 9:15 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
我按照三楼给的(Edgy下的ATI显卡驱动安装)里说的第一种方法安装了驱动程序,但是最高只有1024x768,没有我想要的1440x900那个大侠可以继续帮一下


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-02-06 9:23 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
xorg.conf贴出来。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:20 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Generic Video Cardsudo aticonfig --ovt=Xv"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Cardsudo aticonfig --ovt=Xv"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
Section "Extensions"
Option "Composite" "0"
EndSection


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:20 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
谢谢大侠的帮忙...


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:25 
头像

注册: 2006-11-24 11:00
帖子: 194
地址: 太阳系第3行星
送出感谢: 0 次
接收感谢: 0 次
首先确认你的.conf 文件是正确的,起码 Option "DPMS" 应为 Option "DPMS" "true" 或 "false"
考虑将下面的内容

SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection

换成

SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection

或者执行

sudo aticonfig --initial -f


_________________
要爱护linux 就象爱护我们的庄稼地一样


最后由 arli 编辑于 2007-02-06 10:29,总共编辑了 1 次

页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:28 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
你是说那一段都不要了,然后换能你说的那个吗???????


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:29 
头像

注册: 2006-11-24 11:00
帖子: 194
地址: 太阳系第3行星
送出感谢: 0 次
接收感谢: 0 次
是的


_________________
要爱护linux 就象爱护我们的庄稼地一样


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:34 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
问一下问题,在xorg.conf中有没有注示呀,,,,就像C中的/*........*/的东东..


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:38 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
代码:
Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Generic Video Cardsudo aticonfig --ovt=Xv"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Cardsudo aticonfig --ovt=Xv"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

这三段东西改成:
代码:
Section "Monitor"
   Identifier   "aticonfig-Monitor[0]"
   DisplaySize  409   256
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
   Option       "VideoOverlay"   "on"
   Option       "OpenGLOverlay"   "off"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

然后
代码:
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection
改成
代码:
Section "ServerLayout"
   Identifier     "Default Layout"
   Screen      0  "aticonfig-Screen[0]" 0 0
   InputDevice    "Generic Keyboard"
   InputDevice    "Configured Mouse"
   InputDevice    "stylus" "SendCoreEvents"
   InputDevice    "cursor" "SendCoreEvents"
   InputDevice    "eraser" "SendCoreEvents"
EndSection


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:45 
头像

注册: 2007-02-02 9:11
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
谢谢大侠,,,问题解决了。。。。谢谢


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-02-06 10:51 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
li00000000 写道:
问一下问题,在xorg.conf中有没有注示呀,,,,就像C中的/*........*/的东东..

注释就是#


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译