HOWTO: aMule 的安装与配置

为当前最终发行版之前的所有版本提供支持
newlad
帖子: 258
注册时间: 2005-09-28 12:01
送出感谢: 0
接收感谢: 0

HOWTO: aMule 的安装与配置

#1

帖子 newlad » 2007-02-05 13:51

amule是款相当不错的P2P软件,在linux中使用的算是非常频繁了,这里给出下一些基本的安装与配置方法

1) 安装 amule:

代码: 全选

sudo apt-get install amule amule-utils
2) amule的服务器列表:

打开amule,在server栏中分批次输入

http://www.emule.org.cn/server.met (这是verycd的源)
http://corpo.free.fr/server.met

也可以从emule安装目录的config目录中拷贝server.met到.aMule中去

ps:最好将amule的Nick(用户昵称)改成 [CHN][VeryCD]yourname

3) amule与Firefox的关联:

在Firefox中输入 about:config ,新建下面2个变量:

1.新建一个boolean类型 network.protocol-handler.external.ed2k ,值为true,表示处理ed2k的协议
2.新建一个string类型 network.protocol-handler.app.ed2k ,值为/usr/bin/ed2k,指定处理ed2k协议的程序为/usr/bin/ed2k
附件
server.met.tar.bz2
这是我的amule的服务器列表,400多个了
(19.13 KiB) 下载 1899 次
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#2

帖子 IfI » 2007-02-11 23:06

我这查了又查,和楼主说的没区别。

但是就是不成功~
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#3

帖子 jimmin » 2007-02-12 0:05

我也是总不成功,amule 与 Firefox 关联不起来,都放弃 amule 了。
3) amule与Firefox的关联:

在Firefox中输入 about:config ,新建下面2个变量:

1.新建一个boolean类型 network.protocol-handler.external.ed2k ,值为true,表示处理ed2k的协议
2.新建一个string类型 network.protocol-handler.app.ed2k ,值为/usr/bin/ed2k,指定处理ed2k协议的程序为/usr/bin/ed2k
刚刚看到楼主发帖又精神振奋,仔细找了一下,就发现看/usr/bin/ed2k不顺眼,查了一下 amule 安装文件,如下:
XXX@XXX-desktop:~$ sudo dpkg -L amule
Password:
/.
/usr
/usr/bin
/usr/bin/amule

/usr/share
/usr/share/pixmaps
/usr/share/pixmaps/amule.xpm
/usr/share/applications
/usr/share/applications/amule.desktop
/usr/share/doc
/usr/share/doc/amule
/usr/share/doc/amule/changelog.gz
/usr/share/doc/amule/README.gz
/usr/share/doc/amule/TODO
/usr/share/doc/amule/amulesig.txt
/usr/share/doc/amule/TODO.Debian
/usr/share/doc/amule/copyright
/usr/share/doc/amule/changelog.Debian.gz
/usr/share/doc/amule/ED2K-Links.HOWTO.gz
/usr/share/menu
/usr/share/menu/amule
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/amule.1.gz
/usr/share/man/de
/usr/share/man/de/man1
/usr/share/man/de/man1/amule.1.gz
/usr/share/man/es
/usr/share/man/es/man1
/usr/share/man/es/man1/amule.1.gz
/usr/share/man/fr
/usr/share/man/fr/man1
/usr/share/man/fr/man1/amule.1.gz
/usr/share/man/hu
/usr/share/man/hu/man1
/usr/share/man/hu/man1/amule.1.gz
XXX@XXX-desktop:~$
没有安装/usr/bin/ed2k啊!连名为 ed2k 的都没有。不会我安装的 amule 是盗版吧!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-02-12 0:14

$● dpkg -S '/usr/bin/ed2k'
amule-utils: /usr/bin/ed2k
● 鸣学
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#5

帖子 jimmin » 2007-02-12 0:19

eexpress 写了:$● dpkg -S '/usr/bin/ed2k'
amule-utils: /usr/bin/ed2k

代码: 全选

XXX@XXX-desktop:~$ dpkg -S '/usr/bin/ed2k'
dpkg:没有找到 /usr/bin/ed2k。
XXX@XXX-desktop:~$  
不会真的是盗版吧?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2007-02-12 0:22

碰死哦。是你少了哪个包啊。粗体的那个。
● 鸣学
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#7

帖子 jimmin » 2007-02-12 0:37

成功了,激动中。 :em80 :em80 :em80
akiria2000
帖子: 3
注册时间: 2007-02-12 9:12
送出感谢: 0
接收感谢: 0

#8

帖子 akiria2000 » 2007-02-12 9:14

eexpress 写了:$● dpkg -S '/usr/bin/ed2k'
amule-utils: /usr/bin/ed2k

如何解决啊?我是新手啊,就是无法关联起来啊~~~能说明白一点吗??~?~~
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 karron » 2007-02-12 9:21

sudo apt-get insall amule-utils amule
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#10

帖子 IfI » 2007-02-13 9:06

:( :( :(

为什么我都装了,也都设置了,ed2k也存在,就是不成功呢……总是说未关联……
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#11

帖子 IfI » 2007-02-13 9:23

最后手动编辑firefox的prefs.js,删除已经输入的条目,然后再重新添加,这回终于好了

奇怪死了啦 :em32 :em32 :em32 :em32 :em32 :em32
头像
rory.cn
帖子: 228
注册时间: 2006-10-04 21:52
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 rory.cn » 2007-02-28 16:15

搞定。感谢lz.
本本Acer TravelMate 2403NWXM
xubuntu (feisty fawn)
我的blog:http://jdkcn.com
xbl
帖子: 139
注册时间: 2007-01-01 15:36
来自: 河北
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 xbl » 2007-02-28 18:50

:lol: 今天下午一直在弄amule,终于在搂主的指点下成功的连接了 非常感谢你
xain
帖子: 219
注册时间: 2007-02-05 18:55
送出感谢: 0
接收感谢: 0

#14

帖子 xain » 2007-02-28 19:34

大家不要用amule了。用wine + emule吧。
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 ct » 2007-02-28 19:50

wine+XXX很讨厌的。
回复

回到 “老旧版本支持”