关于BERYL及XGL

为当前最终发行版之前的所有版本提供支持
回复
szllm
帖子: 98
注册时间: 2007-01-28 7:25
送出感谢: 0
接收感谢: 0

关于BERYL及XGL

#1

帖子 szllm » 2007-02-07 15:17

装了一个多星期的 BERYL,到现在有点体会,发出来给大家参考。
BERYL只是在XGL上的应用软件。
所以先要搞定XGL。
偶的显卡是ATI的,走过一段弯路。
偶觉得目前对偶的机器最好的WIKI就是:
http://wiki.beryl-project.org/wiki/Inst ... _on_Ubuntu
不过第一次去的时候,看到
# Install Beryl on Ubuntu Dapper with AIGLX (recommended)
特别是这个recommended,折腾了3天。
后来看到有资料介绍AIGLX对ATI支持不好。
下载了ATI官方驱动,也不会装。
只好转到XGL。

虽然到现在,偶尔GNOME的对话会自动关闭,没有WIN键等,但3D和其他一些特效还是能运行。
回头再搞定ATI的官方驱动。


在Install Beryl on Ubuntu Dapper with XGL中需要注意几点:
1、下载时最好加个代理
偶是去www.proxycn.com找的。
2、在
[edit]
Creating A Separate Xgl session

We need to create a script to launch Xgl. Enter the command below


$ sudo nano /usr/local/bin/startxgl.sh


The contents of the script varies depending on your desktop environment and the graphics card you use. And yes, users of other window managers, please help out and add your own startup scripts here.


GNOME & Nvidia graphics card


#!/bin/sh
/usr/bin/Xgl :1 -fullscreen -ac -br -dpi 96 -accel xv:fbo -accel glx:pbuffer &
sleep 4
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec /etc/X11/Xsession gnome-session

中,最后一行exec /etc/X11/Xsession gnome-session,Xsession应该为xsession.
不过偶进了XGL会话后机器奇慢无比,而且显示也有问题。
现在是通过GNOME进去的。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-02-07 15:33

很遗憾,第一句话就是错的。
你忘了还有aiglx。
ati的卡(开源驱动)可以在aiglx上运行,只是效果不如xgl罢了。
以后fglrx驱动可能会支持aiglx。
aiglx、xgl只是一个平台而已。

而且,你的ati卡为什么用nvidia的方法呢?
应该是这样的吧:

代码: 全选

GNOME & ATi graphics card


#!/bin/sh
Xgl -fullscreen :1 -ac -br -dpi 96 -accel glx:pbuffer -accel xv:pbuffer &
sleep 4  
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie" 
exec /etc/X11/Xsession gnome-session
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
szllm
帖子: 98
注册时间: 2007-01-28 7:25
送出感谢: 0
接收感谢: 0

#3

帖子 szllm » 2007-02-07 15:56

zhuqin_83 写了:很遗憾,第一句话就是错的。
你忘了还有aiglx。
ati的卡(开源驱动)可以在aiglx上运行,只是效果不如xgl罢了。
以后fglrx驱动可能会支持aiglx。
aiglx、xgl只是一个平台而已。

而且,你的ati卡为什么用nvidia的方法呢?
应该是这样的吧:

代码: 全选

GNOME & ATi graphics card


#!/bin/sh
Xgl -fullscreen :1 -ac -br -dpi 96 -accel glx:pbuffer -accel xv:pbuffer &
sleep 4  
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie" 
exec /etc/X11/Xsession gnome-session

“很遗憾,第一句话就是错的。
你忘了还有aiglx。”

呵呵,少加了“一个”
应该是“BERYL只是在XGL上的一个应用软件。 ”
即底层是XGL,上面才是BERYL对它的调用。

第二问题发出来的时候就发现了。
目的在于告诉大家没有这个目录。到时候执行不了。


谢谢指正!!
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#4

帖子 dogfox » 2007-02-07 17:18

我的显卡是ATI的
安装很顺利
一般是先下载0.11的相关deb包
放在系统默认缓存处
安装
修改源
升级为beryl-svn
ok
如果算上下载的时间
大概需要30分钟吧
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
mily
帖子: 107
注册时间: 2006-11-02 13:12
送出感谢: 0
接收感谢: 0

#5

帖子 mily » 2007-02-07 17:21

szllm 写了:
zhuqin_83 写了:很遗憾,第一句话就是错的。
你忘了还有aiglx。
ati的卡(开源驱动)可以在aiglx上运行,只是效果不如xgl罢了。
以后fglrx驱动可能会支持aiglx。
aiglx、xgl只是一个平台而已。

而且,你的ati卡为什么用nvidia的方法呢?
应该是这样的吧:

代码: 全选

GNOME & ATi graphics card


#!/bin/sh
Xgl -fullscreen :1 -ac -br -dpi 96 -accel glx:pbuffer -accel xv:pbuffer &
sleep 4  
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie" 
exec /etc/X11/Xsession gnome-session

“很遗憾,第一句话就是错的。
你忘了还有aiglx。”

呵呵,少加了“一个”
应该是“BERYL只是在XGL上的一个应用软件。 ”
即底层是XGL,上面才是BERYL对它的调用。

第二问题发出来的时候就发现了。
目的在于告诉大家没有这个目录。到时候执行不了。


谢谢指正!!
还是一样,不一定要XGL的
只要aiglx+beryl也可以,XGL不喜欢可以删除了换装aiglx或别的什么
干脆说beryl是众多利用openGL实现各种桌面特效的窗口管理器之一好了
回复

回到 “老旧版本支持”