安装Nvidia驱动碰到麻烦

为当前最终发行版之前的所有版本提供支持
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

安装Nvidia驱动碰到麻烦

#1

帖子 IfI » 2007-02-07 17:51

两种方法,一种是按
这种办法,从源里直接装,但是我装的时候总是提示有依赖问题,说我的软件库设置不正确,而我换了很多源,就是下载不完软件包信息。只得作罢。

第二种从nvidia官网下载驱动安装,但是在装之前的两步准备,好像有问题,
sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号里面添加nv两个字,添加后就是“nv” ,
这一步我打开的是空文件。

装的过程中会出现两次报错,如图。
附件
DSC_5607.JPG
错误一
DSC_56071.JPG
错误二
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#2

帖子 IfI » 2007-02-07 17:52

为了搞一个驱动我呆坐一整天啦,上帝阿…… :cry: :cry: :cry:
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#3

帖子 5451vs5451 » 2007-02-07 17:57

装官方驱动,看这个教程

代码: 全选

http://wiki.ubuntu.org.cn/NvidiaManual
建议你最好还是把源的问题先解决。安装过程中还是有可能要从源里下东西。
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#4

帖子 IfI » 2007-02-07 18:02

我wiki把提供的所有源都加上了

不知哪里还有源?拜谢!
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#5

帖子 5451vs5451 » 2007-02-07 18:13

把apt的错误提示贴出来看看。
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#6

帖子 IfI » 2007-02-07 18:22

sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
nvidia-glx: 依赖: nvidia-kernel-1.0.9631
E: 无法安装的软件包
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#7

帖子 IfI » 2007-02-07 18:24

用新立得的话会提示:
下列软件包具有未满足的依赖关系,请确保首选项里所有需要的软件仓库已添加并启用。

nvidia-glx:
依赖: nvidia-kernel-1.0.9631
依赖: nvidia-glx
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#8

帖子 xiechy » 2007-02-07 18:36

开了universe和multiverse吗?还有用的是edgy还是feisty?具体是什么源。
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#9

帖子 5451vs5451 » 2007-02-07 18:38

你的官方驱动安装成功了吗?如果没有成功可以试试这种方法:

代码: 全选

sudo apt-get install nvidia-glx=1.0.8762+2.6.15.11-1
这会安装一个旧一点的版本,以后可以升上去。现在的源里好像根本就没有nvidia-kernel-1.0.9631,这几天看到好多人都遇到了这个问题。
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#10

帖子 IfI » 2007-02-07 18:42

edgy,所有的选项都开了(是说在新立得管理器里,设置-软件库-软件源里的选项把?全选着呢)
我的源列表如下:
deb http://mirror9.net9.org/ubuntu/ edgy main multiverse restricted universe
deb http://mirror9.net9.org/ubuntu/ edgy-backports main multiverse restricted universe
deb http://mirror9.net9.org/ubuntu/ edgy-proposed main multiverse restricted universe
deb http://mirror9.net9.org/ubuntu/ edgy-security main multiverse restricted universe
deb http://mirror9.net9.org/ubuntu/ edgy-updates main multiverse restricted universe
deb-src http://mirror9.net9.org/ubuntu/ edgy main multiverse restricted universe
deb-src http://mirror9.net9.org/ubuntu/ edgy-backports main multiverse restricted universe
deb-src http://mirror9.net9.org/ubuntu/ edgy-proposed main multiverse restricted universe
deb-src http://mirror9.net9.org/ubuntu/ edgy-security main multiverse restricted universe
deb-src http://mirror9.net9.org/ubuntu/ edgy-updates main multiverse restricted universe
deb http://mirror9.net9.org/ubuntu-cn/ edgy main multiverse restricted universe


deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-updates main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-backports main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-security main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-proposed main multiverse restricted universe
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ edgy-proposed main restricted universe multiverse


deb http://cn.archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse


deb http://ubuntu.cn99.com/ubuntu/ edgy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ edgy main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn/ edgy main restricted universe multiverse

deb http://cn.archive.ubuntu.com/ubuntu edgy main restricted
deb http://cn.archive.ubuntu.com/ubuntu edgy-updates main restricted
deb http://security.ubuntu.com/ubuntu edgy-security main restricted

# Ubuntu community supported packages
# GPG key: 437D05B5
deb http://cn.archive.ubuntu.com/ubuntu edgy universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu edgy-updates universe multiverse
deb http://security.ubuntu.com/ubuntu edgy-security universe multiverse
最后两个是由自动源生成器生成的。
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#11

帖子 IfI » 2007-02-07 18:44

官方驱动如果安装成功我就不用在这里求救啦

装上不起作用,进不了x,不过我会卸(钻研readme来着),试试你说的方法
你的官方驱动安装成功了吗?如果没有成功可以试试这种方法:
代码:
sudo apt-get install nvidia-glx=1.0.8762+2.6.15.11-1

这会安装一个旧一点的版本,以后可以升上去。现在的源里好像根本就没有nvidia-kernel-1.0.9631,这几天看到好多人都遇到了这个问题。
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#12

帖子 IfI » 2007-02-07 18:47

还是不行,没有这个版本的说
sudo apt-get install nvidia-glx=1.0.8762+2.6.15.11-1
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 未找到“nvidia-glx”的“1.0.8762+2.6.15.11-1”版本
这可如何是好…… :cry: :cry: :cry:
IfI
帖子: 146
注册时间: 2007-02-06 20:44
送出感谢: 0
接收感谢: 0

#13

帖子 IfI » 2007-02-07 19:36

装了个X.org的sdk,不报错了,但是仍然无法正常启动。
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#14

帖子 5451vs5451 » 2007-02-07 19:38

IfI 写了:还是不行,没有这个版本的说
sudo apt-get install nvidia-glx=1.0.8762+2.6.15.11-1
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 未找到“nvidia-glx”的“1.0.8762+2.6.15.11-1”版本
这可如何是好…… :cry: :cry: :cry:
看看有那些可用的版本
apt-cache show nvidia-glx | grep "Version"
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#15

帖子 5451vs5451 » 2007-02-07 20:03

算了,如果只是nvidia-kernel-1.0.9631缺失,其他的包都能下的话,还是照http://wiki.ubuntu.org.cn/NvidiaManual上的步骤装官方驱动好了,省得到时候装好了又有冲突。
回复

回到 “老旧版本支持”