出了大问题了

为当前最终发行版之前的所有版本提供支持
回复
zhwlyfx
帖子: 431
注册时间: 2007-01-21 15:44
送出感谢: 0
接收感谢: 0

出了大问题了

#1

帖子 zhwlyfx » 2007-02-09 18:52

每一次用apt-get install安装软件都会得到如下错误:
zhw@zhw-laptop:~$ sudo apt-get -f install xmms
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
kdelibs4c2a: 依赖: libarts1c2a (>= 1.5.0-1) 但是它将不会被安装
依赖: libavahi-qt3-1 (>= 0.6.0) 但是它将不会被安装
依赖: liblua50 (>= 5.0.2) 但是它将不会被安装
依赖: liblualib50 (>= 5.0.2) 但是它将不会被安装
依赖: libopenexr2c2a (>= 1.2.2) 但是它将不会被安装
依赖: libpcre3 (>= 4.5) 但是它将不会被安装
依赖: kdelibs-data (> 4:3.5.5) 但是它将不会被安装
依赖: kdelibs-data (< 4:3.5.6) 但是它将不会被安装
xmms: 依赖: libgtk1.2 (>= 1.2.10-4) 但是它将不会被安装
依赖: libmikmod2 (>= 3.1.10) 但是它将不会被安装
依赖: libvorbisfile3 (>= 1.1.2) 但是它将不会被安装
难道apt不能把这些依赖的文件安装上吗
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#2

帖子 dogfox » 2007-02-09 19:10

的确是大问题
标题不惊悚不罢休啊~~
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
zhwlyfx
帖子: 431
注册时间: 2007-01-21 15:44
送出感谢: 0
接收感谢: 0

#3

帖子 zhwlyfx » 2007-02-09 19:14

晕,给点解决方法阿
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2007-02-09 19:16

您可能需要运行“apt-get -f install”来纠正下列错误
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 gnix_oag » 2007-02-09 19:20

解决方法:

sudo apt-get install beep-media-player
zhwlyfx
帖子: 431
注册时间: 2007-01-21 15:44
送出感谢: 0
接收感谢: 0

#6

帖子 zhwlyfx » 2007-02-09 19:24

楼上2位,我都用过了,还是不行,还是类似的错误
zhw@zhw-laptop:~$ sudo apt-get install beep-media-player
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
beep-media-player: 依赖: libid3-3.8.3c2a 但是它将不会被安装
依赖: libvorbisfile3 (>= 1.1.2) 但是它将不会被安装
kdelibs4c2a: 依赖: libarts1c2a (>= 1.5.0-1) 但是它将不会被安装
依赖: libavahi-qt3-1 (>= 0.6.0) 但是它将不会被安装
依赖: liblua50 (>= 5.0.2) 但是它将不会被安装
依赖: liblualib50 (>= 5.0.2) 但是它将不会被安装
依赖: libopenexr2c2a (>= 1.2.2) 但是它将不会被安装
依赖: libpcre3 (>= 4.5) 但是它将不会被安装
依赖: kdelibs-data (> 4:3.5.5) 但是它将不会被安装
依赖: kdelibs-data (< 4:3.5.6) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

zhw@zhw-laptop:~$ sudo apt-get -f install beep-media-player
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
beep-media-player: 依赖: libid3-3.8.3c2a 但是它将不会被安装
依赖: libvorbisfile3 (>= 1.1.2) 但是它将不会被安装
kdelibs4c2a: 依赖: libarts1c2a (>= 1.5.0-1) 但是它将不会被安装
依赖: libavahi-qt3-1 (>= 0.6.0) 但是它将不会被安装
依赖: liblua50 (>= 5.0.2) 但是它将不会被安装
依赖: liblualib50 (>= 5.0.2) 但是它将不会被安装
依赖: libopenexr2c2a (>= 1.2.2) 但是它将不会被安装
依赖: libpcre3 (>= 4.5) 但是它将不会被安装
依赖: kdelibs-data (> 4:3.5.5) 但是它将不会被安装
依赖: kdelibs-data (< 4:3.5.6) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 BigSnake.NET » 2007-02-09 19:55

E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
zhwlyfx
帖子: 431
注册时间: 2007-01-21 15:44
送出感谢: 0
接收感谢: 0

#8

帖子 zhwlyfx » 2007-02-09 20:03

我晕,原来是这样阿
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 gnix_oag » 2007-02-09 20:03

你的源有没有问题啊。

按这个重新更新吧
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 7%E5%8D%97
zhwlyfx
帖子: 431
注册时间: 2007-01-21 15:44
送出感谢: 0
接收感谢: 0

#10

帖子 zhwlyfx » 2007-02-09 20:12

我的源没有问题,只是我没有运行apt-get -f install,谢谢7楼的兄弟,我的问题解决了,都怪我美好好看提示
,我正打算重装呢(老习惯了 :evil:
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#11

帖子 dogfox » 2007-02-09 20:21

zhwlyfx 写了:我的源没有问题,只是我没有运行apt-get -f install,谢谢7楼的兄弟,我的问题解决了,都怪我美好好看提示
,我正打算重装呢(老习惯了 :evil:
windows的习惯积习难改啊~~~
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
leeyee
帖子: 723
注册时间: 2006-04-11 9:01
送出感谢: 0
接收感谢: 0

#12

帖子 leeyee » 2007-02-09 21:54

哪个Linux用户不是从一遍遍装系统开始的啊?呵呵
I would love to change the world, but they won't give me the source code.
http://hi.baidu.com/wienerlee
回复

回到 “老旧版本支持”