当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 新立得软件包管理器无法使用了(完全解决)
帖子发表于 : 2007-02-09 20:36 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
今天在网上下载了virturalbox来安装.结果出错了.它需要内核的源代码.后来打开新立得想安装源代码.
结果新立得出现一个错误窗口,信息如下:

E: 软件包 virtualbox 需要重新安装,但是我无法找到相应的安装文件。
E: 打开高速缓存(1)时有内部错误。请报告。

用搜索功能,结果什么软件都搜索不到.新立得失效了.
用apt-get,又出现以下提示:

E: 软件包 virtualbox 需要重新安装,但是我无法找到相应的安装文件。

陷入一个死循环了. 谁能帮我解决这个问题,不胜感激.

问题已经完全解决了.具体请看:
http://forum.ubuntu.org.cn/viewtopic.ph ... 251#211251


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


最后由 bernieqiu 编辑于 2007-02-12 21:52,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-02-09 20:40 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo apt-get install -f


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-02-09 21:15 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
没有用,以下是结果:

dubuntu@lsc:~/MyDownloads$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 软件包 virtualbox 需要重新安装,但是我无法找到相应的安装文件。

怎么办?


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-02-10 10:58 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo apt-get remove virtualbox


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-02-10 12:41 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
还是不行.我也搜了不少资料,找不到办法.
以下是执行结果:

dubuntu@lsc:~$ sudo apt-get remove virtualbox
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 软件包 virtualbox 需要重新安装,但是我无法找到相应的安装文件。

哈哈,难啊.


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-02-10 12:55 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
下载 virtualbox的deb,用dpkg -i 暴力安一次


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-10 14:46 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
试试把cd /var/lib/dpkg/info/ 下所有virtualbox有关的内容的删掉


_________________
blog:杰林修·呓


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-02-10 14:53 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
问题己解决.我修改 /var/lib/dpkg/status 删除掉 virtualbox 的东西后,新立得终于正常了。

感谢oneleaf的帮助.

我现在用新立得下载安装LINUX内核源码.virtualbox的安装需要这个.不知道能否顺利安装.
稍后我再发贴.


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-10 17:11 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
安装virtualbox还是不成功,以下是安装结果:

dubuntu@lsc:~/MyDownloads$ sudo dpkg -i VirtualBox_1.3.2_Ubuntu_Dapper_x86.deb
(正在读取数据库 ... 系统当前总共安装有 89409 个文件和目录。)
正预备替换 virtualbox 1.3.2-20070114_Ubuntu_dapper (使用 VirtualBox_1.3.2_Ubuntu _Dapper_x86.deb) ...
(Kernel module not found)...fail!
invoke-rc.d: initscript virtualbox, action "stop" failed.
dpkg:警告 - 原先的 pre-removal 脚本 退出时返回了错误号 1
dpkg - 现转而试用新软件包所带的脚本...
(Kernel module not found)...fail!
invoke-rc.d: initscript virtualbox, action "stop" failed.
dpkg:处理 VirtualBox_1.3.2_Ubuntu_Dapper_x86.deb (--install)时出错:
子进程·新的 pre-removal 脚本·返回了错误号·1

Creating group 'vboxusers'. VM users must be member of that group!

No precompiled module for this kernel found -- trying to build one
Messages displayed during module compilation will be logged to /var/log/vbox-ins tall.log
Compilation of kernel module failed, aborting installation
dpkg: 作下列清理工作时发生错误:
子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
VirtualBox_1.3.2_Ubuntu_Dapper_x86.deb

在安装log文件 /var/log/vbox-ins tall.log中的信息如下:

make: Entering directory `/opt/VirtualBox-1.3.2/src'
Makefile:42: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.。 停止。
make: Leaving directory `/opt/VirtualBox-1.3.2/src'

我的内核源码是用新立得安装的.


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-02-10 21:22 
头像

注册: 2006-12-14 20:33
帖子: 834
送出感谢: 0 次
接收感谢: 0 次
别装这玩意..我从官方和新立得下载都有

dpkg:处理 VirtualBox_1.3.2_Ubuntu_Dapper_x86.deb (--install)时出错:
子进程·新的 pre-removal 脚本·返回了错误号·1

Creating group 'vboxusers'. VM users must be member of that group!

搞的你以后升级也不行了...

送你一个解决方法:
o Edit /etc/init.d/virtualbox and change line 129 from 'exit 1' to 'exit 0'
o Reinstall the virtualbox package by 'dpkg -i <the VirtualBox package for your distribution>'. An installation failure of this package is expected.
o Edit /var/lib/dpkg/info/virtualbox.postinst and change line 39 from 'exit 1' to 'exit 0'
o Execute 'dpkg --configure --pending'
o The package should now be installed successfully. However, the kernel module is still not compiled. Before you will be able to execute VirtualBox you have to create a kernel module for your current kernel, as described in the User Manual (see our Downloads section).




Good lucky...
我自己不能解决...虽然我看得懂上面的英文并操作...我第二步不行 别的都能跳着做...


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-02-10 21:56 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
我装这个虚拟机的主要目的是想安装大智慧股票行情分析软件.我不太想用双系统.
我还试过用wine 来安装,也失败了.
楼上的朋友有别的办法解决吗


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-02-10 22:05 
头像

注册: 2006-01-29 9:29
帖子: 90
送出感谢: 0 次
接收感谢: 0 次
bernieqiu 写道:
我装这个虚拟机的主要目的是想安装大智慧股票行情分析软件.我不太想用双系统.
我还试过用wine 来安装,也失败了.
楼上的朋友有别的办法解决吗


VMware 吧,大一点,但是管用。


_________________
在现实面前,当然是理想错了……


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-02-11 0:15 

注册: 2007-02-04 14:29
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
在网上看了资料,这是virtualbox1.3.2的BUG,可能在下一个版本能够得到解决.只好等待了.


_________________
ubuntu 7.10 + WIN XP
Sempron 3400+/1G/80G/GF7300LE/17" CRT


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-02-11 11:28 
头像

注册: 2006-12-14 20:33
帖子: 834
送出感谢: 0 次
接收感谢: 0 次
bernieqiu 写道:
我装这个虚拟机的主要目的是想安装大智慧股票行情分析软件.我不太想用双系统.
我还试过用wine 来安装,也失败了.
楼上的朋友有别的办法解决吗

bernieqiu 写道:
在网上看了资料,这是virtualbox1.3.2的BUG,可能在下一个版本能够得到解决.只好等待了.

哈哈 我也是装股票软件..不行..
你按我的方法做了麼


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-02-11 11:58 
头像

注册: 2006-12-14 20:33
帖子: 834
送出感谢: 0 次
接收感谢: 0 次
你是dapper 我是edgy...按你的错误提示.应该装好了 在终端里面输入VirtualBox即可打开..
只是安装错误永远存在并影响apt-get升级
顺便报告楼主..我按照我给你的方法成功了 解决了影响升级的错误..


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译