为什么不能升级?

为当前最终发行版之前的所有版本提供支持
回复
sakses
帖子: 168
注册时间: 2006-12-26 16:38
送出感谢: 0
接收感谢: 0

为什么不能升级?

#1

帖子 sakses » 2007-02-10 9:54

今天sudo apt-get upgrade了一下,发现

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
下列的软件包的版本将保持不变:
linux-headers-generic linux-image-generic
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。

为什么不升级?
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SuperWar3Fan » 2007-02-10 9:59

应该是没有可以升级的软件吧!
generic可能是升级Edgy以前的Drapper内核版本。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 zhuqin_83 » 2007-02-10 10:18

你需要等一天左右,我这里已经升级了。
security的网速慢,而且可能没有把该升级的软件同步完毕。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#4

帖子 jimmin » 2007-02-10 10:46

啊,我刚刚升级了,你换个源试试。
我先前用CN99+台湾的源也和你一样。

代码: 全选

~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在筹划升级... 完成
下列【新】软件包将被安装:
  linux-image-2.6.15-28-686 linux-restricted-modules-2.6.15-28-686
下列的软件包将被升级:
  language-pack-en language-pack-en-base linux-image-686 linux-restricted-modules-686
共升级了 4 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 33.5MB 的软件包。
解压缩后会消耗掉 85.0MB 的额外空间。
您希望继续执行吗?[Y/n]
获取:1 http://ubuntu.csie.ntu.edu.tw dapper-security/main linux-image-686 2.6.15.26 [23.4kB]
获取:2 http://ubuntu.csie.ntu.edu.tw dapper-security/restricted linux-restricted-modules-2.6.15-28-                                          686 2.6.15.12-28.1 [7940kB]
获取:3 http://cn.archive.ubuntu.com dapper-updates/main language-pack-en 1:6.06+20070129 [2160B]
获取:4 http://cn.archive.ubuntu.com dapper-updates/main language-pack-en-base 1:6.06+20070129 [3015                                          kB]
获取:5 http://ubuntu.csie.ntu.edu.tw dapper-security/restricted linux-restricted-modules-686 2.6.15.26 [23.5kB]
获取:6 http://cn.archive.ubuntu.com dapper-security/main linux-image-2.6.15-28-686 2.6.15-28.51 [22.5MB]
下载 33.5MB,耗时 13m1s (42.9kB/s)
(正在读取数据库 ... 系统当前总共安装有 91582 个文件和目录。)
正预备替换 language-pack-en 1:6.06+20061130 (使用 .../language-pack-en_1%3a6.06+20070129_all.deb) ...
正在解压缩将用于更替的包文件 language-pack-en ...
正预备替换 language-pack-en-base 1:6.06+20060725 (使用 .../language-pack-en-base_1%3a6.06+20070129_all.deb) ...
正在解压缩将用于更替的包文件 language-pack-en-base ...
选中了曾被取消选择的软件包 linux-image-2.6.15-28-686。
正在解压缩 linux-image-2.6.15-28-686 (从 .../linux-image-2.6.15-28-686_2.6.15-28.51_i386.deb) ...
正预备替换 linux-image-686 2.6.15.25 (使用 .../linux-image-686_2.6.15.26_i386.deb) ...
正在解压缩将用于更替的包文件 linux-image-686 ...
选中了曾被取消选择的软件包 linux-restricted-modules-2.6.15-28-686。
正在解压缩 linux-restricted-modules-2.6.15-28-686 (从 .../linux-restricted-modules-2.6.15-28-686_2.6.15.12-28.1_i386.deb) ...
正预备替换 linux-restricted-modules-686 2.6.15.25 (使用 .../linux-restricted-modules-686_2.6.15.26_i386.deb) ...
正在解压缩将用于更替的包文件 linux-restricted-modules-686 ...
正在设置 linux-image-2.6.15-28-686 (2.6.15-28.51) ...
/initrd.img does not exist. Installing from scratch, eh?
Or maybe you don't want a symbolic link here. Hmm? Lets See.
/vmlinuz does not exist. Installing from scratch, eh?
Or maybe you don't want a symbolic link here. Hmm? Lets See.
Searching for GRUB installation directory ... found: /boot/grub
Testing for an existing GRUB menu.list file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.15-28-686
Found kernel: /boot/vmlinuz-2.6.15-27-686
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done


正在设置 linux-image-686 (2.6.15.26) ...
正在设置 linux-restricted-modules-2.6.15-28-686 (2.6.15.12-28.1) ...

正在设置 linux-restricted-modules-686 (2.6.15.26) ...
正在设置 language-pack-en (6.06+20070129) ...
正在设置 language-pack-en-base (6.06+20070129) ...
Generating locales...
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZW.UTF-8... done
Generation complete.
头像
TualatriX
帖子: 359
注册时间: 2006-11-17 20:07
来自: 杭州/宁波
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 TualatriX » 2007-02-10 10:49

嗯。我今天也升级成2.6.17-11了。昨天还不行的。
IMTX:http://imtx.cn/

LDCN(已经关闭):http://linuxdesktop.cn/

Ubuntu Tweak:http://ubuntu-tweak.com/
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#6

帖子 dogfox » 2007-02-10 11:24

可以升级啊~~

代码: 全选

下载 183kB,耗时 43s (4166B/s)
正在读取软件包列表... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在筹划升级... 完成
下列【新】软件包将被安装:
  linux-image-2.6.15-28-686 linux-restricted-modules-2.6.15-28-686
下列的软件包的版本将保持不变:
  libcairo2
下列的软件包将被升级:
  language-pack-en language-pack-en-base language-pack-gnome-en
  language-pack-gnome-en-base language-pack-gnome-zh
  language-pack-gnome-zh-base language-pack-kde-en language-pack-kde-en-base
  language-pack-kde-zh language-pack-kde-zh-base language-pack-zh
  language-pack-zh-base linux-image-686 linux-restricted-modules-686
共升级了 14 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 1 个软件未被升 级。
需要下载 48.1MB 的软件包。
解压缩后会消耗掉 85.9MB 的额外空间。
您希望继续执行吗?[Y/n]
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2007-02-10 11:40

一般等等就好,有可能还没有同步好
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
sakses
帖子: 168
注册时间: 2006-12-26 16:38
送出感谢: 0
接收感谢: 0

#8

帖子 sakses » 2007-02-10 12:25

等不及了。
我在sources.list的末尾加上几行:
## Official Security
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

现在正在升级,不过只有5kB/s
sakses
帖子: 168
注册时间: 2006-12-26 16:38
送出感谢: 0
接收感谢: 0

#9

帖子 sakses » 2007-02-10 12:34

再问,大家可以更新的都用的什么源啊,把sources.list贴出来看看。
jimmin
论坛版主
帖子: 2138
注册时间: 2006-09-24 4:37
送出感谢: 0
接收感谢: 1 次

#10

帖子 jimmin » 2007-02-10 12:37

代码: 全选

deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
#deb http://ftp.sjtu.edu.cn/ubuntu-cn/ dapper main multiverse restricted universe

deb http://cn.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/ubuntu-cn dapper main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse


########deb http://cn.archive.ubuntu.com/ubuntu/ dapper main restricted
########deb-src http://cn.archive.ubuntu.com/ubuntu/ dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
########deb http://cn.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
########deb-src http://cn.archive.ubuntu.com/ubuntu/ dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://cn.archive.ubuntu.com/ubuntu/ dapper universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://cn.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

########deb http://security.ubuntu.com/ubuntu dapper-security main restricted
########deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
# deb http://security.ubuntu.com/ubuntu dapper-security universe
# deb-src http://security.ubuntu.com/ubuntu dapper-security universe
头像
why_790721
帖子: 295
注册时间: 2006-12-01 22:28
送出感谢: 0
接收感谢: 0

#11

帖子 why_790721 » 2007-02-10 18:45

我的系统自动升级了也有8~9回了,怎么还是2.6.15-28?
我记得我在重装之前使用这个系统没有几天就升级到了2.6.17-28了!
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#12

帖子 dogfox » 2007-02-10 22:08

dapper升级前的默认内核是2.6.15.27
现在升级后是2.6.15.28
我用的是2.6.19.2
无法升级到2.6.20,郁闷
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
回复

回到 “老旧版本支持”