Ati开源驱动,7.04安装beryl,非常简单!

为当前最终发行版之前的所有版本提供支持
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

Ati开源驱动,7.04安装beryl,非常简单!

#1

帖子 shuaiant » 2007-02-11 10:50

看着大家都体验了beryl,我也忍不住体验了一把。效果还不错的说。7.04用AIGLX非常简单。我简单说一下步骤,老鸟别笑话,我也是看wiki学的。

第一步:在源里添加 deb http://ubuntu.beryl-project.org feisty main

并添加key wget http://ubuntu.beryl-project.org/root@lupine.me.uk.gpg -O- | sudo apt-key add -

然后 sudo apt-get update

第二步:启用AIGLX

sudo gedit /etc/X11/xorg.conf

找到 Section "Module" 这一项,保证下面有这几项,没有的就加上。

Load "dri"
Load "dbe"
Load "glx"

然后找到 Section "Device" 这一项,在下面添加

Option "XAANoOffscreenPixmaps"
Option "AddARGBGLXVisuals" "True" #For ati if not you can find problems with window borders

重启X,OK。

第三步:安装beryl和beryl的主题。

sudo apt-get install beryl emerald-themes

ok,这就完成了beryl的安装,简单吧,赶紧试试在终端输入 beryl-manager 看看效果。想我一样到菜鸟乐去吧。嘿嘿。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-02-11 11:11

什么显卡型号?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

#3

帖子 shuaiant » 2007-02-11 11:51

我是9000移动阿
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2007-02-11 12:36

ati的就用开源驱动,用官方的闭源驱动反而还需要xgl来搞,增加了资源占用.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
shuaiant
帖子: 33
注册时间: 2005-05-04 19:51
送出感谢: 0
接收感谢: 0

#5

帖子 shuaiant » 2007-02-11 17:39

我用的就是开源驱动阿。标题写明的阿。
头像
mikel
帖子: 56
注册时间: 2007-02-12 21:46
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 mikel » 2007-02-18 15:20

不错,按照你的方法,搞定了,好!! beryl 确实爽!
头像
happybombman
帖子: 28
注册时间: 2005-06-20 1:32
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 happybombman » 2007-02-19 12:54

留个影,抽空升到7.04试试
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 zhuqin_83 » 2007-02-19 12:59

开源驱动不支持blur效果、水波效果等。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
www1862
帖子: 781
注册时间: 2006-05-12 0:52
来自: Chongqing China
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 www1862 » 2007-02-19 15:11

开源驱动支持X1600显卡
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 zhuqin_83 » 2007-02-19 15:15

要看支持到什么程度。
9800以上的显卡开源驱动都不怎么样。
2D还马马虎虎(其实也不行,至少我的1440x900就显示效果其差无比),3D很不稳定。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
TheThirdGhost
帖子: 1592
注册时间: 2006-07-23 16:25
来自: 南京
送出感谢: 0
接收感谢: 0

#11

帖子 TheThirdGhost » 2007-02-20 10:45

嘿嘿,我是9200,老机也是有好处的。
zhumingvictor
帖子: 15
注册时间: 2007-01-26 8:18
送出感谢: 0
接收感谢: 0

#12

帖子 zhumingvictor » 2007-02-23 1:20

Hi, cannot any body help me?
I am using Radeon Mobility 9000 also, and I successful installed beryl with your instruction. And made any changed needed. But when I try to swith window manager to beryl the monitor always flash and then set back to gnome window manager.

Can you help me with this?

Also I saw you metioned AIGLX, I never installed that. Is it come with ubuntu 7.04 feisty or we need to install it manaully?

Help me please!
Thank you.
democracia
帖子: 29
注册时间: 2007-02-05 15:54
送出感谢: 0
接收感谢: 0

#13

帖子 democracia » 2007-02-27 12:17

我也是用Mobility 9000,握个手先!
现在用的6.10,暂时还不想升级。不过看到楼主用这个显卡成功安装beryl,还是很高兴的,必经在ati.com上已经找不到这个显卡的驱动了(难道是因为太老?)。
现在分辨率只能达到1024*768*60Hz,我其实非常希望能上到75Hz的。等待7.4,看看能不能自动支持这么高的刷新率。
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#14

帖子 sinoyster » 2007-02-28 22:49

只可惜我的Xpress 200开源驱动不支持,郁闷ing
Thank you Ubuntu Team!!!!
I still can't belive this is free...
芳芳郁金香
帖子: 179
注册时间: 2005-10-06 18:49
送出感谢: 0
接收感谢: 0

#15

帖子 芳芳郁金香 » 2007-03-11 23:28

democracia 写了:我也是用Mobility 9000,握个手先!
现在用的6.10,暂时还不想升级。不过看到楼主用这个显卡成功安装beryl,还是很高兴的,必经在ati.com上已经找不到这个显卡的驱动了(难道是因为太老?)。
现在分辨率只能达到1024*768*60Hz,我其实非常希望能上到75Hz的。等待7.4,看看能不能自动支持这么高的刷新率。
刷新率和你的显示器设定有关吧,和显卡好像没什么关系
回复

回到 “老旧版本支持”