我的主题自动改变了,为什么?(已经解决)

为当前最终发行版之前的所有版本提供支持
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

我的主题自动改变了,为什么?(已经解决)

#1

帖子 zhuguangxiang » 2007-02-16 0:10

1、当我再安装一些音频播放器的时(mplayer ,Audacious ,gstreamer ,w32codecs),我的主题自动变了,而且察看主题时,全部没有了,只有一个很丑陋的自定义主题。这不是一次了,好像我这几天都时这个原因重新装了n遍,每次都是主题变了,变成了很丑陋的家伙,气死我了。
2、变了以后,在我的/home/guangxiang/下多了一个文件夹:NONE/var/cache/fontconfig/,其下面是一大堆文件名很长的的文件。
3、变了以后,我以前的美化的字体,也变了。变的非常的丑陋,而且没有ubuntu默认的好看。当然默认的字体没有我美化的好看。美化是用的windows下的一些字体,没有用其他的字体。修改文件时,只修改了language-selector.conf,没有修改其他任何字体配置文件。我的字体放在~/.fonts/下。
4、我在之前,安装的过程为:
系统升级-->美化-->安装build-essential-->安装了gtk开发环境(里面包括pkg-config,freetype,fontconfig ,cairo,glib ,gtk等包)-->安装多媒体了-->天鹅变成了丑小鸭。。。5555555555555555555555
5、在发帖之前我在论坛上搜索的关键字:主题改变,主题自动改变,等等。。。一无所获。
发帖!求救!
这就是我的Unbuntu 6.10的病症了(我发现的)。
上次由 zhuguangxiang 在 2007-02-16 21:42,总共编辑 1 次。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-02-16 0:14

这要看你搞了些什么哦。难道自己编译了一堆软件?
NONE/var/cache/fontconfig/
● 鸣学
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#3

帖子 zhuguangxiang » 2007-02-16 11:35

由于源里面没有gtk,当然安装gtk时,是下载的源码,自己来编译,然后在安装了。
自己编译源码会影响主题和字体吗?
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#4

帖子 zhuguangxiang » 2007-02-16 12:32

我贴一张 我的丑陋的主题的图片555555555555
附件
Screenshot.png
firefish
帖子: 284
注册时间: 2007-01-18 16:14
来自: CHINA
送出感谢: 0
接收感谢: 0

#5

帖子 firefish » 2007-02-16 13:13

zhuguangxiang 写了:由于源里面没有gtk,当然安装gtk时,是下载的源码,自己来编译,然后在安装了。
自己编译源码会影响主题和字体吗?
谁说源里面没有GTK的?
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#6

帖子 zhuguangxiang » 2007-02-16 14:17

我在我的丑陋的字体和主题下,又安装了其他的字体wqy,但是在字体的选择里面,没有发现。
是不是我的字体库崩溃了阿。从而导致这样的后果???
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#7

帖子 zhuguangxiang » 2007-02-16 14:19

firefish 写了:
zhuguangxiang 写了:由于源里面没有gtk,当然安装gtk时,是下载的源码,自己来编译,然后在安装了。
自己编译源码会影响主题和字体吗?
谁说源里面没有GTK的?
我用的是cn99,不知道你那个有GTK的源是什么?
是不是用apt-get install gtk 这样的命令来安装??
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#8

帖子 zhuguangxiang » 2007-02-16 14:21

zhuguangxiang 写了:我在我的丑陋的字体和主题下,又安装了其他的字体wqy,但是在字体的选择里面,没有发现。
是不是我的字体库崩溃了阿。从而导致这样的后果???
由于我在安装gtk时,安装了fontconfig 和freetype 两个软件(这两个软件是GTK 要求安装的,不然GTK无法解析包的依赖)。
是不是这两个软件在作怪呢?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 BigSnake.NET » 2007-02-16 17:16

你為什麽要安裝gtk
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#10

帖子 zhuguangxiang » 2007-02-16 19:27

gtk是一个图形开发环境,当然要安装!再者Eclipse 也需要GTK
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#11

帖子 zhuguangxiang » 2007-02-16 19:36

GTK可以安装,谢谢了!viewtopic.php?t=40971&highlight=gtk
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 BigSnake.NET » 2007-02-16 19:43

講清楚你說的gtk是指庫還是開發包,還是gtk引擎

gtk的庫肯定是已經裝了,不然你的gnome有可能起來(甚至安裝)麽
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 karron » 2007-02-16 20:01

你这个界面是gtk1的风格...

现在的gtk都是gtk+或者叫gtk2.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#14

帖子 BigSnake.NET » 2007-02-16 20:12

karron 写了:你这个界面是gtk1的风格...

现在的gtk都是gtk+或者叫gtk2.
不..他那是没了主题而已
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
zhuguangxiang
帖子: 52
注册时间: 2006-03-29 16:55
送出感谢: 0
接收感谢: 0

#15

帖子 zhuguangxiang » 2007-02-16 21:40

BigSnake.NET 写了:講清楚你說的gtk是指庫還是開發包,還是gtk引擎

gtk的庫肯定是已經裝了,不然你的gnome有可能起來(甚至安裝)麽
不好意思,呵呵。我指的是GTK开发环境的安装。呵呵。
当然gnome 是基于gtk的了。呵呵。谢谢你的关注!
回复

回到 “老旧版本支持”