[讨论]强悍了!我的TP-LINK TL-WN321G usb 无线网卡终于安装成功了!!

为当前最终发行版之前的所有版本提供支持
回复
liutaoxwl
帖子: 5
注册时间: 2007-02-14 9:06
送出感谢: 0
接收感谢: 0

[讨论]强悍了!我的TP-LINK TL-WN321G usb 无线网卡终于安装成功了!!

#1

帖子 liutaoxwl » 2007-02-16 10:47

安装了一个星期(因为只能晚上下班回家安装),终于把我的TP-LINK TL-WN321G usb无线网卡在ubuntu 6.10下安装成功了。下面把我遇到的问题和方法写一下。

开始我使用的FC5 for i386,使用ndiswrapper 1.23安装网卡安装盘带的WINXP下的rt73.inf并且能够正常使用。后来发现FC5的yum升级安装下载速度比较慢,看到网上人说ubuntu包管理的下载速度比较好,而且系统本身比较有发展前途,我就决定下载装一下。

下载安装了ubuntu 6.10 for amd64 的cd版本。安装后,发现安装盘上的pool的main的n目录下有ndiswrapper的安装包,安装之。然后轻车熟路的安装我的网卡驱动rt73.inf,结果发现用iwlist可以看到我的NETGEAR路由信息。可是就是上不了网,essid也设置好了。每次调用iwlist命令的时候网卡灯会闪亮,说明驱动起来了呀。可就是不能上网,ping我的路由也ping不通。郁闷ing。

可能是ndiswrapper版本不行,还是用1.23版的试试。下载ndiswrapper 1.23的源码,准备编译。make出错!仔细看看错误,找不到已开始就是stdlib.h文件?这不是c运行时吗,默认安装了gcc但是居然不给装这些?赶紧到ubuntu安装盘的pool的main中找到libc libc6 linux-source还有一些忘记了,都给他装上,make好了,make install也好了。ndiswrapper -v命令也显示正确版本1.23,安装驱动。。。还是不能上网!!!!我快崩溃了!

怎么办?直接装rt73的linux驱动。到这里找到rt73-CVS,下载之。然后make 再make install。在/etc下建立了modprbe.conf的文件将第一行的a0改成ausb0(无所谓,人家建议这么做)。然后重新启动。。。在启动过程中我的无线网卡闪了几下,进入系统后,可以上网了!!
上次由 liutaoxwl 在 2007-02-16 11:16,总共编辑 1 次。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2007-02-16 10:58

好好排下版,好给你加个精华.以资鼓励

希望楼主以后多与大家分享使用ubuntu的过程中的经验与想法.

另外,ubuntu安装软件一般用apt-get install xxx ,不需要自己去到安装盘里面去找,然后去安装.建议先看看本站wiki里面的快速设置指南. ubuntu的源的概念很重要,和fc里面的yum安装类似,但是由于ubuntu国内镜像较多,速度很快.

当然如果源里面没有的软件还是需要自己编译或者去找别人编译好的deb包.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
liutaoxwl
帖子: 5
注册时间: 2007-02-14 9:06
送出感谢: 0
接收感谢: 0

#3

帖子 liutaoxwl » 2007-02-16 11:17

刚刚进入ubuntu行列,多谢楼上指点,多谢鼓励。我去看看wiki。
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#4

帖子 dogfox » 2007-02-16 11:23

恭喜lz
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#5

帖子 sinoyster » 2007-02-16 11:56

源里的ndiswrapper就可以用吧,我就用这个网卡,是不是64位的原因
Thank you Ubuntu Team!!!!
I still can't belive this is free...
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#6

帖子 jarlyyn » 2007-02-16 13:46

为什么不用rt73的linux自带驱动…………
头像
sinoyster
帖子: 958
注册时间: 2005-10-16 13:24
来自: 四川成都
送出感谢: 2 次
接收感谢: 0
联系:

#7

帖子 sinoyster » 2007-02-16 13:52

自带的似乎有点问题
Thank you Ubuntu Team!!!!
I still can't belive this is free...
glancegreen
帖子: 7
注册时间: 2007-03-08 10:12
送出感谢: 0
接收感谢: 0

#8

帖子 glancegreen » 2007-03-10 16:59

感谢
按照搂主的说明,我也终于配通了。
tp-link usb tl-wn321g无线网卡。
头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 sensei » 2007-03-12 16:27

没有/etc/modprbe.conf文件,怎么办?
glancegreen
帖子: 7
注册时间: 2007-03-08 10:12
送出感谢: 0
接收感谢: 0

#10

帖子 glancegreen » 2007-03-12 16:42

应该是/etc/modprobe.conf文件,里面就1行。
头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 sensei » 2007-03-12 22:23

glancegreen 写了:应该是/etc/modprobe.conf文件,里面就1行。
恩。是啊。上次我弄好了的。这次怎么也安装不上了。
-l 显示驱动正确,设备正确。但就是在network里没有无线网卡。modprobe.conf文件也没有。奇怪。
我只不过上次是默认中文安装,这次是直接英文安装的而已呀,
头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 sensei » 2007-03-13 11:00

大家的modprobe.conf里面是什么?不知道自己创建一个行不行
回复

回到 “老旧版本支持”