[问题]在windwosXP下格式化Ubuntu安装盘导致系统不能引导的问题

为当前最终发行版之前的所有版本提供支持
回复
togevr
帖子: 3
注册时间: 2007-02-16 21:13
送出感谢: 0
接收感谢: 0

[问题]在windwosXP下格式化Ubuntu安装盘导致系统不能引导的问题

#1

帖子 togevr » 2007-02-16 21:22

我在windows XP(C盘)下,格式化了装在D盘(安装了Ubuntu)。
然后重启winxp,发现机器不能引导了。
我试图修改boot.ini,结果还是不行。

之前,我是先装了windows,再装的ubuntu。然后就有了选择OS的菜单。
我想知道这个菜单是哪个文件控制的?
怎样才能让winxp恢复正常启动呢?

谢谢。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 skyx » 2007-02-16 21:23

no security measure is worth anything if an attacker has physical access to the machine
togevr
帖子: 3
注册时间: 2007-02-16 21:13
送出感谢: 0
接收感谢: 0

#3

帖子 togevr » 2007-02-16 21:31

skyx 写了:viewtopic.php?t=2461

其实我正在看这贴。不过发现好像和我的情况相反啊
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 skyx » 2007-02-16 21:50

一回事,先active c盘,再

fdisk /mbr



fixmbr /a
no security measure is worth anything if an attacker has physical access to the machine
头像
cime63
帖子: 286
注册时间: 2007-01-28 11:53
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 cime63 » 2007-02-17 10:18

我是做了张急救盘(从DOS之家下载的),然后从光盘启动,再选择从硬盘启动,然后就OK了
gman3025
帖子: 151
注册时间: 2007-01-13 18:55
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 gman3025 » 2007-02-17 12:31

嗯,有个问题,ubuntu安装的时候不是要格式化分区的吗?一般都会变成ext3格式的,windows下应该认不到的啊?LZ是怎样格式化的?
togevr
帖子: 3
注册时间: 2007-02-16 21:13
送出感谢: 0
接收感谢: 0

#7

帖子 togevr » 2007-02-19 14:52

仍然不知道,我已经重装系统了。。。。。


回答这位老兄:
gman3025 写了:嗯,有个问题,ubuntu安装的时候不是要格式化分区的吗?一般都会变成ext3格式的,windows下应该认不到的啊?LZ是怎样格式化的?
winxp下面显示的是未知的分区,然后删除后,就可以被windows识别成空白区域,然后就可以继续分区了。。。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 skyx » 2007-02-20 12:05

togevr 写了:仍然不知道,我已经重装系统了。。。。。

折腾的精神还不如我 :lol:
no security measure is worth anything if an attacker has physical access to the machine
头像
eastflying
帖子: 58
注册时间: 2006-12-26 15:30
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 eastflying » 2007-02-21 2:05

晕,很简单的阿,只要随便找张DOS启动盘,运行fdisk /mbr,把mbr重写一下,覆盖掉grub就可以了
回复

回到 “老旧版本支持”