请高人帮忙看看这些代码,我的系统哪里出现错误了

为当前最终发行版之前的所有版本提供支持
回复
tlmht
帖子: 15
注册时间: 2012-10-21 12:24
系统: windows
送出感谢: 0
接收感谢: 0

请高人帮忙看看这些代码,我的系统哪里出现错误了

#1

帖子 tlmht » 2013-03-28 8:38

apt 0.8.16~exp12ubuntu10.7,用于 i386 构架,编译于 Dec 12 2012 13:48:03
Usage: apt-get [options] command
apt-get [options] install|remove pkg1 [pkg2 ...]
apt-get [options] source pkg1 [pkg2 ...]

apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.

Commands:
update - Retrieve new lists of packages
upgrade - Perform an upgrade
install - Install new packages (pkg is libc6 not libc6.deb)
remove - Remove packages
autoremove - Remove automatically all unused packages
purge - Remove packages and config files
source - Download source archives
build-dep - Configure build-dependencies for source packages
dist-upgrade - Distribution upgrade, see apt-get(8)
dselect-upgrade - Follow dselect selections
clean - Erase downloaded archive files
autoclean - Erase old downloaded archive files
check - Verify that there are no broken dependencies
changelog - Download and display the changelog for the given package
download - Download the binary package into the current directory

Options:
-h This help text.
-q Loggable output - no progress indicator
-qq No output except for errors
-d Download only - do NOT install or unpack archives
-s No-act. Perform ordering simulation
-y Assume Yes to all queries and do not prompt
-f Attempt to correct a system with broken dependencies in place
-m Attempt to continue if archives are unlocatable
-u Show a list of upgraded packages as well
-b Build the source package after fetching it
-V Show verbose version numbers
-c=? Read this configuration file
-o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.
This APT has Super Cow Powers.


PS:我的系统是12.04 ,现在左上角出现一个红圆圈,里面有一道白杠,点击显示,发生了一个错误,让我右键菜单运行软件管理器或者通过终端执行apt-get来查看具体错误,然后出现一段代码,最后是“这通常意味着您安装的软件包有未满足的依赖关系”。

然后,我就apt-get,出现了上面那些代码,请教高人,能否帮忙看看,我的系统到底是哪里错了,我应该怎么去解决?
头像
qy117121
论坛版主
帖子: 49892
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 335 次
联系:

Re: 请高人帮忙看看这些代码,我的系统哪里出现错误了

#2

帖子 qy117121 » 2013-03-28 8:40

英文不懂,不过要用apt-get 修复的话,

代码: 全选

sudo apt-get install -f 
渠月 · QY    https://vz.rs/u
本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

Re: 请高人帮忙看看这些代码,我的系统哪里出现错误了

#3

帖子 cuihao » 2013-03-28 8:45

你给的输出没有任何问题……那是帮助信息。
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
tlmht
帖子: 15
注册时间: 2012-10-21 12:24
系统: windows
送出感谢: 0
接收感谢: 0

Re: 请高人帮忙看看这些代码,我的系统哪里出现错误了

#4

帖子 tlmht » 2013-03-28 9:05

qy117121 写了:英文不懂,不过要用apt-get 修复的话,

代码: 全选

sudo apt-get install -f 
我用了你的方法,但是终端出现这个:E: 软件包 linux-headers-3.2.0-38 需要重新安装,但是我无法找到相应的安装文件
我想用新立得去安装,结果因为系统错误,软件打不开。郁闷,应该怎么解决啊
回复

回到 “老旧版本支持”