ubuntu12.04LTS上安装深度软件中心依赖关系的问题

为当前最终发行版之前的所有版本提供支持
回复
张江河
帖子: 12
注册时间: 2013-03-25 22:09
系统: ubuntu 12.04
送出感谢: 1 次
接收感谢: 0

ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#1

帖子 张江河 » 2013-03-28 14:13

如何解决啊,谢谢啦
附件
QQ截图20130328141203.png
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#2

帖子 qy117121 » 2013-03-28 14:20

添加深度的源安装
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#3

帖子 qy117121 » 2013-03-28 16:59

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
b33e
论坛版主
帖子: 3866
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#4

帖子 b33e » 2013-03-28 17:36

需要的几个包在这里手动搜索下载http://packages.linuxdeepin.com/deepin/pool/main/d/
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#5

帖子 qy117121 » 2013-03-28 19:14

下载下面的几个包,放到一个目录里,链接里全
http://packages.linuxdeepin.com/deepin/ ... pin-utils/
http://packages.linuxdeepin.com/deepin/ ... deepin-ui/
http://packages.linuxdeepin.com/deepin/ ... re-center/
http://packages.linuxdeepin.com/deepin/ ... pin-storm/
貌似这几个包不是12.04的,不过没关系

先,
sudo apt-get install xdelta3 aria2
然后终端下 安装上面的四个包
sudo dpkg -i *.deb

可能会有依赖问题,sudo apt-get install -f 修复
2013-03-28截图.png
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#6

帖子 qy117121 » 2013-03-28 19:31

加源的话
编辑/etc/apt/sources.list
添加
deb http://mirrors.ustc.edu.cn/deepin precise main non-free
deb http://mirrors.ustc.edu.cn/deepin precise-updates main non-free
deb-src http://mirrors.ustc.edu.cn/deepin precise main non-free
deb-src http://mirrors.ustc.edu.cn/deepin precise-updates main non-free

sudo apt-get update
会提示没签名,不用管
正在读取软件包列表... 完成
W: GPG 错误:http://mirrors.ustc.edu.cn precise InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 0A40427E209088E7
W: GPG 错误:http://mirrors.ustc.edu.cn precise-updates InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 0A40427E209088E7

代码: 全选

sudo apt-get install deepin-software-center 
就会安装好,版本是 2.1.4 不是最新的3.0
23.png
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
张江河
帖子: 12
注册时间: 2013-03-25 22:09
系统: ubuntu 12.04
送出感谢: 1 次
接收感谢: 0

Re: ubuntu12.04LTS上安装深度软件中心依赖关系的问题

#7

帖子 张江河 » 2013-04-06 18:39

qy117121 写了:加源的话
编辑/etc/apt/sources.list
添加
deb http://mirrors.ustc.edu.cn/deepin precise main non-free
deb http://mirrors.ustc.edu.cn/deepin precise-updates main non-free
deb-src http://mirrors.ustc.edu.cn/deepin precise main non-free
deb-src http://mirrors.ustc.edu.cn/deepin precise-updates main non-free

sudo apt-get update
会提示没签名,不用管
正在读取软件包列表... 完成
W: GPG 错误:http://mirrors.ustc.edu.cn precise InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 0A40427E209088E7
W: GPG 错误:http://mirrors.ustc.edu.cn precise-updates InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 0A40427E209088E7

代码: 全选

sudo apt-get install deepin-software-center 
就会安装好,版本是 2.1.4 不是最新的3.0
23.png
谢谢啦!!!
回复

回到 “老旧版本支持”