12.10 openjdk-7-jre无法安装

为当前最终发行版之前的所有版本提供支持
回复
zhuokj
帖子: 3
注册时间: 2010-12-16 15:58
送出感谢: 0
接收感谢: 0

12.10 openjdk-7-jre无法安装

#1

帖子 zhuokj » 2013-04-06 0:32

我的系统版本是64位的12.10。
但是不知为什么系统居然不自带jre。终端输入java -version显示:
程序 'java' 已包含在下列软件包中:
* default-jre
* gcj-4.6-jre-headless
* gcj-4.7-jre-headless
* openjdk-7-jre-headless
* openjdk-6-jre-headless
请尝试:sudo apt-get install <选定的软件包>
使用sudo apt-get install openjdk-7-jre显示如下:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
openjdk-7-jre : 依赖: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.10.1) 但是它将不会被安装
依赖: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) 但无法安装它
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
而且我发现使用“sudo apt-get update"之后还出现这个问题:
W: 无法下载 bzip2:/var/lib/apt/lists/partial/mirrors.163.com_ubuntu_dists_quantal_main_binary-amd64_Packages Hash 校验和不符

W: 无法下载 bzip2:/var/lib/apt/lists/partial/ppa.launchpad.net_webupd8team_java_ubuntu_dists_quantal_main_binary-amd64_Packages Hash 校验和不符

W: 无法下载 bzip2:/var/lib/apt/lists/partial/ppa.launchpad.net_webupd8team_java_ubuntu_dists_quantal_main_binary-i386_Packages Hash 校验和不符
不知道与无法安装openjdk有无关联。



今天上网搜索了一下安装oracle jdk的方法,成功安装了oracle jdk。
方法如下:
Ubuntu12 10版本下,不再预装JDK,包括OpenJdk,所以我们要从Oracle官网上下载java7的压缩包,选择适合自己电脑的安装包,我选的是jdk-7u9-linux-i586.tar.gz。

然后解压该文件: tar -xvf jdk-7u9-linux-i586.tar.gz

解压后得到的文件目录为jdk1.7.0_09 把它移动到/usr/lib/jvm/
sudo mv jdk1.7.0_09 /usr/lib/jdk

然后执行安装命令:

sudo update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.7.0_04/bin/javac 1
sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7.0_04/bin/java 1

设置环境变量:

sudo update-alternatives --config javac
sudo update-alternatives --config java

需要选择一个模式作为默认或者是优先使用的,输入一个数字就可以了。我选择的是 2 ,即 oracle的 jdk1.7.0_09 。

到这里,可以在终端输入 java -version ,若能看到java 的版本信息,说明java安装成功了。我的显示:

java version "1.7.0_09"
Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
Java HotSpot(TM) Server VM (build 23.5-b02, mixed mode)

配置JAVA_HOME和CLASSPATH:

export JAVA_HOME=/usr/lib/jdk

export CLASSPATH=./:$JAVA_HOME

上面红色部分尤其注意。不然,用java命令执行.class文件时会报:错误: 找不到或无法加载主类 这样的错误。
源自:http://my.oschina.net/ctojp/blog/89908
回复

回到 “老旧版本支持”