终端安装软件时提示需要手动安装?

为当前最终发行版之前的所有版本提供支持
回复
hacker85
帖子: 557
注册时间: 2010-02-25 11:19
送出感谢: 0
接收感谢: 0

终端安装软件时提示需要手动安装?

#1

帖子 hacker85 » 2013-04-08 20:13

o@O:~$ sudo apt-get install ia32-libs*
[sudo] password for o:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
注意,根据正则表达式 ia32-libs* 选中了 ia32-libs-multiarch
注意,根据正则表达式 ia32-libs* 选中了 ia32-libs
注意,根据正则表达式 ia32-libs* 选中了 ia32-libs-dev
注意,根据正则表达式 ia32-libs* 选中了 ia32-libs-gtk
注意,根据正则表达式 ia32-libs* 选中了 ia32-libs-sdl
注意,选取 ia32-libs 而非 ia32-libs-gtk
注意,选取 ia32-libs-multiarch:i386 而非 ia32-libs-multiarch
注意,选取 ia32-libs 而非 ia32-libs-sdl
ia32-libs 已经是最新的版本了。
ia32-libs-multiarch:i386 已经是最新的版本了。
ia32-libs-multiarch:i386 被设置为手动安装。 =======> 手动安装??? 怎么个操作过程?
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
头像
tommy007
帖子: 1352
注册时间: 2007-02-18 0:42
送出感谢: 0
接收感谢: 10 次

Re: 终端安装软件时提示需要手动安装?

#2

帖子 tommy007 » 2013-04-08 20:31

之前已经根据依赖安装了。但是因为你这次命令,把这个包标记为手动安装。如果之前安装这个依赖的软件被删除,也不会被apt-get autoremove掉
hacker85
帖子: 557
注册时间: 2010-02-25 11:19
送出感谢: 0
接收感谢: 0

Re: 终端安装软件时提示需要手动安装?

#3

帖子 hacker85 » 2013-08-24 21:54

tommy007 写了:之前已经根据依赖安装了。但是因为你这次命令,把这个包标记为手动安装。
1、这貌似是一种软件安装机制是吧?
2、假设是在新产得里,那么就相当于把已经安装过得软件再点击了一次“标记以便手动安装”?
如果之前安装这个依赖的软件被删除,也不会被apt-get autoremove掉
虽然不会被remove掉,那么如果真想去掉这个设置的话,该会有办法的,是什么呢? 总不能先安装上新立得,然后再到新立得里去
一个个的设置吧?
回复

回到 “老旧版本支持”