【已解决】ubuntu12.10使用android SDK aapt,找不到ibz.so.1

为当前最终发行版之前的所有版本提供支持
回复
bixiaopeng
帖子: 2
注册时间: 2013-04-10 1:42
系统: Ubuntu
送出感谢: 0
接收感谢: 0

ubuntu12.10使用android SDK出现找不到ibz.so.1

#1

帖子 bixiaopeng » 2013-04-10 2:01

error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or...
ia32-libs 不能安装,依赖关系上的
下列软件包有未满足的依赖关系:
ia32-libs-multiarch:i386 : 依赖: gstreamer0.10-plugins-base:i386 但是它将不会被安装
依赖: gstreamer0.10-plugins-good:i386 但是它将不会被安装
依赖: libcurl3:i386 但是它将不会被安装
依赖: libnspr4:i386 但是它将不会被安装
依赖: libnss3:i386 但是它将不会被安装
依赖: libqtwebkit4:i386 但是它将不会被安装
依赖: librsvg2-common:i386 但是它将不会被安装
依赖: libssl1.0.0:i386 但是它将不会被安装
依赖: libxml2:i386 但是它将不会被安装
依赖: libxslt1.1:i386 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

求帮助。。。
bixiaopeng
帖子: 2
注册时间: 2013-04-10 1:42
系统: Ubuntu
送出感谢: 0
接收感谢: 0

【已解决】ubuntu12.10使用android SDK aapt,找不到ibz.so.1

#2

帖子 bixiaopeng » 2013-04-10 2:32

经过大半夜的搜索总算是搞定了:
去软件源里面,把下载自那个地方的源换成主服务器,update一下,如果没有问题的话,继续install就应该可以成功了。
感谢http://blog.csdn.net/fdl19881/article/details/7436260的灵感。。。
还要努力~
-------------------------------------------
[2013-04-10 02:30:55 - JPVerb] /home/bixiaopeng/workextend/adt-bundle-linux-x86_64-20130219/sdk/platform-tools/aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
[2013-04-10 02:30:55 - JPVerb-test] /home/bixiaopeng/workextend/adt-bundle-linux-x86_64-20130219/sdk/platform-tools/aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
安装ia32失败,依赖包不能安装:
error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or...
ia32-libs 不能安装,依赖关系上的
下列软件包有未满足的依赖关系:
ia32-libs-multiarch:i386 : 依赖: gstreamer0.10-plugins-base:i386 但是它将不会被安装
依赖: gstreamer0.10-plugins-good:i386 但是它将不会被安装
依赖: libcurl3:i386 但是它将不会被安装
依赖: libnspr4:i386 但是它将不会被安装
依赖: libnss3:i386 但是它将不会被安装
依赖: libqtwebkit4:i386 但是它将不会被安装
依赖: librsvg2-common:i386 但是它将不会被安装
依赖: libssl1.0.0:i386 但是它将不会被安装
依赖: libxml2:i386 但是它将不会被安装
依赖: libxslt1.1:i386 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

求帮助。。。
回复

回到 “老旧版本支持”