求救啊 无法安装软件

为当前最终发行版之前的所有版本提供支持
回复
dishuishi
帖子: 7
注册时间: 2011-12-01 18:48
送出感谢: 0
接收感谢: 0

求救啊 无法安装软件

#1

帖子 dishuishi » 2013-04-18 23:11

安装软件时出现
E: 无法打开锁文件 /var/lib/dpkg/lock - open (20: 不是目录)
E: 无法对状态列表目录加锁(/var/lib/dpkg/),请查看您是否正以 root 用户运行?
谢谢各位!
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

Re: 求救啊 无法安装软件

#2

帖子 cuihao » 2013-04-18 23:21

在哪里安装软件出现这条信息的?
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
dishuishi
帖子: 7
注册时间: 2011-12-01 18:48
送出感谢: 0
接收感谢: 0

Re: 求救啊 无法安装软件

#3

帖子 dishuishi » 2013-04-19 15:30

在终端用命令安装就出现这个
使用软件包安装程序安装提示
软件索引已损坏
这是您软件管理系统的重大失败。请使用新立得检查损坏的软件包,检查文件权限和 '/etc/apt/sources.list' 文件的正确性并使用 'sudo apt-get update' 和 'sudo apt-get install -f' 重新载入软件信息。
使用新立得就又出现我前面写的提示。
头像
b33e
论坛版主
帖子: 3866
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: 求救啊 无法安装软件

#4

帖子 b33e » 2013-04-19 15:47

应该是你之前装软件中断过 :em01
附件
Screenshot.png
头像
qy117121
论坛版主
帖子: 49939
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 333 次
联系:

Re: 求救啊 无法安装软件

#5

帖子 qy117121 » 2013-04-19 15:50

确保当前没有打开两个软件包管理软件,如新立得,软件中心 什么的
然后可以把那个锁删除
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
回复

回到 “老旧版本支持”