请问如何删除编译失败的内核

为当前最终发行版之前的所有版本提供支持
回复
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

请问如何删除编译失败的内核

#1

帖子 nbdxkfq » 2007-02-23 23:31

我在编译2.6.20.1时不知道什么原因导致最后无法成功,请问我想再编译一遍是否需要把编译失败的删掉?如何删除,谢谢
jianliang79
帖子: 53
注册时间: 2006-10-28 21:14
来自: 北京
送出感谢: 0
接收感谢: 0

Re: 请问如何删除编译失败的内核

#2

帖子 jianliang79 » 2007-02-25 11:17

nbdxkfq 写了:我在编译2.6.20.1时不知道什么原因导致最后无法成功,请问我想再编译一遍是否需要把编译失败的删掉?如何删除,谢谢
我觉得不需要。

但如果你一定要删的话,删除以下几个地方:
1)删除/boot/grub/menu.lst文件中有关2.6.20.1的部分
2)删除/boot下面所有有关2.6.20.1的文件
3)删除/lib/modules/下的2.6.20.1目录
头像
booker
帖子: 116
注册时间: 2006-04-22 10:50
来自: Mito
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 booker » 2007-02-25 12:27

编译没有成功么?

没有生成deb,没有安装的话,不需要删除什么东西。再次编译之前似乎只要make-kpkg clean把先前编译的结果清除一下即可。
Ubuntu only now on Dell XPS M1710
回复

回到 “老旧版本支持”