请问能不能通过网上升级的方式升级内核而不用自己编译,谢谢

为当前最终发行版之前的所有版本提供支持
回复
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

请问能不能通过网上升级的方式升级内核而不用自己编译,谢谢

#1

帖子 nbdxkfq » 2007-02-23 23:45

编译了两次都是在做包时出现警告等不同的错误http://forum.ubuntu.org.cn/viewtopic.php?t=42135,然后就不能进系统,请问有办法不用编译升级系统的吗?谢谢,另外我不知道怎么用新立得删除内核,能教教我吗?谢谢,我想把编译错误的新内核删掉,谢谢
头像
booker
帖子: 116
注册时间: 2006-04-22 10:50
来自: Mito
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 booker » 2007-02-25 12:45

要删除出错的内核,可以

代码: 全选

dpkg -l linux-image-*
dpkg -l linux-headers-*
查看当前安装了哪些内核版本。

要删除对应的,只要

代码: 全选

sudo dpkg --purge 包名
就可以了。

一般来说自己编译安装的内核,只有两个包,一个是linux-image-<版本号>,一个是linux-headers-<版本号>。

而系统默认的内核,默认似乎linux-headers是不装的,但是有linux-restricted-modules
Ubuntu only now on Dell XPS M1710
回复

回到 “老旧版本支持”