[分享]用 Geforce 6100 nforce 405 主板 硬盘安装 ubuntu 6.10 Edgy

为当前最终发行版之前的所有版本提供支持
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

[分享]用 Geforce 6100 nforce 405 主板 硬盘安装 ubuntu 6.10 Edgy

#1

帖子 flyinflash » 2007-02-24 1:29

用 Geforce 6100 nforce 405 主板 硬盘安装 ubuntu 6.10 Edgy


1、硬盘安装 Edgy
2、手动升级到内核版本到 2.6.20-5
3、设置置pppoe和更新源
4、安装显卡驱动及berly
5、初步设置优化
6、其它


* 机器配置是:AsRock AM2NF6G-VSTA,主芯片为Geforce 6100 nforce 405,512MB RAM 。



1、硬盘安装 Edgy

Edgy 的内核版本为 2.6.17 不支持 c61等系列芯片的主板,安装以后网声显均无法正常工作。解决方法有许多,其中一种是手动升级内核版本到 2.6.18 以上,这里选 2.6.20-5 。

硬盘安装的具体方法
viewtopic.php?t=26167

*硬盘安装文件iso放在G盘,加入了ubuntu.fs和swap.fs支持,安装完Edgy系统后作收藏。要注意的是,ubuntu.fs必需先WinRAR解压,选越大越耗时。
*分区:
  • sda1 WinXP NTFS C
    sda5 WinXP NTFS D
    sda6 WinXP NTFS E
    sda7 (share) FAT32 F
    sda8 Linux EXT3 / 3G
    sda9 Linux swap sawp 1G
    sda10 Linux EXt3 /home 4G
    sda11 Linux Ext3 /usr 5G
    sda12 Linux Ext3 /var 6G
    sda13 (bacup) FAT32 G
*sda1为主分区,其余全部为扩展分区。主分区上限为4个,所以win下的D盘在win下标记为sda5,而不是sda2。
*/是系统文件所在地,相当于Win下的C盘,/home是用户文件夹,相当于Win下的“我的文档”和“用户配置文件”。
*重启到Win,下载 2.6.20-5 内核相关文件到F盘(sda7),为内核升级准备。

http://archive.ubuntu.org.cn/ubuntu/poo ... 7_i386.deb

http://archive.ubuntu.org.cn/ubuntu/poo ... 6_i386.deb

http://archive.ubuntu.org.cn/ubuntu/poo ... 6_i386.deb

*修复MBR,主要是开机提速和防止重装win后不能引导Linux。
[分享]一劳永逸,让win的重装不改变linux的引导(单硬盘,重装后mbr不用改动!)
viewtopic.php?t=34110



2、手动升级到内核版本到 2.6.20-5

重启入ubuntu图形界面,进入内核所在目录,双击安装内核相关的三个.deb文件。

*安装deb包可在图形界面下双击安装(deb包能自动选择路径自动安装,有点似win下的.bat),也可在终瑞中输入

代码: 全选

cd /media/sda7
//转入deb包所在目录

代码: 全选

sudo dpkg -i *.deb
//安装

安装完后重启,在引导菜单会发现多了两条 ubuntu 6.10 Edgy 2.6.20-5 之类的,选择这个进入。



3、设置pppoe虚拟网卡驱动和更新源

终端输入

代码: 全选

#sudo pppoeconf
更新源:
快速设置指南(Edgy 6.10)版
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 97/EdgyEft



4、安装显卡驱动及berly

NVIDIA显卡安装配置指南
http://wiki.ubuntu.org.cn/NVIDIA%E6%98% ... 7%E5%8D%97



5、初步设置优化

Beryl在Edgy+nVIDIA显卡系统上的安装
http://wiki.ubuntu.org.cn/Beryl-Edgy-nVIDIA

*选用第一个
deb http://www.beerorkid.com/compiz edgy main-edgy deb http://media.blutkind.org/xgl/ edgy main-edgy deb http://compiz-mirror.lupine.me.uk/ edgy main-edgy deb http://ubuntu.compiz.net/ edgy main-edgy


快速设置指南(Edgy 6.10)版
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... 97/EdgyEft

*在berly默认主题下,运行终瑞有bug,它会是一片空白的,看不到任何东西。更新主题即可。
*berly主要作用是方便切换窗口,多桌面工作和视觉享受,目录为非正式版本,可要可不要。



6、其它

Edgy下的字体其实不是很难看,习惯了就好;

Firefox是非常非常非常强大、安全的浏览器(虽然我还是觉得 Greenbroswe 人性化点),假如安装上多多的插件和扩展;

Gaim是非常非常非常强大的即时通讯工具,假如安装上多多的插件和扩展。最新版本已经支持OICQ;

Win下的软件,Linux上大多有代替品,但要有心理准备,不是“一模一样”的;

Linux上是可是运行Win的程序的,不过比较麻烦,需要安装配置虚拟环境;

没有必要让系统开启自动更新,尤其是使用了 2.6.20-8 内核 之后。其实更新可自己在 Synaptic 操作。



参考资料:
[教学]ubuntu常见问题指南发帖问问题前必看 07/02/19 更新
viewtopic.php?t=35100

Ubuntu 的中文文档
http://wiki.ubuntu.org.cn/
上次由 flyinflash 在 2007-02-28 1:13,总共编辑 5 次。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 skyx » 2007-02-24 9:08

天啊,下载内核deb安装,ee看了会骂的。 8) 8)
no security measure is worth anything if an attacker has physical access to the machine
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

Re: [分享]用 Geforce 6100 nforce 405 主板 硬盘安装 ubuntu 6.10 Edgy

#3

帖子 skyx » 2007-02-24 9:11

flyinflash 写了:


1、硬盘安装 Edgy

Edgy 的内核版本为 2.6.17 不支持 c51、
谁说c51不支持,dapper都没问题。不要误导。 :lol: 8)
no security measure is worth anything if an attacker has physical access to the machine
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

Re: [分享]用 Geforce 6100 nforce 405 主板 硬盘安装 ubuntu 6.10 Edgy

#4

帖子 flyinflash » 2007-02-24 9:18

skyx 写了:
flyinflash 写了:


1、硬盘安装 Edgy

Edgy 的内核版本为 2.6.17 不支持 c51、
谁说c51不支持,dapper都没问题。不要误导。 :lol: 8)
呵呵,马上就修改。
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

#5

帖子 flyinflash » 2007-02-24 9:22

skyx 写了:天啊,下载内核deb安装,ee看了会骂的。 8) 8)
旧内核认不出我的网显声,难道重新编译内核?重新编译内核也要下载几个包哦,但是网卡认不出也就上不了网……

我印象中ee给我推荐过一个包,是2.6.20-8的,我觉得太新,不敢用~~ :em04
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 skyx » 2007-02-24 9:29

flyinflash 写了:
skyx 写了:天啊,下载内核deb安装,ee看了会骂的。 8) 8)
旧内核认不出我的网显声,难道重新编译内核?重新编译内核也要下载几个包哦,但是网卡认不出也就上不了网……

我印象中ee给我推荐过一个包,是2.6.20-8的,我觉得太新,不敢用~~ :em04

你帖的几个deb我以前安装过,没什么问题。

不过有个deb我记得早就下载了

viewtopic.php?t=41780&highlight=skyx+wget
no security measure is worth anything if an attacker has physical access to the machine
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

#7

帖子 flyinflash » 2007-02-24 10:31

安照上面,安装不了系统可以找我 :em04

正在使用ubuntu中……

mp3----Rhythmbox 0.9.6
rmvb----Totem 2.16.2
pdf----Adobe Reader 8.0
chm----Firefox 2.0.0.1
C----gcc 4.1.2

找不到一个能比较完全代替win下几何画板的工具
:(
kash
帖子: 23
注册时间: 2007-01-13 1:39
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 kash » 2007-02-24 12:40

我就是这个配置,用的好好的,更本不需要升级什么内核,声卡和网卡都能识别,默认安装显卡驱动不太好,但是能进x,只要安个nvidia的驱动就ok了。
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 skyx » 2007-02-24 12:42

flyinflash 写了:安照上面,安装不了系统可以找我 :em04

viewtopic.php?t=41780&highlight=skyx+wget


那当然不用找你,deb都下不了,怎么可能找你哦
:lol: :lol:
no security measure is worth anything if an attacker has physical access to the machine
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

#10

帖子 flyinflash » 2007-02-24 12:53

skyx 写了:
flyinflash 写了:安照上面,安装不了系统可以找我 :em04

viewtopic.php?t=41780&highlight=skyx+wget


那当然不用找你,deb都下不了,怎么可能找你哦
:lol: :lol:

你好坏哦
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

#11

帖子 flyinflash » 2007-02-24 12:54

kash 写了:我就是这个配置,用的好好的,更本不需要升级什么内核,声卡和网卡都能识别,默认安装显卡驱动不太好,但是能进x,只要安个nvidia的驱动就ok了。

20是双数,17是单数
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 zhuqin_83 » 2007-02-24 12:59

flyinflash 写了:
skyx 写了:
flyinflash 写了:安照上面,安装不了系统可以找我 :em04

viewtopic.php?t=41780&highlight=skyx+wget


那当然不用找你,deb都下不了,怎么可能找你哦
:lol: :lol:

你好坏哦
两个女生。。。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#13

帖子 Decease » 2007-02-25 20:14

flyinflash 写了:安照上面,安装不了系统可以找我 :em04

正在使用ubuntu中……

mp3----Rhythmbox 0.9.6
rmvb----Totem 2.16.2
pdf----Adobe Reader 8.0
chm----Firefox 2.0.0.1
C----gcc 4.1.2

找不到一个能比较完全代替win下几何画板的工具
:(
几何画板GIMP Image Editor 运行:终端输入gimp-remote-2.2 %U
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#14

帖子 huangjiahua » 2007-02-26 22:36

几何画板又不是图像处理工具。


类似几何画板的可以先试试 kig
跃过无数的时间断层,只为了在
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#15

帖子 Decease » 2007-02-27 12:15

huangjiahua 写了:几何画板又不是图像处理工具。


类似几何画板的可以先试试 kig
虚心接受指教..
回复

回到 “老旧版本支持”