[问题]出现未满足依赖关系(已解决)

为当前最终发行版之前的所有版本提供支持
回复
mdblg
帖子: 43
注册时间: 2006-12-20 9:50
来自: CHN xj
送出感谢: 0
接收感谢: 0

[问题]出现未满足依赖关系(已解决)

#1

帖子 mdblg » 2007-02-24 15:22

1,我的显卡是NV的GO 7300,按照wiki的说法要升级成nvidia-glx,但是下载的时候出现下列字样:

为满足依赖关系:
nvidia-glx:
依赖: nvidia-kernel-1.0.9631
依赖: nvidia-glx

已经解决了:
具体方法:按照skyx的提供的方法:
deb http://nvidia.limitless.lupine.me.uk/ubuntu edgy stable-9631
wget http://nvidia.limitless.lupine.me.uk/ub ... .me.uk.gpg -O- | sudo apt-key add -

然后:
sudo apt-get install nvidia-glx -d
sudo apt-get install nvidia-glx

重启,这时多了一个选项条 ubutnu-6.10 geXXXXXXXX-386,选择,出现nvidia的标志,搞定......
谢谢skyx......
上次由 mdblg 在 2007-02-25 0:43,总共编辑 3 次。
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#2

帖子 Decease » 2007-02-24 15:22

把他们全部下载并且安装咯...
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-02-24 15:23

试下
把下面的源加入:

deb http://nvidia.limitless.lupine.me.uk/ubuntu edgy stable

保存后:
wget http://nvidia.limitless.lupine.me.uk/ub ... .me.uk.gpg -O- | sudo apt-key add -

sudo apt-get update && sudo apt-get install linux-restricted-modules-$(uname -r) nvidia-glx

sudo nvidia-xconfig --add-argb-glx-visuals

装好以后是9746的
no security measure is worth anything if an attacker has physical access to the machine
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#4

帖子 Decease » 2007-02-24 15:27

不用这么麻烦吧..
新立得源有 只不过nvidia-kernel-1.0.9625
mdblg
帖子: 43
注册时间: 2006-12-20 9:50
来自: CHN xj
送出感谢: 0
接收感谢: 0

#5

帖子 mdblg » 2007-02-24 16:10

谢谢,不过我试了,还是不行......
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2007-02-24 17:35

aptitude 注意看清楚再確定
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
mdblg
帖子: 43
注册时间: 2006-12-20 9:50
来自: CHN xj
送出感谢: 0
接收感谢: 0

#7

帖子 mdblg » 2007-02-24 17:40

BigSnake.NET 写了:aptitude 注意看清楚再確定
aptitude???
头像
Decease
帖子: 834
注册时间: 2006-12-14 20:33
送出感谢: 0
接收感谢: 0

#8

帖子 Decease » 2007-02-24 17:45

aptitude
终端下的软件包工具
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#9

帖子 skyx » 2007-02-24 17:48

加这个源

代码: 全选

deb http://nvidia.limitless.lupine.me.uk/ubuntu edgy stable-9631
然后

代码: 全选

wget http://nvidia.limitless.lupine.me.uk/ubuntu/root@lupine.me.uk.gpg -O- | sudo apt-key add -

再安装

nvidia-glx  装完后是9631的。
no security measure is worth anything if an attacker has physical access to the machine
mdblg
帖子: 43
注册时间: 2006-12-20 9:50
来自: CHN xj
送出感谢: 0
接收感谢: 0

#10

帖子 mdblg » 2007-02-24 17:54

skyx 写了:加这个源

代码: 全选

deb http://nvidia.limitless.lupine.me.uk/ubuntu edgy stable-9631
然后

代码: 全选

wget http://nvidia.limitless.lupine.me.uk/ubuntu/root@lupine.me.uk.gpg -O- | sudo apt-key add -

再安装

nvidia-glx  装完后是9631的。
谢谢,我加过了,速度太慢了,呵呵,几千B,好像也只能这样子了
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 skyx » 2007-02-24 17:59

mdblg 写了:
skyx 写了:加这个源

代码: 全选

deb http://nvidia.limitless.lupine.me.uk/ubuntu edgy stable-9631
然后

代码: 全选

wget http://nvidia.limitless.lupine.me.uk/ubuntu/root@lupine.me.uk.gpg -O- | sudo apt-key add -

再安装

nvidia-glx  装完后是9631的。
谢谢,我加过了,速度太慢了,呵呵,几千B,好像也只能这样子了
最多15M,有几kb也可以的。

安装时

sudo apt-get install nvidia-glx -d

如果出错,再来一次:


sudo apt-get install nvidia-glx -d

直到没错。

完成后再

sudo apt-get install nvidia-glx
接下来和wiki上的做法一样。
no security measure is worth anything if an attacker has physical access to the machine
onemoretouch
帖子: 84
注册时间: 2007-03-20 8:23
送出感谢: 0
接收感谢: 0

#12

帖子 onemoretouch » 2007-03-26 23:52

为什么我成功把升到了9631,nvidia-glx也装上了,那个386的内核也装上了,可还是没有Nvidia标志出现呢?
我以前按网上的手动方法装过驱动,但没成功,不知道这个会不会有影响
冰封尘
帖子: 162
注册时间: 2005-04-09 7:23
来自: 云南
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 冰封尘 » 2007-03-27 4:38

skyx 写了:试下
把下面的源加入:

deb http://nvidia.limitless.lupine.me.uk/ubuntu edgy stable

保存后:
wget http://nvidia.limitless.lupine.me.uk/ub ... .me.uk.gpg -O- | sudo apt-key add -

sudo apt-get update && sudo apt-get install linux-restricted-modules-$(uname -r) nvidia-glx

sudo nvidia-xconfig --add-argb-glx-visuals

装好以后是9746的
按照此方法安装后运行sudo nvidia-glx-config enable
Error: unable to load nvidia kernel driver! Be sure to have installed
the nvidia driver for your running kernel.
求解
回复

回到 “老旧版本支持”