求助!关于依赖关系的问题!

为当前最终发行版之前的所有版本提供支持
回复
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

求助!关于依赖关系的问题!

#1

帖子 ikey » 2005-10-16 10:55

我在装ggobi的时候,它告诉我:
ggobi:
依赖: libglib1.2 (>=1.2.0) but it is not installable
依赖: libgtk1.2 (>=1.2.10-4) but it is not installable


libglib1.2 ,libgtk1.2我怎么才能装上去呢?另外,我装软件的时候,make从来没有成功过!是不是和上面的包有关系啊?求各位帮忙啊!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yongyi » 2005-10-16 11:24

源里头有没有?直接apt-get行不?
make不行是不是连编译环境都没安装呀?ubuntu默认没安装的。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
snonow
帖子: 251
注册时间: 2005-09-08 9:01
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 snonow » 2005-10-16 11:25

你的源里没有那两个东西可以安装:)
BenQ P41-C30
\找不到64位软件已经是历史了
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 yongyi » 2005-10-16 11:31

你的ggobi 是哪弄来的?.deb?基于什么发行版编译打包的?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

#5

帖子 ikey » 2005-10-16 12:09

连编译环境都装上了!这是make fcitx时候出错的情况:
ikey@ikey:~/fcitx$ make
cd . && /bin/sh /home/ikey/fcitx/missing --run autoheader
/home/ikey/fcitx/missing: line 46: autoheader: command not found
WARNING: `autoheader' is missing on your system. You should only need it if
you modified `acconfig.h' or `configure.in'. You might want
to install the `Autoconf' and `GNU m4' packages. Grab them
from any GNU archive site.
rm -f stamp-h1
touch config.h.in
cd . && /bin/sh ./config.status config.h
config.status: creating config.h
config.status: config.h is unchanged
make all-recursive
make[1]: Entering directory `/home/ikey/fcitx'
Making all in doc
make[2]: Entering directory `/home/ikey/fcitx/doc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/ikey/fcitx/doc'
Making all in tools
make[2]: Entering directory `/home/ikey/fcitx/tools'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../src -I../lib -g -O2 -INONE -Wall -MT mb2txt.o -MD -MP -MF ".deps/mb2txt.Tpo" -c -o mb2txt.o mb2txt.c; \
then mv -f ".deps/mb2txt.Tpo" ".deps/mb2txt.Po"; else rm -f ".deps/mb2txt.Tpo"; exit 1; fi
gcc -g -O2 -INONE -Wall -o mb2txt mb2txt.o -LNONE -lX11
/usr/bin/ld: cannot find -lX11
collect2: ld 返回 1
make[2]: *** [mb2txt] 错误 1
make[2]: Leaving directory `/home/ikey/fcitx/tools'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/ikey/fcitx'
make: *** [all] 错误 2
ikey@ikey:~/fcitx$

只要有提示的,我什么都试过,缺什么我就试过装什么!
但是不光是fcitx,从来没有 make成功一个东西!最后装fcitx还是用rpm装的!


ggobi 是新立得里面的!



TO: snonow

那我该怎么装libglib1.2 和libgtk1.2呢?
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

#6

帖子 ikey » 2005-10-16 12:51

libglib1.2 libgtk1.2 找到了!再试!
头像
snonow
帖子: 251
注册时间: 2005-09-08 9:01
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 snonow » 2005-10-16 17:58

成功了没有?
我没试过,是不是提示autoheader没有?
BenQ P41-C30
\找不到64位软件已经是历史了
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

#8

帖子 ikey » 2005-10-16 19:12

失败了!不知道怎么办了!可能不是那两个东西的问题!装了那两个子东西还是没有成功!从来没有make成功一个软件阿!就刚才装了个amap,还是强行装是去的!一堆错误!装是装上了,可是没有办法用啊!

不知道是重装还是重新投入红帽的怀抱?高手来救我啊!!!1
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yongyi » 2005-10-16 20:49

You might want
to install the `Autoconf' and `GNU m4' packages.

这安装了没?
fcitx版本多少?我还真从来没试过编译fcitx不通过的呀。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

#10

帖子 ikey » 2005-10-16 21:12

装fcitx的时候,各个版本都试了!最后找个rpm装上了!所以再就没有 试它了,但是fcitx不能随系统启动!
不可能每个我要的软件源里面都有啊?也不太可能找到每个软件的rpm啊!不知道怎么解决make问题啊! :cry: :cry:

不知道怎么搞的,不管什么软件,就是不让我make!真象伺候爷爷一样!有多少人象我一样什么都不能make 呢?怎么解决的呢?
上次由 ikey 在 2005-10-16 21:16,总共编辑 1 次。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 yongyi » 2005-10-16 21:16

fcitx的设置,你搜索一下主页或论坛,都有的。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

#12

帖子 ikey » 2005-10-16 21:19

yongyi回复好快啊!
现在不想管fcitx了!我现在想装其他的东西!就是不让我装!
其中在装hydra5.0(一个暴力破解工具)的时候,明明我有的东西,他提示没有!

你make其他软件有问题吗?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#13

帖子 eexpress » 2005-10-16 21:29

ikey 写了:明明我有的东西,他提示没有!

你看到的,系统不一定认到。需要在特定路径的指定版本才可以。比如libglib1.2,如果不在/etc/ld.so.conf内所列的目录下,就等于没有。
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 yongyi » 2005-10-16 21:52

基本上./configure通过的,make出问题的机会比较少。至少我遇到的情况是这样。
当然编译出错,可以说是常事,把它需要的安装好,基本上就OK了。(当然,那软件源码得本身就没问题的)
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
ikey
帖子: 155
注册时间: 2005-10-09 15:25
送出感谢: 0
接收感谢: 0

#15

帖子 ikey » 2005-10-16 22:22

源码应该没有问题!因为有的我以前在红帽上装过的!

过几天重装试试!没有办法了!
回复

回到 “老旧版本支持”