当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [贴图][原创]简单设置系统,跟我一样刚刚装Ubuntu的菜鸟必看
帖子发表于 : 2005-10-16 23:06 

注册: 2005-10-14 2:56
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
前言:我也是刚刚接触DEBIAN的菜鸟,经过昨天安装数遍的系统,经过昨天的跌打滚爬,终于用了8-9个小时的时间配置好了系统,为了让以后方面,所以我今天又再一次的安装配置了它,又随笔些下了这篇手记,希望下次能够按照它能够很快的配置好一个系统。我贴出自己的笔记的原因就是希望大家少走弯路,能尽快的进入DEBIAN的美好世界。希望各位高手能够补充我的不足的地方,也欢迎跟我交流,我的QQ:545121


安装ubunt以后需要apt-get很多东西,所以你得需要一个很好的网络环境才能完成下面的工作。

1。首先安装系统 OK

2。更改软件包源。修改/etc/apt/sources.list 文件,使用sudo gedit命令。
终端命令:
$:sudo gedit /etc/apt/sources.list
删除原有文本中的软件源,再添加:
deb http://cn.archive.ubuntu.com/ubuntu breezy main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu breezy-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu breezy-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu warty main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu warty-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu warty-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu breezy main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu breezy-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu breezy-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn ubuntu.org.cn main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted
保存文本。
$:sudo apt-get update
$:sudo apt-get dist-upgrade

3。装好系统以后,输入默认是没有的。必须更新下载安装包。使用sudo apt-get命令下载输入法。
终端命令:
$:sudo apt-get install scim scim-gtk2-immodule scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh scim-input-pad
$:sudo sh -c " echo 'export XMODIFIERS=@im=SCIM ; export GTK_IM_MODULE="scim" ; scim -d ' > /etc/X11/Xsession.d/95xinput "
$:sudo chmod +755 /etc/X11/Xsession.d/95xinput
输入法安装好以后,注销系统,然后再登录,就可以使用CTRL+空格键切换输入法了。

4。挂载WINDOWS分区,使用相关命令mount挂载,使用umount命令卸载。
先卸载原先系统默认挂载的WIN分区,因为默认挂载存在错误,需要修改,但是在修改之前,必须先卸载。
卸载WIN分区的终端命令:
$:sudo umount /media/hda1
$:sudo umount /media/hda5
$:sudo umount /media/hda6
然后修改/etc/fstab文件,使用上面提到的sudo命令。
$:sudo gedit /etc/fstab
删除错误的挂载命令,也就是那个/dev/hda1,/dev/hda5/,/dev/hda6的3条命令。
添加如下正确的命令:
/dev/hda1 /media/hda1 ntfs utf8,umask=000 0 0
/dev/hda5 /media/hda5 ntfs utf8,umask=000 0 0
/dev/hda6 /media/hda6 vfat utf8,umask=000 0 0
保存这个文本。然后使用重新自动挂载命令来挂载我们新建立挂载。
$:sudo mount -a
成功挂载以后,我们可以看到桌面上已经有正确的挂载了,我们可以尝试进入这三个目录。^-^,可以了吧?

5。修改系统字体,使系统显示字体完美。我们需要WINDOWS下的商业字体。simsun.ttf和SimSun-Bold.ttf。
复制这两个字体到我们的字体文件夹里,使用CP命令。如下:
$:sudo cp /tmp/simsun.ttf /usr/share/fonts/truetype/freefont/
$:sudo cp /tmp/SimSun-Bold.ttf /usr/share/fonts/truetype/freefont/
然后使用 系统-首选项-字体 更改字体,关闭。
更改浏览器字体 编辑-首选项-字体 更改字体,关闭。
更本文件编辑器 编辑-首选项-字体 更改字体,关闭。
重起系统,再次登录,系统字体好看多了。

6。安装LumaQQ,到网站http://lumaqq.linuxsir.org/main/?q=node/231下载适合的QQ版本。我选择LumaQQ 2004T 初始安装包,带JER的,解压就能使用。
点击下载,然后使用tar zxvf命令解压缩文件,命令如下:
$:sudo tar zxvf lumaqq_2004t-linux_gtk2_x86_with_jre.tar.gz -C /opt/
$:sudo unzip -o lumaqq_2004t_patch_2005.09.05.23.00.zip -d /opt/LumaQQ/lib
$:sudo chown -R root:root /opt/LumaQQ/
$:sudo chmod -R 755 /opt/LumaQQ/
$:sudo gedit /usr/share/applications/LumaQQ.desktop
在新增的文件内加入下面这几行
[Desktop Entry]
Name=LumaQQ
Comment=QQ Client
Exec=/opt/LumaQQ/lumaqq
Icon=/opt/LumaQQ/QQ.png
Terminal=false
Type=Application
Categories=Application;Network;
保存编辑过的文件

7。更改刷新率,首先备份你的配置 xorg.conf:
$:sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
$:sudo gedit /etc/X11/xorg.conf
然后查找Section "Monitor",然后后把下面的几列改为如下:
Section "Monitor"
Identifier "Generic Monitor"
HorizSync 31-101
VertRefresh 60-160
EndSection
重起系统,就能使用85的刷新率了。

8。安装xine多媒体播放器,使用如下命令:
$:sudo apt-get install xine-ui
指定 xine-ui 播放多媒体文件
$:gconftool-2 --type string --set /desktop/gnome/volume_manager/autoplay_dvd_command "xine dvd://"
$:sudo rm -f /usr/share/applnk/Multimedia/xine.desktop
$:sudo ln -fs /usr/share/xine/desktop/xine.desktop /usr/share/applications/
$:sudo cp /usr/share/applications/defaults.list /usr/share/applications/defaults.list_backup
$:sudo sed -e 's/totem.desktop/xine.desktop/g' /usr/share/applications/defaults.list_backup > /tmp/defaults.list
$:sudo mv /tmp/defaults.list /usr/share/applications/defaults.list
安装多媒体解码/编码器
$:sudo apt-get install gstreamer0.8-plugins
$:sudo apt-get install gstreamer0.8-lame
$:sudo apt-get install gstreamer0.8-ffmpeg
$:sudo apt-get install w32codecs
$:sudo apt-get install libdivx4linux
$:sudo apt-get install lame
$:sudo apt-get install sox
$:sudo apt-get install ffmpeg
$:sudo apt-get install mjpegtools
$:sudo apt-get install vorbis-tools
$:gst-register-0.8

9。需要安装的几个必要的包以后,换张桌面壁纸吧,这样会更加好看!


附件:
文件注释: 网页字体
Screenshot-2.png
Screenshot-2.png [ 79.31 KiB | 被浏览 1365 次 ]

文件注释: LumaQQ
Screenshot-1.png
Screenshot-1.png [ 1008.43 KiB | 被浏览 1349 次 ]

文件注释: 终端下的字体
Screenshot.png
Screenshot.png [ 68.03 KiB | 被浏览 1307 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:10 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
应该写到你的blog。这里总结一下也不错。可以查点资料一样 :P


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:11 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
scim-gtk2-immodule 不要安装,据说会引起synaptic段错误


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:20 

注册: 2005-10-14 2:56
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
感谢eexpress老大提点,不过有个问题我搞不清楚
我用SCIM打字的时候老是中文模式会莫名其妙的变成英文模式,不知道怎么解决...


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:26 

注册: 2005-09-16 7:32
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
引用:
6。安装LumaQQ,到网站http://lumaqq.linuxsir.org/main/?q=node/231下载适合的QQ版本。我选择LumaQQ 2004T 初始安装包,带JER的,解压就能使用。
点击下载,然后使用tar zxvf命令解压缩文件,命令如下:
$:sudo tar zxvf lumaqq_2004t-linux_gtk2_x86_with_jre.tar.gz -C /opt/
$:sudo unzip -o lumaqq_2004t_patch_2005.09.05.23.00.zip -d /opt/LumaQQ/lib
$:sudo chown -R root:root /opt/LumaQQ/
$:sudo chmod -R 755 /opt/LumaQQ/
$:sudo gedit /usr/share/applications/LumaQQ.desktop
在新增的文件内加入下面这几行
[Desktop Entry]
Name=LumaQQ
Comment=QQ Client
Exec=/opt/LumaQQ/lumaqq
Icon=/opt/LumaQQ/QQ.png
Terminal=false
Type=Application
Categories=Application;Network;
保存编辑过的文件


用个Gaim的openq包,装完了apt-get install openq完事
多一种选择,各有所爱 :)


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:33 

注册: 2005-10-14 2:56
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
呵呵,感谢楼上的,不过希望你能帮我解决我上面说的问题,老是有输入法问题


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:38 

注册: 2005-09-16 7:32
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
哈哈,我用fcitx,你看看scim的配置文件


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-10-17 10:30 

注册: 2005-10-14 8:42
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
z5488 写道:
引用:
6。安装LumaQQ,到网站http://lumaqq.linuxsir.org/main/?q=node/231下载适合的QQ版本。我选择LumaQQ 2004T 初始安装包,带JER的,解压就能使用。
点击下载,然后使用tar zxvf命令解压缩文件,命令如下:
$:sudo tar zxvf lumaqq_2004t-linux_gtk2_x86_with_jre.tar.gz -C /opt/
$:sudo unzip -o lumaqq_2004t_patch_2005.09.05.23.00.zip -d /opt/LumaQQ/lib
$:sudo chown -R root:root /opt/LumaQQ/
$:sudo chmod -R 755 /opt/LumaQQ/
$:sudo gedit /usr/share/applications/LumaQQ.desktop
在新增的文件内加入下面这几行
[Desktop Entry]
Name=LumaQQ
Comment=QQ Client
Exec=/opt/LumaQQ/lumaqq
Icon=/opt/LumaQQ/QQ.png
Terminal=false
Type=Application
Categories=Application;Network;
保存编辑过的文件


用个Gaim的openq包,装完了apt-get install openq完事
多一种选择,各有所爱 :)


现在QQ上净是垃圾,到处都是广告,用了Openq,被那些过一会儿就跳出来认证的窗口烦死了,也不知道什么时候哪位高手改改,别在Openq里拒绝添加要点那么多下,好麻烦啊,搞得现在qq都不敢用


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-10-17 18:10 

注册: 2005-09-16 7:32
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
gaim好象有个隐私设置可以用的


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-10-17 21:17 

注册: 2005-08-11 15:10
帖子: 27
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
even1004 写道:
现在QQ上净是垃圾,到处都是广告,用了Openq,被那些过一会儿就跳出来认证的窗口烦死了,也不知道什么时候哪位高手改改,别在Openq里拒绝添加要点那么多下,好麻烦啊,搞得现在qq都不敢用


Openq和Gaim1.2.0配合使用最好,如果gaim版本过高的话,比如是1.5.0版,Openq会比较经常地死掉。不过我使用openq的时候就不再有弹出广告了。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-10-17 22:26 
头像

注册: 2005-09-11 14:08
帖子: 188
地址: N朝古都
送出感谢: 0 次
接收感谢: 0 次
yongyi 写道:
scim-gtk2-immodule 不要安装,据说会引起synaptic段错误

好象是,我把这个remove后就好了。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-10-18 21:28 
头像

注册: 2005-10-13 11:29
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
这个源能装scim-fcitx吗?
谢谢


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-10-24 11:09 

注册: 2005-10-23 21:02
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
这么多热心人 看来我要好好努力了呀。加油,不过晚上还是考试第一,呵呵。


_________________
tomorrow is another day!
向帮我们打开linux大门的无私的软件编辑者,帮助提供者们表示最大的尊敬!!
tinysheep.blog.sohu.com


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-10-24 11:26 

注册: 2005-08-23 11:19
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
不错
收藏了


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-10-24 12:35 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
mnday
SimSun-Bold.ttf 字体从哪儿搞来的?


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译