为何每次升级内核,系统都无法进入x?

为当前最终发行版之前的所有版本提供支持
回复
头像
akilq
帖子: 328
注册时间: 2007-02-03 21:40
来自: 花花世界
送出感谢: 0
接收感谢: 1 次

为何每次升级内核,系统都无法进入x?

#1

帖子 akilq » 2007-03-02 11:23

每次系统提示有重要更新,更新后都无法进入X-windows,不然就出现很多小问题(譬如哪个软件不兼容了)!重点是每次都不能进系统很烦人,既然存在问题,不明白为何要用户更新?有没有好的解决办法?这是唯一一点让我对linux感到头疼的地方,用了3个月,没有一次成功升级!几乎升级后都要重新装ubuntu!
sakses
帖子: 168
注册时间: 2006-12-26 16:38
送出感谢: 0
接收感谢: 0

#2

帖子 sakses » 2007-03-02 11:35

是不是nvidia的卡?

如果你安装nvidia官方的驱动,则每次升级内核都要重新安装驱动。
Ubuntu 9.10 (Karmic Koala)
头像
akilq
帖子: 328
注册时间: 2007-02-03 21:40
来自: 花花世界
送出感谢: 0
接收感谢: 1 次

#3

帖子 akilq » 2007-03-02 11:42

sakses 写了:是不是nvidia的卡?

如果你安装nvidia官方的驱动,则每次升级内核都要重新安装驱动。


我用envy安装的nvidia的驱动,所以今天尝试进envy卸载,再重新安装,还是不成功!能不能指点一下,怎样安装?
sakses
帖子: 168
注册时间: 2006-12-26 16:38
送出感谢: 0
接收感谢: 0

#4

帖子 sakses » 2007-03-02 12:17

envy不适驱动程序,envy是用来安装官方驱动的脚本。

你卸载envy是没有用的,升级以后要再次运行envy一次,用envy卸载nvidia驱动,然后再重新安装一次nvidia驱动,就可以了。
Ubuntu 9.10 (Karmic Koala)
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2007-03-02 12:22

如果不知道怎么解决,请不要安装第三方的显卡驱动(包括nvidia自己的官方驱动),请使用源里面的驱动.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
akilq
帖子: 328
注册时间: 2007-02-03 21:40
来自: 花花世界
送出感谢: 0
接收感谢: 1 次

#6

帖子 akilq » 2007-03-02 12:26

sakses 写了:envy不适驱动程序,envy是用来安装官方驱动的脚本。

你卸载envy是没有用的,升级以后要再次运行envy一次,用envy卸载nvidia驱动,然后再重新安装一次nvidia驱动,就可以了。


haha,可能我的意思表达不清楚,我就是用envy卸载的驱动,可是还是进入不了系统,开机选择时,出现2个内核,如果在新内核的安全模式下卸载驱动,那么老内核也无法启动,真不知道怎么搞的!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2007-03-02 12:28

显卡驱动会被编译成内核模块,只要内核升级,就要重新编译成新内核的模块,你自己安装的显卡驱动不会有这样的过程,当然就启动不了X了.
而ubuntu官方的驱动就会在升级内核的时候也会升级相应的内核模块.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
akilq
帖子: 328
注册时间: 2007-02-03 21:40
来自: 花花世界
送出感谢: 0
接收感谢: 1 次

#8

帖子 akilq » 2007-03-02 18:04

karron 写了:显卡驱动会被编译成内核模块,只要内核升级,就要重新编译成新内核的模块,你自己安装的显卡驱动不会有这样的过程,当然就启动不了X了.
而ubuntu官方的驱动就会在升级内核的时候也会升级相应的内核模块.


能不能给一个更好的安装显卡方案?因为我把论坛里所有的安装方法都试过了,只有envy可以安装,别的安装方法都有关联性的错误,所以没法安装!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2007-03-02 18:42

最好的就是使用源的glx驱动。喜欢升级。呵呵。还没明白编译的意思哦。
● 鸣学
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 BigSnake.NET » 2007-03-02 18:51

akilq 写了:
karron 写了:显卡驱动会被编译成内核模块,只要内核升级,就要重新编译成新内核的模块,你自己安装的显卡驱动不会有这样的过程,当然就启动不了X了.
而ubuntu官方的驱动就会在升级内核的时候也会升级相应的内核模块.


能不能给一个更好的安装显卡方案?因为我把论坛里所有的安装方法都试过了,只有envy可以安装,别的安装方法都有关联性的错误,所以没法安装!

使用aptitude,谨记任何操作都要明白自己在做什么
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
thankwsx
帖子: 132
注册时间: 2006-02-28 20:26
来自: 江苏淮安周恩来故居
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 thankwsx » 2007-04-05 11:33

我也想各位大侠在写代码段时,后面加一行注释告诉我们这是在干什么。。。
头像
adqin
帖子: 1417
注册时间: 2007-01-24 22:07
来自: http://adqin.cn
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 adqin » 2007-04-05 12:48

NV的驱动还是很好装的了。
6.06的直接用源里的glx。
6.10和7.04需要自己下载NV for Linux的驱动,自己安装。
只要没有开启beryl,是不需每次升级后都重装驱动的。
而且开启beryl后,也只是内核升级后才需要重装驱动。

6.06的驱动安装方法论坛搜搜。6.10及7.04的可以参见这里:
http://forum.ubuntu.org.cn/weblog_entry.php?e=2968

另外注意一点的就是要有备份重要配置文件的习惯。
备份x配置文件:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.bak
崩溃后恢复:
sudo cp /etc/X11/xorg.bak /etc/X11/xorg.conf
回复

回到 “老旧版本支持”