安装不上mplayer,具体情况如下,请大侠帮忙!

为当前最终发行版之前的所有版本提供支持
回复
ediny
帖子: 14
注册时间: 2007-03-07 9:59
送出感谢: 0
接收感谢: 0

安装不上mplayer,具体情况如下,请大侠帮忙!

#1

帖子 ediny » 2007-03-07 21:43

ediny@ediny-desktop:/tmp/sp-sc$ sudo apt-get install mplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer: 依赖: libdirectfb-0.9-22 但却无法安装它
E: 无法安装的软件包

上面就是安装时给出的提示,请大侠帮忙看看啊!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-03-07 21:46

用aptitude install xxxx安装,看提示什么。
● 鸣学
ediny
帖子: 14
注册时间: 2007-03-07 9:59
送出感谢: 0
接收感谢: 0

#3

帖子 ediny » 2007-03-07 21:50

这叫装上了吗?
ediny@ediny-desktop:/tmp/sp-sc$ sudo aptitude install mplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列软件包是“破损”的:
mplayer
下列软件包将被自动安装:
libconfhelper-perl libdivxdecore0 libdivxencore0 libfaac0 libggi-target-x libggi2 libgii1
libgii1-target-x libgtk1.2 libgtk1.2-common liblame0 liblogfile-rotate-perl libmikmod2
libmp4v2-0 libsvga1 libxvidcore4 xmms
下列软件包已经被阻止升级:
hpijs python-adns python-clientcookie python-crypto python-egenix-mxproxy
python-egenix-mxstack python-egenix-mxtexttools python-egenix-mxtools python-gadfly
python-htmlgen python-htmltmpl python-imaging python-imaging-sane python-jabber
python-kjbuckets python-ldap python-mysqldb python-pam python-pexpect python-pgsql
python-pylibacl python-pyopenssl python-pyxattr python-reportlab python-simpletal
python-soappy python-sqlite python-syck python-xmpp ubuntu-minimal wpasupplicant
下列“新”软件包将被安装。
libconfhelper-perl libdivxdecore0 libdivxencore0 libfaac0 libggi-target-x libggi2 libgii1
libgii1-target-x libgtk1.2 libgtk1.2-common liblame0 liblogfile-rotate-perl libmikmod2
libmp4v2-0 libsvga1 libxvidcore4 xmms
0 个软件包被升级,新安装18 个, 0 个将被删除, 同时 31 个将不升级。
需要获取 12.4MB 的存档。 解包后将要使用 39.0MB。
下列软件包存在未满足的依赖关系:
mplayer: 依赖: libdirectfb-0.9-22 这是一个虚拟软件包。
Resolving dependencies...
下列动作将解决这些依赖关系:

保持 下列软件包于其当前版本:
mplayer [未安装的]

分数是 -1

是否接受该解决方案?[Y/n/q/?] y
下列软件包已经被阻止升级:
hpijs python-adns python-clientcookie python-crypto python-egenix-mxproxy
python-egenix-mxstack python-egenix-mxtexttools python-egenix-mxtools python-gadfly
python-htmlgen python-htmltmpl python-imaging python-imaging-sane python-jabber
python-kjbuckets python-ldap python-mysqldb python-pam python-pexpect python-pgsql
python-pylibacl python-pyopenssl python-pyxattr python-reportlab python-simpletal
python-soappy python-sqlite python-syck python-xmpp ubuntu-minimal wpasupplicant
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 31 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
您要继续吗?[Y/n/?] y
正在编辑扩展状态信息... 完成
ediny
帖子: 14
注册时间: 2007-03-07 9:59
送出感谢: 0
接收感谢: 0

#4

帖子 ediny » 2007-03-07 21:50

没有装上吧!
ediny
帖子: 14
注册时间: 2007-03-07 9:59
送出感谢: 0
接收感谢: 0

#5

帖子 ediny » 2007-03-07 22:25

大侠们,帮个忙啊!!!怎么就是装不上啊!
gegfried
帖子: 482
注册时间: 2006-06-29 17:30
送出感谢: 0
接收感谢: 0

#6

帖子 gegfried » 2007-03-07 23:17

更改源,系统升级,再安装mplayer
ediny
帖子: 14
注册时间: 2007-03-07 9:59
送出感谢: 0
接收感谢: 0

#7

帖子 ediny » 2007-03-08 12:50

呵呵,昨天晚上换源后就装上了,谢谢了。。。
suddenst
帖子: 48
注册时间: 2007-08-13 9:42
送出感谢: 0
接收感谢: 0

#8

帖子 suddenst » 2008-02-20 11:07

楼主换的是哪个源?
回复

回到 “老旧版本支持”