如何卸载2.6.20.1

为当前最终发行版之前的所有版本提供支持
回复
头像
cs160
帖子: 62
注册时间: 2006-12-02 13:33
送出感谢: 0
接收感谢: 0

如何卸载2.6.20.1

#1

帖子 cs160 » 2007-03-08 20:45

我已升级内核到2.6.20.1,
现在要卸载,请问如何进行?
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#2

帖子 dogfox » 2007-03-08 21:01

代码: 全选

sudo apt-get remove linux-
tab键,官方内核

代码: 全选

sudo apt-get remove kenerl-
tab键,自己编译的内核
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
ibearz
帖子: 80
注册时间: 2007-03-03 15:50
送出感谢: 0
接收感谢: 0

#3

帖子 ibearz » 2007-03-08 22:47

好新的内核

首先先把你的内核降回去,修改sudo vi /boot/grub/meus.list文件,不要使用你想卸载的内核

然后重启

重起后查找要卸载的包,你问这个问题估计你的内核和不可能是变异的了

sudo dpkg -l | grep 2.6.20.1

然后出现你要写在的包

再 sudo dpkg -P 你要的包就可以了。
头像
cs160
帖子: 62
注册时间: 2006-12-02 13:33
送出感谢: 0
接收感谢: 0

#4

帖子 cs160 » 2007-03-18 14:32

谢解LS,问题已解决,不过您最后的命令应该是sudo dpkg -r ****
qianghr
帖子: 67
注册时间: 2007-03-09 14:23
送出感谢: 0
接收感谢: 0

#5

帖子 qianghr » 2007-03-21 16:34

-p是彻底删除
回复

回到 “老旧版本支持”