编译程序报找不到某个需要的程序,可以我已经安装了那个需要的程序

为当前最终发行版之前的所有版本提供支持
回复
andrew.luo
帖子: 3
注册时间: 2007-03-01 21:08
送出感谢: 0
接收感谢: 0

编译程序报找不到某个需要的程序,可以我已经安装了那个需要的程序

#1

帖子 andrew.luo » 2007-03-09 1:12

我在Ubuntu6.10上试图安装dsniff-2.3,该程序需要一些其他程序库支持,其中就有Berkeley DB 1.85。
我在源码目录里执行./configure时,提示我:
checking for Berkeley DB with 1.85 compatibility... configure: error: Berkeley DB with 1.85 compatibility not found
因此,我在该产品网站下载了最新版本的Berkeley DB 4.5,并且通过编译正确安装了。
但是,我再次试图执行dsniff-2.3源码目录里的./configure时,还是报上面的错误。

请告诉我,需要怎样做才能正确识别出已安装的Berkeley DB,并通过编译。
谢谢!
回复

回到 “老旧版本支持”