[问题]ubuntu6.10默认安装的是vi还是vim啊?

为当前最终发行版之前的所有版本提供支持
回复
头像
wq86731
帖子: 92
注册时间: 2006-12-21 9:41
送出感谢: 0
接收感谢: 0

[问题]ubuntu6.10默认安装的是vi还是vim啊?

#1

帖子 wq86731 » 2007-03-09 12:28

6.10默认到底有没有安装vim?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-03-09 12:34

vim-tiny,不算
安装vim-gnome就有了。
● 鸣学
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2007-03-09 12:35

是不是默认安装很重要吗?
ubuntu似乎默认安装了 vim-tiny ,一个功能最简单的vim.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
wq86731
帖子: 92
注册时间: 2006-12-21 9:41
送出感谢: 0
接收感谢: 0

#4

帖子 wq86731 » 2007-03-09 12:38

请问怎么在写代码的时候实现语法高亮和缩进阿?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2007-03-09 12:49

sudo apt-get install vim-gtk
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
neomi
帖子: 137
注册时间: 2006-08-11 13:03
送出感谢: 0
接收感谢: 0

#6

帖子 neomi » 2007-03-09 12:52

:syntax enable

:set ai!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2007-03-09 12:53

默认安装的vim-tiny是没有语法高亮的功能的.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
wq86731
帖子: 92
注册时间: 2006-12-21 9:41
送出感谢: 0
接收感谢: 0

#8

帖子 wq86731 » 2007-03-09 13:06

是不是一定要安装了完整的vim才行阿?
头像
yang_hui1986527
帖子: 888
注册时间: 2006-03-04 23:10
来自: 江西高安
送出感谢: 0
接收感谢: 2 次
联系:

Re:

#9

帖子 yang_hui1986527 » 2009-07-13 11:25

neomi 写了::syntax enable

:set ai!
不错,谢谢分享!
QQ:273247606
EMAIL:yanghui1986527@gmail.com
回复

回到 “老旧版本支持”