7.04 fcitx中英文切换的问题好像已经解决了

为当前最终发行版之前的所有版本提供支持
回复
owwbu
帖子: 614
注册时间: 2006-11-15 14:14
送出感谢: 0
接收感谢: 1 次

7.04 fcitx中英文切换的问题好像已经解决了

#1

帖子 owwbu » 2007-03-09 23:37

ctrl+space不会关闭当前程序了。
jay
帖子: 52
注册时间: 2006-01-17 6:53
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 jay » 2007-03-10 1:31

你刚升级的吗?
f0rrest
帖子: 133
注册时间: 2006-09-27 20:49
送出感谢: 0
接收感谢: 4 次

#3

帖子 f0rrest » 2007-03-10 5:54

看libxcb的changelog:
+ [ Timo Aaltonen ]
+ * debian/patches:
+ - 100_allow_sloppy_lock.diff from Novell, workaround to the various
+ 'Assertion `c->xlib.lock' failed"' -bugs by setting an environment
+ variable LIBXCB_ALLOW_SLOPPY_LOCK to any value and the check will
+ simply be ignored.
+ * debian/{control,rules}:
+ - add quilt to Build-deps, and patchsys-quilt.mk to rules.
+ - change Maintainer address.
+
+ [ Martin Pitt ]
+ * 100_allow_sloppy_lock.diff: Reverse the patch logic for Feisty: Use
+ sloppy locking by default for now, because we won't have time to discover
+ and fix all broken apps. Setting LIBXCB_NO_SLOPPY_LOCK will enable the
+ strict behaviour. This should be dropped right at the opening of
+ Feisty+1.


大概意思是说:既然Feisty的发行日期不变,Feisty又选定了libxcb,现在已经没有时间来解决各种程序的“c->xlib.lock”问题,于是想出一个hack的方法:设置一个环境变量LIBXCB_NO_SLOPPY_LOCK来跳过这个assert(既然能条过,为什么当初设计的时候还要assert?)

不知道是不是我选择的源有问题,我在升级后没有任何变化(fcitx还是崩溃),把源代码下载来看,补丁是在里面,但编译的时候并没打上去。我自己打补丁编译安装后,发现所有的X程序都无法启动,想来是因为这个补丁改了libxcb里的一个头文件,而其他X应用是连接到原来的libxcb上的,导致二进制兼容问题。干脆直接把那两条assert语句去掉,现在一切正常,fcitx也能用了。

Feisty四月份发行,二月份却来升级X这样的基础库,真不知道他们怎么想的!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2007-03-10 10:05

昨天升级之后已经可以用了,我昨天看见升级了xcb的包,就感觉可能有戏了,果然.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
skiwi
帖子: 146
注册时间: 2006-07-16 12:24
送出感谢: 0
接收感谢: 0

#5

帖子 skiwi » 2007-03-10 19:04

确实可以了哈哈
sjn3
帖子: 81
注册时间: 2006-08-14 19:46
送出感谢: 0
接收感谢: 0

#6

帖子 sjn3 » 2007-03-10 21:14

我怎么没更新到。我用的是C99的源,但在软件源5 个勾里应勾哪几个,现在我都是空的
sanzhiyangoo
帖子: 94
注册时间: 2006-12-04 9:37
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 sanzhiyangoo » 2007-03-11 21:15

karron 写了:昨天升级之后已经可以用了,我昨天看见升级了xcb的包,就感觉可能有戏了,果然.




是的,我升级完后,可以拉。
用的是cn99,和官方的源。
顶起,让根多的人看到阿
faircloth
帖子: 29
注册时间: 2006-10-29 19:21
送出感谢: 0
接收感谢: 0

我的是MATLAB出那个问题了????

#8

帖子 faircloth » 2007-03-13 19:18

用了

代码: 全选

 export  LIBXCB_NO_SLOPPY_LOCK 

但是还是没有用!
help??
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 karron » 2007-03-13 19:39

直接升级就行了,不需要设置。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”