[问题]alien安装问题(已经解决~~)~

为当前最终发行版之前的所有版本提供支持
回复
raymond.chen
帖子: 9
注册时间: 2007-01-19 21:59
送出感谢: 0
接收感谢: 0

[问题]alien安装问题(已经解决~~)~

#1

帖子 raymond.chen » 2007-03-10 14:28

本来想装一个alien学学如何做deb的包,结果发现下面的问题
////////////////////////////
raymond@raymond-Ubuntu:~$ sudo apt-get install alien
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
alien: 依赖: debhelper (>= 3) 但是它将不会被安装
E: 无法安装的软件包
raymond@raymond-Ubuntu:~$ sudo apt-get install debhelper
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
The following packages were automatically installed and are no longer required:
python-gst0.10 update-manager openoffice.org-writer python-gnome2
python-support nautilus python-apport-utils python-gnome2-extras
python-gnomecanvas hwdb-client-gnome gdebi alacarte python-libxml2 gedit
gnome-menus python-numeric gnome-control-center hplip python-apt
python-virtkey python-gconf update-notifier apport gnome-terminal
python-gtkhtml2 gnome-btdownload gnome-orca nautilus-cd-burner python-glade2
python-uno python-xdg python-vte unattended-upgrades language-selector
gnome-doc-utils python-xml openoffice.org python-central python-dbus
python-gnupginterface hal-device-manager onboard gnome-applets python-gmenu
gnome-panel deskbar-applet python-gnome2-desktop openoffice.org-help-en-us
apport-gtk gnome-session python-gtk2 python-cairo gimp-python serpentine
python-gobject
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
debconf-utils dpkg-dev html2text
建议安装的软件包:
dh-make debian-keyring
下列软件包将被【卸载】:
alacarte apport apport-gtk deskbar-applet gdebi gedit gimp-python
gnome-applets gnome-btdownload gnome-control-center gnome-doc-utils
gnome-menus gnome-orca gnome-panel gnome-session gnome-terminal
hal-device-manager hplip hwdb-client-gnome language-selector nautilus
nautilus-cd-burner onboard openoffice.org openoffice.org-help-en-us
openoffice.org-writer python-apport-utils python-apt python-cairo
python-central python-dbus python-gconf python-glade2 python-gmenu
python-gnome2 python-gnome2-desktop python-gnome2-extras python-gnomecanvas
python-gnupginterface python-gobject python-gst0.10 python-gtk2
python-gtkhtml2 python-libxml2 python-numeric python-support python-uno
python-virtkey python-vte python-xdg python-xml serpentine
unattended-upgrades update-manager update-notifier
下列【新】软件包将被安装:
debconf-utils debhelper dpkg-dev html2text
共升级了 0 个软件包,新安装了 4 个软件包,要卸载 55 个软件包,有 3 个软件未被升级。
需要下载 795kB 的软件包。
解压缩后将会空出 93.5MB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。
raymond@raymond-Ubuntu:~$
////////////////////////////////

为什么安装一个这个要卸载这么多的包 阿,其中还有好多有用的包,比如terminal之类的~~

谁能帮我阿~~~


~~~~~~~~~~~~~~~~~~~~

搞清楚为什么了~~
原来我源用错了~我用了DAPPER的源。。。。哎

哎,以后大家要注意阿
6.10要用edgy的~~~
archer1129
帖子: 1
注册时间: 2007-06-10 9:48
送出感谢: 0
接收感谢: 0

同样问题

#2

帖子 archer1129 » 2007-06-27 12:16

raymond.chen
楼主,我也遇到你 同样的问题,你 能 给我 说说你是怎么解决的吗?
我 的是7.04的
回复

回到 “老旧版本支持”