[问题]小区网(LAN)撤掉路由器后的怪异问题

为当前最终发行版之前的所有版本提供支持
回复
头像
星际流火
帖子: 39
注册时间: 2006-12-15 13:23
来自: 广东茂名
送出感谢: 0
接收感谢: 0

[问题]小区网(LAN)撤掉路由器后的怪异问题

#1

帖子 星际流火 » 2007-03-11 23:05

我原来用的是电信的ADSL,开了路由器,win2003 +winxp(V64)双系统。后来下了ubuntu 6.10 (AMD64),就格了winxp64,装了ubuntu。后来学校转网,把我们的asdl转成了小区网(固定帐号和密码的),也是相安无事。前几天,路由器拆了,
win2003正常,ubuntu却让我抓狂。先是ubuntu下无法上网,ping不通!本人是linux的菜鸟,用了论坛和网上的方法,sudo pppoeconf ,重起网络等,都不行。折腾了一番,启动时出来一个框(5分钟才显示),提示gnome守护进程出错,才能进x
windows. ghost 好几次,还搞不定。一怒之下,重装ubuntu,故障一样。找遍了google,用live cd 生成的interfaces 覆盖,启动时可顺利进入了。可还不能上网。现在的办法是:重启或关机前删掉interfaces,进入ubuntu后用备份的考进去,sudo /etc/init.d/networking restart ,sudo pon dsl-provider可上网了。实验结果是:重启或关机前不删掉interfaces,下次就别上网。纳闷中。ubuntu,想说爱你是多么的不容易!??
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zmcbb30 » 2007-03-11 23:17

什么样的小区网?还是校园网?

我记得应该是有动态ip和静态ip之分的,是否要设一下?
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
头像
星际流火
帖子: 39
注册时间: 2006-12-15 13:23
来自: 广东茂名
送出感谢: 0
接收感谢: 0

#3

帖子 星际流火 » 2007-03-11 23:30

小区网是学校和电信和搞的,网上查ip的站点显示:218.15.22.136;拨号后分配的是:192.168.3.120,同网段用lansee查不到其他机子,ubuntu下自动获取的DNS为:202.103.176.22 , 210.38.240.33 。动态ip和静态ip都试了,无效。
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 SuperWar3Fan » 2007-03-12 10:51

修改一下/etc/dhcp3/dhcpclient.conf文件,
把含有pre字段的行的注释去掉,加入你的DNS地址,尝试一下!
有空的话,请访问我的BlogUbuntu高地
头像
星际流火
帖子: 39
注册时间: 2006-12-15 13:23
来自: 广东茂名
送出感谢: 0
接收感谢: 0

#5

帖子 星际流火 » 2007-03-12 15:31

没有dhcpclient.conf,只有 dhclient.conf。能把你的dhcpclient.conf内容贴出来吗?
头像
星际流火
帖子: 39
注册时间: 2006-12-15 13:23
来自: 广东茂名
送出感谢: 0
接收感谢: 0

#6

帖子 星际流火 » 2007-03-13 14:38

问题未解决,顶上去。
回复

回到 “老旧版本支持”